Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 48

Thread: Nvidia Proprietary drivers on Wayland

  1. #11

    Default AW: Nvidia Proprietary drivers on Wayland

    Ah well, quoting from https://en.wikipedia.org/wiki/Waylan...rver_protocol):
    Desktop environments

    Desktop environments in process of being ported from X to Wayland include GNOME,[95] KDE Plasma 5[96] and Enlightenment.[97]

    In November 2015, Enlightenment e20 was announced with full Wayland support.[98][48][99]

    GNOME 3.20 was the first version to have a full Wayland session.[100] GNOME 3.22 included much improved Wayland support across GTK, Mutter, and GNOME Shell.[101] GNOME 3.24 shipped support for the proprietary NVidia drivers under Wayland.[102]


    Wayland support for KDE Plasma was delayed until the release of Plasma 5,[103] though previously KWin 4.11 got an experimental Wayland support.[104] The version 5.4 of Plasma was the first with a Wayland session.[105]
    As Leap 15.2 ships with GNOME 3.34, it should indeed work with the proprietary nvidia driver as well (if installed properly).
    Last edited by wolfi323; 02-Jul-2020 at 05:04.

  2. #12

    Default Re: Nvidia Proprietary drivers on Wayland

    And for KDE Plasma/kwin's nvidia support, see e.g.:
    https://www.phoronix.com/scan.php?pa...rged-KWin-5.16

    It's available since version 5.16, Leap 15.2 ships with 5.18.

    I forgot to mention (but it is written in that article), to activate NVidia support in kwin, you'd need to set this environment variable:
    Code:
    KWIN_DRM_USE_EGL_STREAMS=1
    The easiest way to do it is probably to add this line to /etc/environment, or add a file /etc/profile.d/kwin.sh (the actual name doesn't matter) with that line.

  3. #13
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    281

    Default Re: Nvidia Proprietary drivers on Wayland

    Quote Originally Posted by wolfi323 View Post
    But why don't you rather use the available packages from the repo?
    I first installed the drivers from the repo, they do install but in Gnome Wayland doesn't work ofc. So I get a terminal instead of GUI. When I disable Wayland in the /etc/gdm/custom.conf I just get a black login screen with a mouse pointer and that's it. I have a GTX1080 and I was doing everything on 15.1 with it. Including top gaming titles.

  4. #14
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    281

    Default Re: Nvidia Proprietary drivers on Wayland

    As Leap 15.2 ships with GNOME 3.34, it should indeed work with the proprietary nvidia driver as well (if installed properly).
    You are the first to say NVidia should work with Wayland. At least, so far I read it doesn't work. I did install the NVidia drivers through their repo on 15.2, just one day too soon. Perhaps now there is an update. I'll post the error when I try again.

  5. #15

    Default Re: Nvidia Proprietary drivers on Wayland

    Quote Originally Posted by Ricochet View Post
    I first installed the drivers from the repo, they do install but in Gnome Wayland doesn't work ofc. So I get a terminal instead of GUI. When I disable Wayland in the /etc/gdm/custom.conf I just get a black login screen with a mouse pointer and that's it.
    I guess you should make sure that the nvidia driver works at all (with X11) before you go on about Wayland.

    The Xorg log should have a clue.
    IIRC, it will be in ~/.local/share/xorg/Xorg.log when using gdm.

    You could also switch to a different display manager/login screen for now, until the nvidia driver is installed and working (gdm and sddm use OpenGL which can be broken if the nvidia driver is not installed correctly).

    I'd suggest xdm as a start, that should be installed by default, and is so simple that there are high chances that it will work even if there are driver problems. Makes investigating easier...
    In particular, it could be a permission problem. GDM runs the X server as unprivilileged user, while others (including xdm) run it as root.
    The user might have not enough permissions to access the hardware, which can happen especially with the nvidia driver (because it cannot use the standard methods to gain access due to its proprietary nature).

    To switch, run:
    Code:
    sudo update-alternatives --config default-displaymanager
    I have a GTX1080 and I was doing everything on 15.1 with it. Including top gaming titles.
    And what login screen/desktop environment did you use then?

    Quote Originally Posted by Ricochet View Post
    You are the first to say NVidia should work with Wayland. At least, so far I read it doesn't work.
    I provided links...

    I did install the NVidia drivers through their repo on 15.2, just one day too soon. Perhaps now there is an update.
    I don't see why the repo's driver wouldn't work just because you installed it "one day too soon"...
    Did you get an error when trying to install it, or did it succeed and just not work?

    Could be that there was indeed an update necessary because of a problem, no idea, I don't use nvidia (and I haven't even upgraded to 15.2 yet anyway).

    I'll post the error when I try again.
    That would be a good idea.
    Last edited by wolfi323; 02-Jul-2020 at 07:05.

  6. #16

    Default Re: Nvidia Proprietary drivers on Wayland

    Quote Originally Posted by wolfi323 View Post
    The Xorg log should have a clue.
    IIRC, it will be in ~/.local/share/xorg/Xorg.log when using gdm.
    Although, I'm not sure where exactly the log for gdm will be...
    Maybe /var/lib/gdm/.local/share/xorg/Xorg.log ?

    You could also switch to a different display manager/login screen for now, until the nvidia driver is installed and working (gdm and sddm use OpenGL which can be broken if the nvidia driver is not installed correctly).
    In that case, the log will be located in /var/log/Xorg.0.log.

    Alternatively, you could also login to text mode as root, and run "startx".
    That would print the log to the (text mode) console.

  7. #17

    Default AW: Nvidia Proprietary drivers on Wayland

    FYI, I found a blog post (from a KDE/Plasma developer) about how to get Plasma/Wayland running with the proprietary nvidia driver:
    http://blog.davidedmundson.co.uk/blo...and-on-nvidia/

    It mentions that modesetting support in the nvidia driver needs to be enabled.
    This can be done e.g. by adding "nvidia-drm.modeset=1" to the kernel parameters (or creating a file in /etc/modeprobe.d/ with the content "options nvidia-drm modeset=1").

    I don't know if that also applies to GNOME on Wayland, though it's probably worth a try in case it doesn't work out of the box.

    Btw, as a side-effect this will also make plymouth's boot splash work in graphics mode when the nvidia driver is installed...

  8. #18
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    281

    Default Re: Nvidia Proprietary drivers on Wayland

    Ok doing this step by step now. I installed the NVidia G05 driver (which is for the GTX1080). As I understand it, Wayland should still load but perhaps without NVidia? I installed from the repo with no errors. I reboot the machine, and now don’t see the Leap load screen. When I press ESC I see in the top left ^[ and a blinking cursor. After a while I see a flash of text all over the screen and the machine now does nothing.

    Now I do curl+alt+F1 and I get my login prompt.

    I now type update-alternative default-displaymanager and I now see more options than when I type this in Wayland from a terminal. 0 to 5 where 0 is gdm auto mode. 1 is a console, don’t want that. I choose 2 which is also gdm (just to try) and reboot the machine. Same thing happens. Now I turn of Wayland from the /etc/gdm/custom.conf file and now when I reboot I just get a prompt.

    I again type update-alternative default-displaymanager and I choose 3, lightdm and I reboot. The same thing happens.

    I type journalctl -b and I see in between all the other lines:

    Code:
    systemd-udev: modprobe: ERROR: could not insert ‘nvidia’: Operation not permitted.
    startproc: exit status of parent of /user/sbin/lightdm: 1
    displaymanager: Starting service lightdm.failed
    Failed to start X Display Manager.
    Starting Terminate Plymouth Boot Screen...
    Again I do update-alternative default-displaymanager and now I choose option 4, xdm and I reboot.

    Now I get the login prompt again and the last line of the boot process says: OK Started X Display Manager
    Yes, I’m on a console log in.

    When I type starts I get:

    Code:
    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error
    journalctl -b now gives none of the errors as in the previous try.

    The /var/log/Xorg.o.log shows:

    Code:
    [    91.010] (II) LoadModule: "glx"
    [    91.010] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    91.010] (II) Module glx: vendor="X.Org Foundation"
    [    91.010]   compiled for 1.20.3, module version = 1.0.0
    [    91.010]   ABI class: X.Org Server Extension, version 10.0
    [    91.010] (II) Scanning /etc/X11/xorg_pci_ids directory for additional PCI ID's supported by the drivers
    [    91.010] (II) Scanning /etc/X11/xorg_pci_ids directory for additional PCI ID's supported by the drivers
    [    91.010] (==) Matched intel as autoconfigured driver 0
    [    91.010] (==) Matched nvidia as autoconfigured driver 1
    [    91.010] (==) Matched nouveau as autoconfigured driver 2
    [    91.010] (==) Matched nv as autoconfigured driver 3
    [    91.010] (==) Matched modesetting as autoconfigured driver 4
    [    91.010] (==) Matched fbdev as autoconfigured driver 5
    [    91.010] (==) Matched vesa as autoconfigured driver 6
    [    91.010] (==) Assigned the driver to the xf86ConfigLayout
    [    91.010] (II) LoadModule: "intel"
    [    91.010] (WW) Warning, couldn't open module intel
    [    91.010] (EE) Failed to load module "intel" (module does not exist, 0)
    [    91.010] (II) LoadModule: "nvidia"
    [    91.010] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
    [    91.011] (II) Module nvidia: vendor="NVIDIA Corporation"
    [    91.011]   compiled for 1.6.99.901, module version = 1.0.0
    [    91.011]   Module class: X.Org Video Driver
    [    91.011] (II) LoadModule: "nouveau"
    [    91.011] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
    [    91.011] (II) Module nouveau: vendor="X.Org Foundation"
    [    91.011]   compiled for 1.20.3, module version = 1.0.15
    [    91.011]   Module class: X.Org Video Driver
    [    91.011]   ABI class: X.Org Video Driver, version 24.0
    [    91.011] (II) LoadModule: "nv"
    [    91.011] (WW) Warning, couldn't open module nv
    [    91.011] (EE) Failed to load module "nv" (module does not exist, 0)
    [    91.011] (II) LoadModule: "modesetting"
    [    91.011] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    [    91.011] (II) Module modesetting: vendor="X.Org Foundation"
    [    91.011]   compiled for 1.20.3, module version = 1.20.3
    [    91.011]   Module class: X.Org Video Driver
    [    91.011]   ABI class: X.Org Video Driver, version 24.0
    [    91.011] (II) LoadModule: "fbdev"
    [    91.011] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [    91.011] (II) Module fbdev: vendor="X.Org Foundation"
    [    91.011]   compiled for 1.20.3, module version = 0.5.0
    [    91.011]   Module class: X.Org Video Driver
    [    91.011]   ABI class: X.Org Video Driver, version 24.0
    [    91.011] (II) LoadModule: "vesa"
    [    91.011] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [    91.011] (II) Module vesa: vendor="X.Org Foundation"
    [    91.011]   compiled for 1.20.3, module version = 2.4.0
    [    91.011]   Module class: X.Org Video Driver
    [    91.011]   ABI class: X.Org Video Driver, version 24.0
    [    91.011] (II) NVIDIA dlloader X Driver  440.100  Fri May 29 08:21:27 UTC 2020
    [    91.011] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [    91.011] (II) NOUVEAU driver 
    [    91.011] (II) NOUVEAU driver for NVIDIA chipset families :
    [    91.011]   RIVA TNT        (NV04)
    [    91.011]   RIVA TNT2       (NV05)
    [    91.011]   GeForce 256     (NV10)
    [    91.011]   GeForce 2       (NV11, NV15)
    [    91.011]   GeForce 4MX     (NV17, NV18)
    [    91.011]   GeForce 3       (NV20)
    [    91.011]   GeForce 4Ti     (NV25, NV28)
    [    91.011]   GeForce FX      (NV3x)
    [    91.011]   GeForce 6       (NV4x)
    [    91.011]   GeForce 7       (G7x)
    [    91.011]   GeForce 8       (G8x)
    [    91.011]   GeForce GTX 200 (NVA0)
    [    91.011]   GeForce GTX 400 (NVC0)
    [    91.011] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    91.011] (II) FBDEV: driver for framebuffer: fbdev
    [    91.011] (II) VESA: driver for VESA chipsets: vesa
    [    91.011] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    [    91.011] (II) Loading sub module "fb"
    [    91.011] (II) LoadModule: "fb"
    [    91.012] (II) Loading /usr/lib64/xorg/modules/libfb.so
    [    91.012] (II) Module fb: vendor="X.Org Foundation"
    [    91.012]   compiled for 1.20.3, module version = 1.0.0
    [    91.012]   ABI class: X.Org ANSI C Emulation, version 0.4
    [    91.012] (II) Loading sub module "wfb"
    [    91.012] (II) LoadModule: "wfb"
    [    91.012] (II) Loading /usr/lib64/xorg/modules/libwfb.so
    [    91.012] (II) Module wfb: vendor="X.Org Foundation"
    [    91.012]   compiled for 1.20.3, module version = 1.0.0
    [    91.012]   ABI class: X.Org ANSI C Emulation, version 0.4
    [    91.012] (II) Loading sub module "ramdac"
    [    91.012] (II) LoadModule: "ramdac"
    [    91.012] (II) Module "ramdac" already built-in
    [    91.022] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
    [    91.022] (EE) NVIDIA:     system's kernel log for additional error messages and
    [    91.022] (EE) NVIDIA:     consult the NVIDIA README for details.
    [    91.144] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
    [    91.144] (WW) Falling back to old probe method for modesetting
    [    91.145] (II) modeset(1): using default device
    [    91.145] (WW) Falling back to old probe method for fbdev
    [    91.145] (II) Loading sub module "fbdevhw"
    [    91.145] (II) LoadModule: "fbdevhw"
    [    91.145] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [    91.145] (II) Module fbdevhw: vendor="X.Org Foundation"
    [    91.145]   compiled for 1.20.3, module version = 0.0.2
    [    91.145]   ABI class: X.Org Video Driver, version 24.0
    [    91.145] (II) FBDEV(2): using default device
    [    91.145] (II) modeset(G0): using drv /dev/dri/card0
    [    91.145] (EE) Screen 0 deleted because of no matching config section.
    [    91.145] (II) UnloadModule: "modesetting"
    [    91.145] (EE) 
    Fatal server error:
    [    91.145] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
    [    91.146] (EE) 
    [    91.146] (EE) 
    Please consult the The X.Org Foundation support 
       at http://wiki.x.org
     for help. 
    [    91.146] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    91.146] (EE) 
    [    91.157] (EE) Server terminated with error (1). Closing log file.
    Now I removed the NVidia driver and change the /etc/gdm/custom.conf to load Wayland and I get the boot splash screen for the first time and a GUI/Wayland.
    The driver did place a config file in the modprobe dir to blacklist nouveau and this got removed when I removed the NVidia driver.

    I’m guessing the modprobe boot error, where it failed to insert ‘nvidia’ is the big bad guy here?

  9. #19
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    281

    Default Re: AW: Nvidia Proprietary drivers on Wayland

    Quote Originally Posted by wolfi323 View Post
    FYI, I found a blog post (from a KDE/Plasma developer) about how to get Plasma/Wayland running with the proprietary nvidia driver:
    http://blog.davidedmundson.co.uk/blo...and-on-nvidia/

    It mentions that modesetting support in the nvidia driver needs to be enabled.
    This can be done e.g. by adding "nvidia-drm.modeset=1" to the kernel parameters (or creating a file in /etc/modeprobe.d/ with the content "options nvidia-drm modeset=1").

    I don't know if that also applies to GNOME on Wayland, though it's probably worth a try in case it doesn't work out of the box.

    Btw, as a side-effect this will also make plymouth's boot splash work in graphics mode when the nvidia driver is installed...

    I think I saw this in a file the NVidia driver places in the modprobe dir. The kernel parameter. When I install I again, I’ll check that.

  10. #20

    Default Re: Nvidia Proprietary drivers on Wayland

    Quote Originally Posted by Ricochet View Post
    I installed from the repo with no errors. I reboot the machine, and now don’t see the Leap load screen.

    That's normal, the (graphical) load screen needs modesetting enabled as mentioned (and nvidia doesn't have it enabled by default.
    Nothing new though, you must have seen that with previous distribution versions too. (actually nvidia only supports that since not too long ago in the first place, a year, maybe two)

    Code:
    [    91.022] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
    [    91.022] (EE) NVIDIA:     system's kernel log for additional error messages and
    [    91.022] (EE) NVIDIA:     consult the NVIDIA README for details.
    The nvidia kernel module cannot be loaded, and so the nvidia driver fails.
    But the question is why.

    Maybe this would give a clue (run with the nvidia driver installed, after X failed to start):
    Code:
    dmesg|grep -i nvidia
    Also check if the kernel module is actually installed for the current kernel:
    Code:
    find /lib/modules/ -iname nvidia*
    Quote Originally Posted by Ricochet View Post
    I think I saw this in a file the NVidia driver places in the modprobe dir. The kernel parameter. When I install I again, I’ll check that.
    It wasn't when I last checked a few months ago, and that you didn't see the boot splash indicates it isn't.
    But as I said, I don't know if it's needed for GNOME on Wayland.
    Doesn't matter much though as long as the driver doesn't work anyway.

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •