Results 1 to 7 of 7

Thread: Default text editor

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,393

    Default Default text editor

    I really don't understand why when I click on a .txt file while running PcManFM it opens with notepad a WinDoze application running under wine. Does it imply that there are no Linux simple text editors?

    Any suggestions on getting rid of it would be appreciated.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,830
    Blog Entries
    3

    Default Re: Default text editor

    There's probably a setting for that.

    In KDE, the default is "kate", but there is a setting to change that.

    I mostly use the unix shell as my file manager, so I don't try changing it. But "vi" (really "vim") is my preferred text editor.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,393

    Default Re: Default text editor

    Quote Originally Posted by nrickert View Post
    There's probably a setting for that.
    I'm sure there must be but I haven't found it yet. It's still a brand new OS version for me. As for vim, while I like working in a console I really don't feel like learning vi's complicated commands. I tend to use nano.

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,459

    Default Re: Default text editor

    Regards, Paul

    2x Tumbleweed (Snapshot: 20200701) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,393

    Default Re: Default text editor

    Quote Originally Posted by tannington View Post
    Many thanks. A lot of reading, but excellent result.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,829
    Blog Entries
    15

    Default Re: Default text editor

    Hi
    Just add to your shell source eg ~/.bashrc

    Code:
    export EDITOR='nano'
    export VISUAL='nano'
    Save and source it....

    Code:
    . .bashrc
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,293
    Blog Entries
    2

    Default Re: Default text editor

    IMO the following article describes what you want, which is to disable/remove the WINE file associations allowing your default PCManFM file associations to work.

    https://appuals.com/unregister-wine-...iations-linux/

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •