Results 1 to 2 of 2

Thread: need help building libffi 3.3

  1. #1

    Default need help building libffi 3.3

    Hi,

    I need to build libffi 3.3 as dependency of another project. I created a package (you can see it here: https://build.opensuse.org/package/s...tebanlm/libffi) and everything seems to work fine, the first time.

    But then, some repositories stop work, with a message "Unresolvable: nothing provides libffi.so.6()(64bit) needed by glib2, nothing provides libffi.so.6()(64bit) needed by guile22".

    Now, in my build I do install the libraries under %{_libdir}, but I do not override libffi.so (to not mess with other installed packages).

    Moreover, this weird status gets "transmitted"to other packages I have created (see https://build.opensuse.org/package/s...ebanlm/libgit2, as an example).

    Until now, the only "solution" I found is to remove the package and start over, but this does not solves the problem because even if then the build of libffi succeeds, subsequent builds on same repository don't.

    So... my question would be: how can I avoid my libffi build to break everything?

    Thanks in advance,
    Esteban

  2. #2
    Join Date
    Sep 2012
    Posts
    5,646

    Default Re: need help building libffi 3.3

    Quote Originally Posted by estebanlm View Post
    But then, some repositories stop work
    Not "some" - Fedora stop work.
    with a message "Unresolvable: nothing provides libffi.so.6()(64bit) needed by glib2, nothing provides libffi.so.6()(64bit) needed by guile22".
    Well, apparently you give your package the same name as Fedora package, but your package builds library with different major number. That is wrong, if major number changes library package name must change as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •