Results 1 to 2 of 2

Thread: KDE adds font style in settings.ini in UTF8 format that is unreadable by some applications

  1. #1

    Exclamation KDE adds font style in settings.ini in UTF8 format that is unreadable by some applications

    Choosing font for GTK+ applications with KDE Settings -> Application style -> GNOME Application Style (GTK) -> GTK Themes:
    if I choose font with font style written not with english (latin) characters, then KDE writes it in a file with settings
    Code:
    /home/MyName/.config/gtk-3.0/settings.ini
    in UTF8 string coding:

    Code:
    gtk-font-name=Bitstream Charter Regular 11
    but

    Code:
    gtk-font-name=Courier New \xd0\x9e\xd0\xb1\xd1\x8b\xd1\x87\xd0\xbd\xd1\x8b\xd0\xb9 11
    Here
    "\xd0\x9e\xd0\xb1\xd1\x8b\xd1\x87\xd0\xbd\xd1\x8b\xd0\xb9" = "Обычный".

    Decoding: http://ddecode.com/hexdecoder/

    If program uses GTK+, then it cannot get neither font style, nor font size.
    It is possible to correct it by hands and get what we expext:

    Code:
    gtk-font-name=Courier New Обычный 11

  2. #2

    Default Re: KDE adds font style in settings.ini in UTF8 format that is unreadable by some applications


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •