Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: No Input Signal from my Internal Microphones

  1. #31
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,657
    Blog Entries
    38

    Default Re: No Input Signal from my Internal Microphones

    Quote Originally Posted by oldcpu View Post
    The above works on my PC under the assumption that the PCI detection order is fixed and that the card/USB device detection is stable. Fortunately on my PC it is stable. However I have read of other users where the detection is not stable, and that causes them problems.

    Fortunately, in today's GNU/Linux, with pulse audio and 'pavucontrol' application, the order of devices is not so important, as pulse audio can direct the audio as required, with 'pavucontrol' providing the user the needed control.
    .
    I should add to the above, with different order of devices in the "index= ... " in the 50-sound.conf, which can change the sound card assignments, one may need to tune pulse audio via pavucontrol afterward, to ensure sound from an application goes to the correct sound device.

  2. #32
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,728
    Blog Entries
    1

    Default Re: No Input Signal from my Internal Microphones

    Quote Originally Posted by oldcpu View Post
    I'm still puzzling over the VID/PID assignments. I thought they worked for the snd_hda_intel modules, but maybe my memory has failed me.
    I also remember a time when they were valid....but not now....
    Code:
    # modinfo -p snd-hda-intel
    index:Index value for Intel HD audio interface. (array of int)
    id:ID string for Intel HD audio interface. (array of charp)
    enable:Enable Intel HD audio interface. (array of bool)
    model:Use the given board model. (array of charp)
    position_fix:DMA pointer read method.(-1 = system default, 0 = auto, 1 = LPIB, 2 = POSBUF, 3 = VIACOMBO, 4 = COMBO, 5 = SKL+, 6 = FIFO). (array of int)
    bdl_pos_adj:BDL position adjustment offset. (array of int)
    probe_mask:Bitmask to probe codecs (default = -1). (array of int)
    probe_only:Only probing and no codec initialization. (array of int)
    jackpoll_ms:Ms between polling for jack events (default = 0, using unsol events only) (array of int)
    single_cmd:Use single command to communicate with codecs (for debugging only). (bint)
    enable_msi:Enable Message Signaled Interrupt (MSI) (bint)
    patch:Patch file for Intel HD audio interface. (array of charp)
    beep_mode:Select HDA Beep registration mode (0=off, 1=on) (default=1). (array of bool)
    dmic_detect:Allow DSP driver selection (bypass this driver) (0=off, 1=on) (default=1); deprecated, use snd-intel-dspcfg.dsp_driver option instead (bool)
    power_save:Automatic power-saving timeout (in second, 0 = disable). (xint)
    pm_blacklist:Enable power-management blacklist (bool)
    power_save_controller:Reset controller in power save mode. (bool)
    align_buffer_size:Force buffer and period sizes to be multiple of 128 bytes. (bint)
    snoop:Enable/disable snooping (bint)
    Fortunately, in today's GNU/Linux, with pulse audio and 'pavucontrol' application, the order of devices is not so important, as pulse audio can direct the audio as required, with 'pavucontrol' providing the user the needed control.
    .
    Yes, PA provides that effective functionality.
    openSUSE Leap 15.2; KDE Plasma 5

  3. #33
    Join Date
    Jun 2020
    Location
    Banburyshire, UK
    Posts
    21

    Default Re: No Input Signal from my Internal Microphones

    oldcpu, deano,

    it seems that reboot is responsible for changing the order of the sound cards... I tested 0,1,2 cards (no YaST, editing 50-sound.conf directly) then booted into "multi-user" then a "init 5". After editing 50-sound.conf from one card to two cards, after reboot, the PCH card (originally card 0) was pushed down to "card 1" (and also suffered a name change from PCH to NVidia) with the NVidia as "card 0"

    one card rl3

    Code:
    === /etc/modprobe.d/50-sound.conf ===
    
    
    options snd slots=snd-hda-intel
    # nS1_.4iMtSV4J9L1:Comet Lake PCH cAVS
    options snd_hda_intel index=0 model=dual-codecs id=PCH
    alias snd-card-0 snd-hda-intel
    
    === /proc/asound/cards ===
    
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDAudio-Gigabyte-ALC1220DualCodecs
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xa1000000 irq 17
    ####################################################################

    two cards rl3

    Code:
    === /etc/modprobe.d/50-sound.conf ===
    
    
    options snd slots=snd-hda-intel,snd-hda-intel
    # nS1_.4iMtSV4J9L1:Comet Lake PCH cAVS
    options snd_hda_intel index=0 model=dual-codecs id=PCH
    alias snd-card-0 snd-hda-intel
    # NXNs.Q5mfEK148i4:TU106 High Definition Audio Controller
    options snd_hda_intel index=1 model=dual-codecs id=NVidia
    alias snd-card-1 snd-hda-intel
    
    === /proc/asound/cards ===
    
     0 [NVidia_1       ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xa1000000 irq 17
     1 [NVidia         ]: HDA-Intel - HDA Intel PCH
                          HDAudio-Gigabyte-ALC1220DualCodecs

    so it looks like leap 15.1 is responsible.

    I will experiment more tomorrow hopefully.

    regards
    stevetom




  4. #34
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,657
    Blog Entries
    38

    Default Re: No Input Signal from my Internal Microphones

    Quote Originally Posted by stevetom View Post
    I will experiment more tomorrow hopefully.
    IMHO, there appears to be duplication in the 50-sound.conf files that you are using where more entries are in place than needed ? ... although I could be wrong.

    Did you try the following four different 50-sound.conf file entries:

    First edit this into the 50-sound.conf (and nothing else) followed by a reboot to test:
    Code:
    options snd-hda-intel index=0,1
    Does that give sound that works? and if so, which device is sound card 0 and sound card 1 ?

    and instead this 50-sound.conf, followed by a reboot to test properly:
    Code:
    options snd-hda-intel index=1,0
    Does that give sound that works? and if so, which device is sound card 0 and sound card 1 ?

    Or if the above yields no sound and if this "model=dual-codecs" is necessary, try only this in the 50-sound.conf followed by a reboot to test:
    Code:
    options snd-hda-intel index=0,1 model=dual-codecs
    Does that give sound that works? and if so, which device is sound card 0 and sound card 1 ?

    and instead this 50-sound.conf, followed by a reboot to test properly:
    Code:
    options snd-hda-intel index=1,0 model=dual-codecs
    Does that give sound that works? and if so, which device is sound card 0 and sound card 1 ?

    My idea is to keep the 50-sound.conf file simple - as simple as possible - where I find keeping things simple helps me to understand better the affect of individual entries. If I put in a bunch of entries it totally confuses me as to what each entry does.

  5. #35
    Join Date
    Jun 2020
    Location
    Banburyshire, UK
    Posts
    21

    Default Re: No Input Signal from my Internal Microphones

    oldcpu,
    many thanks - I understand: the KISS principle. Would you believe your post came in just after I had closed down after a testing session - I haven't even reviewed the results yet! I may be able to do your tests later this afternoon, if not then this evening - each test generates a shed-load of diags.
    To tell truth, currently I haven't been actually testing the actual sound - just watching the kernel stuff moving around - but will for your tests.
    i also note there is a dkms build failure (journal -b|grep realtek), but that should probably be investigated via a separate thread.
    regards
    stevetom

  6. #36
    Join Date
    Jun 2020
    Location
    Banburyshire, UK
    Posts
    21

    Default Re: No Input Signal from my Internal Microphones

    oldcpu,
    from your sequence of tests I can confirm that sound works only with the model assignment in the options line - output works fine with no problem whichever order was used in the index assignment. However, whilst input (internal mike) is working (I can see activity in the arecord VU meter) but aplay is silent. I did watch aplay in pavucontrol (output devices) and the activity was there also - but no sound. Subsequently playing an mp3 image via the Files application was also silent, whereas it had worked during my output test - looks like pavucontrol had routed the sound somewhere.

    applying the dual-codecs value does change the names reported in alsacontrol, and is confirmed in /proc/asound/cardX/codec#Y <-- there are other more subtle changes to be seen in that data, I suspect I will find other differences.
    reboot seems to mute and otherwise modify the controls, but once my config settles down I can script the relevant amixer sset changes.
    Plus the dkms build failure mentioned before.

    Option 1

    Code:
    oldcpu opt #1
    
    === /etc/modprobe.d/50-sound.conf ===
    
    options snd-hda-intel index=0,1
    
    === /proc/asound/cards ===
    
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0x6052200000 irq 174
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xa1000000 irq 17
    Option 4

    Code:
    oldcpu opt 4
    
    === /etc/modprobe.d/50-sound.conf ===
    
    options snd-hda-intel index=0,1 model=dual-codecs
    
    === /proc/asound/cards ===
    
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDAudio-Gigabyte-ALC1220DualCodecs
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xa1000000 irq 17

    I can recreate and get you alsa-info.sh images if you want them.
    regards
    stevetom

  7. #37
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,657
    Blog Entries
    38

    Default Re: No Input Signal from my Internal Microphones

    Quote Originally Posted by stevetom View Post
    Option 1

    Code:
    oldcpu opt #1
    
    === /etc/modprobe.d/50-sound.conf ===
    
    options snd-hda-intel index=0,1
    
    === /proc/asound/cards ===
    
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0x6052200000 irq 174
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xa1000000 irq 17
    OK, my understanding is there is no sound with the above as there is no 'model=dual-codecs' assignment.

    I think this next one was actually the 3rd test (as "index=0,1" was always an odd # test in the order of tests I suggested) ...
    Quote Originally Posted by stevetom View Post
    Option 4

    Code:
    oldcpu opt 4
    
    === /etc/modprobe.d/50-sound.conf ===
    
    options snd-hda-intel index=0,1 model=dual-codecs
    
    === /proc/asound/cards ===
    
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDAudio-Gigabyte-ALC1220DualCodecs
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xa1000000 irq 17
    My understanding the above, with 'index=0,1' and 'model=dual-codecs' gives you ok sound and mic working. I suspect with the reverse 'index=1,0' you probably could also get to work but you would need to tune pavucontrol as sound cards would be reversed.

    No need to run the script again if my above understanding is correct.

  8. #38
    Join Date
    Jun 2020
    Location
    Banburyshire, UK
    Posts
    21

    Default Re: No Input Signal from my Internal Microphones

    oldcpu, deano, Svyatko,



    many thanks for your inputs, and apologies for the radio silence – I needed to take a bit of a break. In the meantime, I have made some progress of sorts albeit somewhat circular.
    In comparing my results from oldcpu’s 50-sound.conf suggestions, I didn’t find too much enlightenment, so experimented with Bluetooth connection:



    Initially very varied results, until I noticed the “Sound Settings” button when clicking on my connected device (in Activities → Bluetooth→ ) – a slightly cut-down pavucontrol. There I can select the device to use for Input/Output which included the internal microphone/headphone options and my Bluetooth device. The (Bluetooth) output certainly works, I suspect the input works (it shows activity on the Input tab “VU meter”, but arecord/aplay does not reproduce the expected recording – I suspect it is switched away to a digital (unconnected) sink).



    Then curiosity got the better of me, the above results were using a 50-sound.conf:

    options snd-hda-intel index=0,1 model=dual-codecs

    what would happen if I used the “factory fresh” version ie no 50-sound.conf? Answer: It still works.



    So it appears I have wasted people’s time & efforts – apologies - by trying to get the simple things working (ie internal devices) rather than going straight for the bluetooth jugular. In retrospect a simpler starting point (for multimedia: sound) would have been Activities → Settings → Sound



    regards
    stevetom

  9. #39
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,657
    Blog Entries
    38

    Default Re: No Input Signal from my Internal Microphones

    Quote Originally Posted by stevetom View Post
    what would happen if I used the “factory fresh” version ie no 50-sound.conf? Answer: It still works.
    Interesting news.

    openSUSE and GNU/Linux in general has made significant progress the past 15 years (IMHO) wrt automatic sound configuration. There was a day when many GNU/Linux users needed to to tune the 'equivalent' of 50-sound.conf. Today - the alsa configuration is often automatic and such 50-sound.conf (or equivalent) tuning is often not needed. Rather its the higher layer (pulseaudio) configuration that confuses new users, resulting in them tuning alsa,when in fact its pulse audio (or some other higher level aspect) that requires the tuning.

    I don't see anyone's time wasted here.

    We all can learn from such things IMHO.

  10. #40
    Join Date
    Jun 2020
    Location
    Banburyshire, UK
    Posts
    21

    Default Re: No Input Signal from my Internal Microphones

    oldcpu - many thanks

    I was a bit "economical with the truth" in saying "it still works" - without the 50-sound.conf, the internal speakers again do not work. I'm not too worried about that as my preferred target would be some bluetooth speakers (MiniRigs - use 80 of them for a 3000 Watt sound system! small, good quality, and very rugged).

    I did find a very useful document via the pulseaudio website: https://gavv.github.io/articles/puls...nder-the-hood/ - if not ready to dive into code, then the first 4 sections & the Example Setups sections make me feel that I now have some useful tools to explore what is happening with my internal speakers - probably.

    Currently I'm running without the 50-sound.conf tuning - it's "cleaner", and fixes two issues: the dkms build errors, and the alsamixer channel labels.

    I was going to close down this thread, but it now looks as if I need to flex my pactl list wings.

    cheers
    stevetom

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •