Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cannot b

  1. #1

    Default Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cannot b

    Code:
    # zypper up
    Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cannot be provided
      not installable providers: icewm-theme-branding-1.2.4-lp151.3.3.1.noarch[http-download.opensuse.org-ff8e5a28]
                       icewm-theme-branding-1.2.4-lp151.3.6.1.noarch[http-download.opensuse.org-ff8e5a28]
                       icewm-theme-branding-1.2.4-lp151.2.1.noarch[repo-oss]
                       icewm-theme-branding-1.2.4-lp151.3.3.1.noarch[repo-update]
                       icewm-theme-branding-1.2.4-lp151.3.6.1.noarch[repo-update]
     Solution 1: Following actions will be done:
      deinstallation of icewm-1.4.2-lp151.8.3.1.x86_64
      deinstallation of icewm-default-1.4.2-lp151.8.3.1.x86_64
      deinstallation of icewm-lite-1.4.2-lp151.8.3.1.x86_64
      deinstallation of icewm-lang-1.4.2-lp151.8.3.1.noarch
     Solution 2: deinstallation of icewm-config-upstream-1.4.2-lp151.8.3.1.noarch
     Solution 3: do not install patch:openSUSE-2020-890-1.noarch
     Solution 4: break icewm-1.4.2-lp151.8.6.1.x86_64 by ignoring some of its dependencies
    What is please best solution ?

  2. #2
    Join Date
    Sep 2012
    Posts
    5,646

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    Quote Originally Posted by MakeTopSite View Post
    Code:
    Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cannot be provided
     Solution 2: deinstallation of icewm-config-upstream-1.4.2-lp151.8.3.1.noarch
    These two packages conflict - icewm-theme-branding is openSUSE defaults, icewm-config-upstream is upstream defaults.

    This sounds like a packaging bug - it must be possible to install either of two packages, and icewm should require 'icewm-configuration-files' instead which is satisfied by either of two.

    If you intend to continue to use icewm-config-upstream, select 4 and open bug report. Otherwise just select 2.

  3. #3

    Smile Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    Quote Originally Posted by arvidjaar View Post
    These two packages conflict - icewm-theme-branding is openSUSE defaults, icewm-config-upstream is upstream defaults.

    This sounds like a packaging bug - it must be possible to install either of two packages, and icewm should require 'icewm-configuration-files' instead which is satisfied by either of two.

    If you intend to continue to use icewm-config-upstream, select 4 and open bug report. Otherwise just select 2.
    Thank you.

    I was searching bug reporting web page so I've tried some menu of this page:
    https://www.opensuse.org/sitemap#community

    https://www.opensuse.org/sitemap#development

    https://www.opensuse.org/sitemap#support

    None of them is working:
    Code:
    404 Not Found
    
     
    nginx/1.16.1
    Is it another bug ?

  4. #4
    Join Date
    Sep 2012
    Posts
    5,646

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    Quote Originally Posted by MakeTopSite View Post
    None of them is working
    https://bugzilla.opensuse.org/enter_...20Distribution, same user/password as forums

    Is it another bug ?
    .
    Where have you got these links from? I do not see them on https://www.opensuse.org/.

  5. #5

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    Quote Originally Posted by arvidjaar View Post
    https://bugzilla.opensuse.org/enter_...20Distribution, same user/password as forums

    .
    Where have you got these links from? I do not see them on https://www.opensuse.org/.
    on the top of this page

  6. #6

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann


  7. #7
    Join Date
    Sep 2012
    Posts
    5,646

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    Quote Originally Posted by MakeTopSite View Post
    on the top of this page
    If "this" means www.opensuse.org, this page works for me. May be some extensions you are using or something else in browser configuration. But this is separate topic.

  8. #8

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    Quote Originally Posted by arvidjaar View Post
    If "this" means www.opensuse.org, this page works for me. May be some extensions you are using or something else in browser configuration. But this is separate topic.
    "this" means https://forums.opensuse.org/showthre...09#post2939509

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,838
    Blog Entries
    3

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    I just installed that "icewm" update (on a Leap 15.1 system). I did not run into any problems. But then I am using the openSUSE theme rather than the upstream theme.

    I don't think this was a security update. If you prefer the upstream theme, you could just skip that update.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  10. #10

    Default Re: Problem: icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cann

    Quote Originally Posted by nrickert View Post
    I just installed that "icewm" update (on a Leap 15.1 system). I did not run into any problems. But then I am using the openSUSE theme rather than the upstream theme.

    I don't think this was a security update. If you prefer the upstream theme, you could just skip that update.
    Thank you. I prefer other theme than Default and this patch is mentioned neither in https://forums.opensuse.org/forumdis...-Announcements

    nor https://lists.opensuse.org/opensuse-...0-06/date.html

    so I've choosen 3)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •