Results 1 to 10 of 10

Thread: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

  1. #1

    Question MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    hi

    i try connect minecraft to other computer inside my house: LAN, but maybe is blocked from firewall but how i want connect without problem..playing my daughters.. i see firewall but there is not name: minecraft or java...
    what i will do this for my daughters.. playing minecraft use with two computer linux (opensuse 15.0 and opensuse 15.2 beta)..

    thank you

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,061

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    Minecraft uses TCP 25565 for communication, so you'll need to open that port in your firewall on the system where you are hosting the minecraft server on.

    You can open a port in firewall's public zone by issuing:
    Code:
    sudo firewall-cmd  --zone=public --add-port=25565/tcp
    It will ask for your root password. See if this helps, if not - let's try to debug why not.
    .: miuku #suse @ irc.freenode.net

  3. #3

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    Quote Originally Posted by Miuku View Post
    Minecraft uses TCP 25565 for communication, so you'll need to open that port in your firewall on the system where you are hosting the minecraft server on.

    You can open a port in firewall's public zone by issuing:
    Code:
    sudo firewall-cmd  --zone=public --add-port=25565/tcp
    It will ask for your root password. See if this helps, if not - let's try to debug why not.
    ok i did comand firewall... but not works..nothing list of lan

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,833
    Blog Entries
    15

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    Quote Originally Posted by manuel_songokuh View Post
    ok i did comand firewall... but not works..nothing list of lan
    Hi
    Just tested here, minecraft server on Leap 15.1, client on Tumbleweed. Opening the port worked fine on the server side....

    Can you confirm the rule on the server took, you might also want to switch to root user rather than sudo via su -

    Code:
    firewall-cmd  --list-all
    
    public (active)
      target: default
      icmp-block-inversion: no
      interfaces: eth0
      sources: 
      services: ssh dhcpv6-client
      ports: 
      protocols: 
      masquerade: no
      forward-ports: 
      source-ports: 
      icmp-blocks: 
      rich rules: 
        
    firewall-cmd  --zone=public --add-port=25565/tcp
    success
    
    firewall-cmd  --list-all
    public (active)
      target: default
      icmp-block-inversion: no
      interfaces: eth0
      sources: 
      services: ssh dhcpv6-client
      ports: 25565/tcp
      protocols: 
      masquerade: no
      forward-ports: 
      source-ports: 
      icmp-blocks: 
      rich rules:
    I ran the server in GUI mode....

    Server:


    Firewall running on server no port open:


    Opened port:
    Miniatures attachées Miniatures attachées Click image for larger version. 

Name:	Screenshot from 2020-06-25 10-42-25.png 
Views:	61 
Size:	105.6 KB 
ID:	895   Click image for larger version. 

Name:	Screenshot from 2020-06-25 10-41-17.png 
Views:	62 
Size:	25.1 KB 
ID:	896   Click image for larger version. 

Name:	Screenshot from 2020-06-25 10-42-07.png 
Views:	63 
Size:	232.8 KB 
ID:	897  
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    ok i try..
    Code:
    firewall-cmd  --list-all                 
    public (active)
      target: default
      icmp-block-inversion: no
      interfaces: eth0
      sources: 
      services: dhcpv6-client
      ports: 4644/tcp 4644/udp 25565/tcp
      protocols: 
      masquerade: no
      forward-ports: 
      source-ports: 
      icmp-blocks: 
      rich rules: 
    
    gokuhh@localhost:~> firewall-cmd  --zone=public --add-port=25565/tcp
    Warning: ALREADY_ENABLED: '25565:tcp' already in 'public'
    success
    gokuhh@localhost:~> firewall-cmd  --list-all
    public (active)
      target: default
      icmp-block-inversion: no
      interfaces: eth0
      sources: 
      services: dhcpv6-client
      ports: 4644/tcp 4644/udp 25565/tcp
      protocols: 
      masquerade: no
      forward-ports: 
      source-ports: 
      icmp-blocks: 
      rich rules:
    on opensuse 15.2 beta minecraft: i go single player, open world, menu: open to lan,start lan world, output text message:local game hosted on port 33079.
    on opensuse 15.0 minecraft: i go multiplayer:

  6. #6

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...


  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,833
    Blog Entries
    15

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    Hi
    Did you add the server ip address to the client?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    i try restart firewall but there isone list in search minecraft lan: LAN WORLD but error message: https://paste.opensuse.org/48480590

  9. #9

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    but i click REFRESH result list is empty..but i restart firewall and back the list but 2 seconds after is empty (refresh)..what is problem from..?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,833
    Blog Entries
    15

    Default Re: MINECRAFT JAVA EDITION on LAN: opensuse 15, not works...

    Quote Originally Posted by manuel_songokuh View Post
    but i click REFRESH result list is empty..but i restart firewall and back the list but 2 seconds after is empty (refresh)..what is problem from..?
    Hi
    Did you check the firewall command again, since you restarted the firewall;

    Code:
    firewall-cmd  --list-all
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •