Results 1 to 7 of 7

Thread: How can I smooth the Network Manager and WiFi Login process.

  1. #1

    Default How can I smooth the Network Manager and WiFi Login process.

    How may I reduce and possibly simplify the many interruptions I receive when turning on my laptop and connecting to wifi.

    If I wake up the laptop I get a prompt for KeepassXC login, sometimes a prompt for pCloud login and now a new prompt asking for root authority simply to connect to my wifi.
    Until last week I had a KDE prompt for my wallet which I thought would deal with this but this has now disappeared.

    What is particularly annoying is that these popups interrupt each entry process so I find I have only typed in half of my passphrase and have to start over.

    The situation is now even worse if I re-boot, a frequent requirement with Tumbleweed. There are now a couple more popups telling me that I have no network connection. Of course I don't because I am still typing in passphrases when the popup interrupts me and frustrates my network connection to tell me about it.
    The situation is getting ridiculous and I must turn off this clutter or arrange it so it everything in an orderly manner and when I am typing in one window, this is not interrupted by a new popup.
    Any suggestion please?
    Budge

  2. #2
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,628

    Default Re: How can I smooth the Network Manager and WiFi Login process.

    Quote Originally Posted by Budgie2 View Post
    How may I reduce and possibly simplify the many interruptions I receive when turning on my laptop and connecting to wifi.

    If I wake up the laptop I get a prompt for KeepassXC login, sometimes a prompt for pCloud login and now a new prompt asking for root authority simply to connect to my wifi.
    Until last week I had a KDE prompt for my wallet which I thought would deal with this but this has now disappeared.

    What is particularly annoying is that these popups interrupt each entry process so I find I have only typed in half of my passphrase and have to start over.

    The situation is now even worse if I re-boot, a frequent requirement with Tumbleweed. There are now a couple more popups telling me that I have no network connection. Of course I don't because I am still typing in passphrases when the popup interrupts me and frustrates my network connection to tell me about it.
    The situation is getting ridiculous and I must turn off this clutter or arrange it so it everything in an orderly manner and when I am typing in one window, this is not interrupted by a new popup.
    Any suggestion please?
    Budge
    Disabled NetworkManager and enabled systemd-networkd: https://en.opensuse.org/Systemd-networkd
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  3. #3

    Default Re: How can I smooth the Network Manager and WiFi Login process.

    Quote Originally Posted by karlmistelberger View Post
    Disabled NetworkManager and enabled systemd-networkd: https://en.opensuse.org/Systemd-networkd
    That looks rather good although possibly a bit beyond my ability. Not sure how I would be able to manage it dodging between wireless aps and different subnets, vlans etc. with roaming laptop but excellent option for my main workstations.

    Meanwhile I have put the workstation on Wicked for now.

    Am still using Network Manager on laptop which is what prompted this post and I am sure I shall be able to tune the configuration. For example one new problem I cited is that Network Manager has started asking me for root password ahead of the Kwallet asking for my wallet password. I found this when I cancelled the NM request for root and the Wallet then popped up.
    How may I tune the timing of these so that things proceed in an orderly manner?

    I recently found that a new popup has several configurable settings they have gone before I know what they are. Will try and get a screenshot.

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,628

    Default Re: How can I smooth the Network Manager and WiFi Login process.

    Quote Originally Posted by Budgie2 View Post
    That looks rather good although possibly a bit beyond my ability. Not sure how I would be able to manage it dodging between wireless aps and different subnets, vlans etc. with roaming laptop but excellent option for my main workstations.

    Meanwhile I have put the workstation on Wicked for now.
    With wicked network is managed by root. You can have this with NetworkManager too. Password will be stored in a configuration file. Logs are really cool with networkd:

    Code:
    [    3.815812] systemd[1]: Starting Network Service...
    [    4.533061] systemd-networkd[525]: Enumeration completed
    [    4.543363] systemd[1]: Started Network Service.
    [    4.854458] systemd-networkd[525]: eth0: Interface name change detected, eth0 has been renamed to enp0s25.
    [    5.472958] systemd-networkd[525]: enp0s25: Link UP
    [    7.005737] systemd-networkd[525]: enp0s25: Gained carrier
    vs.

    Code:
    [    8.374436] systemd[1]: Starting Network Manager...
    [    8.631201] NetworkManager[1118]: <info>  [1592481084.8251] NetworkManager (version 1.22.6) is starting... (for the first time)
    [    8.631495] NetworkManager[1118]: <info>  [1592481084.8252] Read config: /etc/NetworkManager/NetworkManager.conf
    [    8.635295] NetworkManager[1118]: <info>  [1592481084.8278] bus-manager: acquired D-Bus service "org.freedesktop.NetworkManager"
    [    8.637180] NetworkManager[1118]: <info>  [1592481084.8309] manager[0x559db0f4a0e0]: monitoring kernel firmware directory '/lib/firmware'.
    [    8.768037] systemd[1]: Started Network Manager.
    [    8.878312] NetworkManager[1118]: <info>  [1592481085.0723] hostname: hostname: using hostnamed
    [    8.878821] NetworkManager[1118]: <info>  [1592481085.0727] dns-mgr[0x559db0f2a240]: init: dns=default,systemd-resolved rc-manager=netconfig
    [    8.885512] NetworkManager[1118]: <info>  [1592481085.0787] manager[0x559db0f4a0e0]: rfkill: Wi-Fi hardware radio set enabled
    [    8.885755] NetworkManager[1118]: <info>  [1592481085.0787] manager[0x559db0f4a0e0]: rfkill: WWAN hardware radio set enabled
    [    8.886938] NetworkManager[1118]: <info>  [1592481085.0809] Loaded device plugin: NMAtmManager (/usr/lib64/NetworkManager/1.22.6/libnm-device-plugin-adsl.so)
    [    8.890628] NetworkManager[1118]: <info>  [1592481085.0846] Loaded device plugin: NMBluezManager (/usr/lib64/NetworkManager/1.22.6/libnm-device-plugin-bluetooth.so)
    [    8.892527] NetworkManager[1118]: <info>  [1592481085.0865] Loaded device plugin: NMOvsFactory (/usr/lib64/NetworkManager/1.22.6/libnm-device-plugin-ovs.so)
    [    8.897959] NetworkManager[1118]: <info>  [1592481085.0920] Loaded device plugin: NMTeamFactory (/usr/lib64/NetworkManager/1.22.6/libnm-device-plugin-team.so)
    [    8.899090] NetworkManager[1118]: <info>  [1592481085.0931] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/1.22.6/libnm-device-plugin-wifi.so)
    [    8.899658] NetworkManager[1118]: <info>  [1592481085.0937] Loaded device plugin: NMWwanFactory (/usr/lib64/NetworkManager/1.22.6/libnm-device-plugin-wwan.so)
    [    8.902610] NetworkManager[1118]: <info>  [1592481085.0940] manager: rfkill: Wi-Fi enabled by radio killswitch; enabled by state file
    [    8.902874] NetworkManager[1118]: <info>  [1592481085.0941] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
    [    8.903142] NetworkManager[1118]: <info>  [1592481085.0942] manager: Networking is enabled by state file
    [    8.903318] NetworkManager[1118]: <info>  [1592481085.0944] dhcp-init: Using DHCP client 'internal'
    [    8.905087] NetworkManager[1118]: <info>  [1592481085.0944] settings: Loaded settings plugin: keyfile (internal)
    [    8.905424] NetworkManager[1118]: <info>  [1592481085.0949] device (lo): carrier: link connected
    [    8.905601] NetworkManager[1118]: <info>  [1592481085.0952] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
    [    8.905941] NetworkManager[1118]: <info>  [1592481085.0980] manager: (eth0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
    [    8.908845] NetworkManager[1118]: <info>  [1592481085.1028] settings: (eth0): created default wired connection 'Kabelgebundene Verbindung 1'
    [    8.910355] NetworkManager[1118]: <info>  [1592481085.1044] device (eth0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
    [    9.126722] NetworkManager[1118]: <info>  [1592481085.3207] ovsdb: Verbindung ist gescheitert: Datei oder Verzeichnis nicht gefunden
    [    9.130467] NetworkManager[1118]: <info>  [1592481085.3245] modem-manager: ModemManager available
    [   10.708683] NetworkManager[1118]: <info>  [1592481086.9026] device (eth0): carrier: link connected
    [   10.708940] NetworkManager[1118]: <info>  [1592481086.9029] device (eth0): state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed')
    [   10.709547] NetworkManager[1118]: <info>  [1592481086.9036] policy: auto-activating connection 'Kabelgebundene Verbindung 1' (30ca0e62-3d3e-3074-a9ab-3d6d0adccca5)
    [   10.710020] NetworkManager[1118]: <info>  [1592481086.9040] device (eth0): Activation: starting connection 'Kabelgebundene Verbindung 1' (30ca0e62-3d3e-3074-a9ab-3d6d0adccca5)
    [   10.710201] NetworkManager[1118]: <info>  [1592481086.9041] device (eth0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
    [   10.710362] NetworkManager[1118]: <info>  [1592481086.9043] manager: NetworkManager state is now CONNECTING
    [   10.710513] NetworkManager[1118]: <info>  [1592481086.9045] device (eth0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    [   10.710749] NetworkManager[1118]: <info>  [1592481086.9048] device (eth0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
    [   10.710964] NetworkManager[1118]: <info>  [1592481086.9050] dhcp4 (eth0): activation: beginning transaction (timeout in 45 seconds)
    [   15.543211] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option dhcp_lease_time      => '86400'
    [   15.543466] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option domain_name          => 'lan'
    [   15.543641] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option domain_name_servers  => '10.0.0.138 10.0.0.138'
    [   15.543803] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option expiry               => '1592567489'
    [   15.544078] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option ip_address           => '10.0.0.28'
    [   15.544348] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option requested_broadcast_address => '1'
    [   15.544575] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option requested_domain_name => '1'
    [   15.544675] NetworkManager[1118]: <info>  [1592481091.7372] dhcp4 (eth0): option requested_domain_name_servers => '1'
    [   15.544813] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_domain_search => '1'
    [   15.544961] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_host_name  => '1'
    [   15.545112] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_interface_mtu => '1'
    [   15.545266] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_ms_classless_static_routes => '1'
    [   15.545417] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_nis_domain => '1'
    [   15.545531] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_nis_servers => '1'
    [   15.545637] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_ntp_servers => '1'
    [   15.545746] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_rfc3442_classless_static_routes => '1'
    [   15.545855] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_root_path  => '1'
    [   15.545992] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_routers    => '1'
    [   15.546117] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_static_routes => '1'
    [   15.546250] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_subnet_mask => '1'
    [   15.546359] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_time_offset => '1'
    [   15.546498] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option requested_wpad       => '1'
    [   15.546633] NetworkManager[1118]: <info>  [1592481091.7373] dhcp4 (eth0): option routers              => '10.0.0.138'
    [   15.546770] NetworkManager[1118]: <info>  [1592481091.7374] dhcp4 (eth0): option subnet_mask          => '255.255.255.0'
    [   15.546870] NetworkManager[1118]: <info>  [1592481091.7374] dhcp4 (eth0): state changed unknown -> bound
    [   15.546973] NetworkManager[1118]: <info>  [1592481091.7383] device (eth0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
    [   15.547112] NetworkManager[1118]: <info>  [1592481091.7398] device (eth0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
    [   15.547245] NetworkManager[1118]: <info>  [1592481091.7400] device (eth0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
    [   15.547375] NetworkManager[1118]: <info>  [1592481091.7404] manager: NetworkManager state is now CONNECTED_LOCAL
    [   15.547494] NetworkManager[1118]: <info>  [1592481091.7412] manager: NetworkManager state is now CONNECTED_SITE
    [   15.547597] NetworkManager[1118]: <info>  [1592481091.7413] policy: set 'Kabelgebundene Verbindung 1' (eth0) as default for IPv4 routing and DNS
    [   15.663882] NetworkManager[1118]: nisdomainname: you must be root to change the domain name
    [   15.666731] NetworkManager[1118]: <info>  [1592481091.8602] device (eth0): Activation: successful, device activated.
    [   15.667184] NetworkManager[1118]: <info>  [1592481091.8612] manager: startup complete
    [   15.670468] NetworkManager[1118]: <info>  [1592481091.8645] policy: set-hostname: set hostname to 'localhost.localdomain' (Fehler beim Rückwärtsauflösen von »10.0.0.28«: Der Name oder der Dienst ist nicht bekannt)
    [   15.760620] NetworkManager[1118]: <info>  [1592481091.9546] manager: NetworkManager state is now CONNECTED_GLOBAL
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,584
    Blog Entries
    1

    Default Re: How can I smooth the Network Manager and WiFi Login process.

    Quote Originally Posted by Budgie2 View Post
    How may I reduce and possibly simplify the many interruptions I receive when turning on my laptop and connecting to wifi.

    If I wake up the laptop I get a prompt for KeepassXC login, sometimes a prompt for pCloud login and now a new prompt asking for root authority simply to connect to my wifi.
    Until last week I had a KDE prompt for my wallet which I thought would deal with this but this has now disappeared.

    What is particularly annoying is that these popups interrupt each entry process so I find I have only typed in half of my passphrase and have to start over.
    I frequently change networks in my job/home environment as well. For wifi networks, create the connection as a 'system-connection', with the credentials stored in the root-owned config file for that connection. It's explained here
    https://doc.opensuse.org/documentati...c-nm-sec-types
    openSUSE Leap 15.2; KDE Plasma 5

  6. #6

    Default Re: How can I smooth the Network Manager and WiFi Login process.

    Quote Originally Posted by deano_ferrari View Post
    I frequently change networks in my job/home environment as well. For wifi networks, create the connection as a 'system-connection', with the credentials stored in the root-owned config file for that connection. It's explained here
    https://doc.opensuse.org/documentati...c-nm-sec-types
    Hi Deano,
    I must be losing it! Could it be that the gnome desktop is different from KDE in this respect. I could not see an Identity tab, only General Configuration and I have always had the "All users may connect to this network" set on.

    Today I have a PolicyKit 1 Agent popup asking for my authority to modify my network connection, even though I have not changed any of this. The action showing is
    Modify network connections for all users
    which was already set and also my KDE Wallet Service asking to unlock the wallet even though I had already unlocked it.

    I have read your post and followed all the links. Am no wiser and have done nothing of which I am aware to bring these issue up now.
    Will press on and many thanks for all your help once more.
    Regards,
    Budge.

  7. #7
    Join Date
    Mar 2020
    Location
    São Leopoldo, RS, Brazil
    Posts
    153

    Default Re: How can I smooth the Network Manager and WiFi Login process.

    Quote Originally Posted by Budgie2 View Post
    Hi Deano,
    I must be losing it! Could it be that the gnome desktop is different from KDE in this respect. I could not see an Identity tab, only General Configuration and I have always had the "All users may connect to this network" set on.

    Today I have a PolicyKit 1 Agent popup asking for my authority to modify my network connection, even though I have not changed any of this. The action showing is which was already set and also my KDE Wallet Service asking to unlock the wallet even though I had already unlocked it.
    Regarding the network connections pop-ups, open the Connections editor. There,

    1) activate the General configuration tab, uncheck "All users may connect to this network", and;
    2) activate the Wi-Fi Secutity tab, select "Store password for all users (not encrypted)".

    This makes the pop-ups go away. Whether it's what you looking for that's up to you, but for most single and even multi-user setups this should be fine.
    openSUSE Tumbleweed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •