Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Epson, WF-7510, Colour missing

  1. #1
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    343

    Red face Epson, WF-7510, Colour missing

    Thanks to Dean'o's help, Ive managed to get two printers working in my Opensuse 15.1 install. The Black and White brother works fine. Unfortunately, my large format Epson Colour (WF-7510 does not.

    When I print a test print with my epson (from the YAST printer setup) it comes out in colour. When I try to print a colour picture from my files - it comes out in black and white. It doensn't matter if I open the picture with dolphin or gwenview or showfoto - If I print it it comes out in black and white. It doesn't matter if I choose the epson printer driver or one of the gutenprint ones. I 've tried using a .jpg and a .tiff - no difference - no colour. Advice, please?
    bob@rsmits.ca
    First Law of Laboratory Work: Hot glass looks exactly the same as cold glass.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,873

    Default AW: Epson, WF-7510, Colour missing

    Maybe you have Black/white as standard?

    Goto:
    localhost:631
    in your Browser and change it.

    If password is asked, its the root one.

  3. #3
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    483

    Cool Re: Epson, WF-7510, Colour missing

    Quote Originally Posted by robertsmits View Post
    Thanks to Dean'o's help, Ive managed to get two printers working in my Opensuse 15.1 install. The Black and White brother works fine. Unfortunately, my large format Epson Colour (WF-7510 does not.

    When I print a test print with my epson (from the YAST printer setup) it comes out in colour. When I try to print a colour picture from my files - it comes out in black and white. It doensn't matter if I open the picture with dolphin or gwenview or showfoto - If I print it it comes out in black and white. It doesn't matter if I choose the epson printer driver or one of the gutenprint ones. I 've tried using a .jpg and a .tiff - no difference - no colour. Advice, please?
    In YaST hardware printer, select "All Options for the Current Driver" and make sure that Output Mode is not set to Gray.
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,077
    Blog Entries
    1

    Default Re: Epson, WF-7510, Colour missing

    What the others already said.
    openSUSE Leap 15.2; KDE Plasma 5

  5. #5
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    343

    Default Re: AW: Epson, WF-7510, Colour missing

    Quote Originally Posted by Sauerland View Post
    Maybe you have Black/white as standard?

    Goto:
    localhost:631
    in your Browser and change it.

    If password is asked, its the root one.
    How? This is what shows for the Epson printer

    Description: Epson WF-7510 with driver Epson WF-7510 Series, Epson Inkjet Printer Driver (ESC/P-R) for Linux
    Location:
    Driver: Epson WF-7510 Series, Epson Inkjet Printer Driver (ESC/P-R) for Linux (color, 2-sided printing)
    Connection: usb://EPSON/WF-7510%20Series?serial=4D5853593033383345&interface=1
    Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

    Where do i go from here?
    bob@rsmits.ca
    First Law of Laboratory Work: Hot glass looks exactly the same as cold glass.

  6. #6
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    343

    Unhappy Re: Epson, WF-7510, Colour missing

    Quote Originally Posted by crmrhm View Post
    In YaST hardware printer, select "All Options for the Current Driver" and make sure that Output Mode is not set to Gray.
    Thanks for the reply, Howard.

    When I look at printer configurations in Yast and then edit my Epson file I get a choice of three drivers - the one from Epson and two Gutenprint ones.

    Epson WF-7510 Series, Epson Inkjet Printer Driver (ESC/P-R) for Linux [manufacturer-PPDs/epson-inkjet-printer-escpr/Epson-WF-7510_Series-epson-escpr-en.ppd.gz]

    Epson WF-7510 Series - CUPS+Gutenprint v5.2.14 [gutenprint/5.2/C/stp-escp2-wf7510.5.2.ppd.gz]

    Epson WF-7510 Series - CUPS+Gutenprint v5.2.14 Simplified [gutenprint/5.2/C/stp-escp2-wf7510.5.2.sim.ppd.gz]

    I've tried selecting each driver file, then editing it to get to "All Options for the Current Driver" and I find with the Epson Printer Driver it says It is set to colour, with the first Gutenprint driver it says Colormodel/Color Model RGB, and with the last gutenprint driver it sys the same - Color model RGB. In addition, the Epson driver won't let me select letter size paper as it only offers European sizes.
    bob@rsmits.ca
    First Law of Laboratory Work: Hot glass looks exactly the same as cold glass.

  7. #7
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    483

    Default Re: AW: Epson, WF-7510, Colour missing

    Quote Originally Posted by robertsmits View Post
    How? This is what shows for the Epson printer

    Description: Epson WF-7510 with driver Epson WF-7510 Series, Epson Inkjet Printer Driver (ESC/P-R) for Linux
    Location:
    Driver: Epson WF-7510 Series, Epson Inkjet Printer Driver (ESC/P-R) for Linux (color, 2-sided printing)
    Connection: usb://EPSON/WF-7510%20Series?serial=4D5853593033383345&interface=1
    Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

    Where do i go from here?
    On that same page, click the Administration button. In the drop-down menu, click Set Default Options. Is there a selection there for color? (My printer is B&W, so of course I see no option.)
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  8. #8
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    343

    Default Re: AW: Epson, WF-7510, Colour missing

    Quote Originally Posted by crmrhm View Post
    On that same page, click the Administration button. In the drop-down menu, click Set Default Options. Is there a selection there for color? (My printer is B&W, so of course I see no option.)
    Yes. It's set to Color RGB

    BTW, what are the login and password for CUPS?

    I tried to change the duplex setting and it seems to think changing it is forbidden.

    Bob
    bob@rsmits.ca
    First Law of Laboratory Work: Hot glass looks exactly the same as cold glass.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,873

    Default AW: Epson, WF-7510, Colour missing

    BTW, what are the login and password for CUPS?
    See here in my first post:
    Quote Originally Posted by Sauerland View Post
    Maybe you have Black/white as standard?

    Goto:
    localhost:631
    in your Browser and change it.

    If password is asked, its the root one.

  10. #10
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    343

    Default Re: Epson, WF-7510, Colour missing

    Quote Originally Posted by deano_ferrari View Post
    What the others already said.
    Thanks, Deano - in Cups admin it's set to color RGB. In Yast, it's set to color.I have no idea what to do now . I need to get some of my software working. Right now I'm making sure I have everyhing backed up onto some portable large drives.

    I know the Epson printer runs on Win 10, so there does't seem to be anything wrong with the printer itself.
    bob@rsmits.ca
    First Law of Laboratory Work: Hot glass looks exactly the same as cold glass.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •