Hello,
I am not sure if this belongs to hardware or wifi section but the thread is specifically about a wifi card. I've had a string of Lenovo laptops utilizing Intel(R) Centrino(R) Advanced-N 6205 wifi cards. Lenovo T420, 430, X230 and W530. I'm fairly certain that this card does not play nice with Kernel 4.* in general since I had this issue in other distros that utilize Kernel 4.* as well. My old solution was to upgrade to N 6300, and this is not an option for me right now.

I am currently having issues to get it to work reliably on my Lenovo W530 with OpenSUSE LEAP 15.1. The issue is that a wrong driver is loaded on boot, and wifi card tries to connect to a saved wifi network, fails then crashes and the current best solution for me is to unload and reload the wifi card and hope for the best.
Code:
sudo rmmod iwldvm && sudo rmmod iwlwifi && sudo modprobe iwlwifi
Someone else had a similar issue in an older version of LEAP (https://forums.opensuse.org/showthre...-wasnt-working), but his "conclusion" followed a fresh install.

I am curious, has anyone figured out which driver needs to be blacklisted to not make Intel Centrino Advanced N6205 to work properly?