Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: openSuse Leap 15.1: Apache is extremely slow

  1. #1
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    422

    Default openSuse Leap 15.1: Apache is extremely slow

    Hello.

    I've been developing web apps with LAMP, the Apache is on my hard drive, wasn't using virtual hosts, just a simlink to the htdocs folder. Everything was fast and good.

    Then I've started playing with Laravel for some time, virtual box, vagrant, virtual hosts etc. Laravel seemed pretty fast, maybe because I haven't made heavy DBs.

    Now I went back to my localhost and find it extreeeeeeemly slow. It takes about 10 s to load any page from my local site which used to load in 1-2 s before. I thought it might be something to do with the virtual hosts and all. So I've removed them all, I've even reinstalled Apache and PHP, I've deleted ALL settings and configs, removed all rewrites etc. - same thing, the server is very slow. I tried the sites in Chromium - same slow.

    I have not touched any MySql settings or configs ever, so it should not be the cause.

    Would you have any ideas what might have caused this and how I can fix this?

    Thank you.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,412
    Blog Entries
    2

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    First,
    You might reboot and see if that improves performance.
    You can also run top and free to monitor system resource usage.

    You should also know that Apache, particularly as part of a LAMP configuration can require tuning.
    A lot will depend on the type of website code you're running.
    If you're running a website that serves non-interactive content, a script-based webserver like nginx, or many from your choice of coding (nodejs, ruby, python, etc) can perform better and might not require any tuning.

    There's a ton of articles written about Apache tuning, and there are many tools that can test various settings.

    Bottom line,
    This is a topic that's hard to discuss in a Forum.
    Every situation is individual to the hardware you're running on, other software running and your website.

    Troubleshooting SOP should be same as everything else,
    Try to narrow down your problem bit by bit which is why I suggest the reboot and system monitoring to start... try to first determine if something in your system other than your LAMP might be the cause before you start looking at your webserver/website itself.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    422

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    That's exactly the reason why I wrote here because I've exhausted all other options, i.e. rebooting, reinstalling, tuning and all. I'm basically running a fresh install of LAMP here but it's still slow.

    As I said, everything was running fast and ok a few weeks ago.

    I'm wondering what might have caused it to run much slower with the exactly same code (I haven't touched any of the server files, as I said I was playing with Laravel from my home folder and virtual hosts, the site file remain in the htdocs unchanged). Because it's never happened before on Linux. I haven't had a single problem with openSuse for years, this post is like the first one in 5 years. That's why I'm so puzzled.

    It may not even be LAMP, maybe something else on Linux. What should I check for?

    I've checked the memory usage, it's got a few mysql, 6 Web processes, a dozen of httpd-prefork - are these quantities normal? WebExtensions take >300,000 K. I have 16 GB of RAM though.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  4. #4
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    422

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    I've disabled all desktop search stuff and cleared everything with the Sweeper. It improved the server speed a lot, now a simple page loads in 5 sec vs > 10 sec before. But this is still not enough, still too long. The pages opened within a second or two before. Something else is still interfering or slowing it down.
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,742
    Blog Entries
    1

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    openSUSE Leap 15.2; KDE Plasma 5

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,705
    Blog Entries
    1

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    Quote Originally Posted by linuxoidoz View Post
    That's exactly the reason why I wrote here because I've exhausted all other options, i.e. rebooting, reinstalling, tuning and all. I'm basically running a fresh install of LAMP here but it's still slow.

    As I said, everything was running fast and ok a few weeks ago.

    I'm wondering what might have caused it to run much slower with the exactly same code (I haven't touched any of the server files, as I said I was playing with Laravel from my home folder and virtual hosts, the site file remain in the htdocs unchanged). Because it's never happened before on Linux. I haven't had a single problem with openSuse for years, this post is like the first one in 5 years. That's why I'm so puzzled.

    It may not even be LAMP, maybe something else on Linux. What should I check for?

    I've checked the memory usage, it's got a few mysql, 6 Web processes, a dozen of httpd-prefork - are these quantities normal? WebExtensions take >300,000 K. I have 16 GB of RAM though.
    Apache is really fast even on the small i3-4130. The i7-6700K has:

    Code:
    erlangen:~ # systemctl status apache2.service 
    ● apache2.service - The Apache Webserver
         Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled; vendor preset: disabled)
         Active: active (running) since Mon 2020-06-15 05:04:08 CEST; 1h 52min ago
       Main PID: 755 (httpd-prefork)
         Status: "Processing requests..."
          Tasks: 6
         Memory: 8.1M
         CGroup: /system.slice/apache2.service
                 ├─755 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache>
                 ├─827 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache>
                 ├─828 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache>
                 ├─829 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache>
                 ├─830 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache>
                 └─831 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache>
    
    Jun 15 05:04:08 erlangen systemd[1]: Starting The Apache Webserver...
    Jun 15 05:04:08 erlangen systemd[1]: Started The Apache Webserver.
    erlangen:~ #
    Watch for additional messages in the journal. Tinkering with the network can have nasty side effects:

    Code:
    erlangen:~ # journalctl  -b -q --no-hostname -o short-monotonic -u apache2.service 
    [    3.946907] systemd[1]: Starting The Apache Webserver...
    [    4.106248] systemd[1]: Started The Apache Webserver.
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  7. #7
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    422

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    Here's what I got:

    Code:
    systemctl status apache2.service
    ● apache2.service - The Apache Webserver
       Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled; vendor preset: disabled)
       Active: active (running) since Mon 2020-06-15 13:15:33 +11; 3h 6min ago
     Main PID: 1683 (httpd-prefork)
       Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
        Tasks: 11
       CGroup: /system.slice/apache2.service
               ├─1683 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─1839 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─1844 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─3232 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─3677 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─4467 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─4954 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─4958 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─5203 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─5320 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               └─5326 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
    
    Jun 15 13:15:27 linux-hvw6 systemd[1]: Starting The Apache Webserver...
    Jun 15 13:15:30 linux-hvw6 start_apache2[1683]: AH00557: httpd-prefork: apr_sockaddr_info_get() failed for linux-hvw6
    Jun 15 13:15:30 linux-hvw6 start_apache2[1683]: AH00558: httpd-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
    Jun 15 13:15:33 linux-hvw6 systemd[1]: Started The Apache Webserver.
    @deano_ferrari, thank you for the references!
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  8. #8
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    422

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    and this:

    Code:
    httpd -V
    Server version: Apache/2.4.33 (Linux/SUSE)
    Server built:   2020-04-28 05:50:17.000000000 +0000
    Server's Module Magic Number: 20120211:76
    Server loaded:  APR 1.6.3, APR-UTIL 1.6.1
    Compiled using: APR 1.6.3, APR-UTIL 1.6.1
    Architecture:   64-bit
    Server MPM:     prefork
      threaded:     no
        forked:     yes (variable process count)
    Server compiled with....
     -D APR_HAS_SENDFILE
     -D APR_HAS_MMAP
     -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
     -D APR_USE_PROC_PTHREAD_SERIALIZE
     -D APR_USE_PTHREAD_SERIALIZE
     -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
     -D APR_HAS_OTHER_CHILD
     -D AP_HAVE_RELIABLE_PIPED_LOGS
     -D DYNAMIC_MODULE_LIMIT=256
     -D HTTPD_ROOT="/srv/www"
     -D SUEXEC_BIN="/usr/sbin/suexec"
     -D DEFAULT_PIDLOG="/run/httpd.pid"
     -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
     -D DEFAULT_ERRORLOG="/var/log/apache2/error_log"
     -D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
     -D SERVER_CONFIG_FILE="/etc/apache2/httpd.conf"
    Reading what deano_ferrari posted, they say "This MPM is not suitable for use with non-thread-safe modules like mod_php, for which a replacement such a PHP-FPM must be used instead". I have the prefork module installed, the other two (worker and event) are not installed, and I'm using the mod-php. Could this be the problem? Should I uninstall the mpm and install either the worker or event? Or can I have all 3 installed? PHP-FPM i snot installed either. What's the best combination of modules with Apache and PHP for my local dev machine (not production server)?
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

  9. #9
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,705
    Blog Entries
    1

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    Quote Originally Posted by linuxoidoz View Post
    Here's what I got:

    Code:
    systemctl status apache2.service
    ● apache2.service - The Apache Webserver
       Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled; vendor preset: disabled)
       Active: active (running) since Mon 2020-06-15 13:15:33 +11; 3h 6min ago
     Main PID: 1683 (httpd-prefork)
       Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
        Tasks: 11
       CGroup: /system.slice/apache2.service
               ├─1683 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─1839 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─1844 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─3232 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─3677 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─4467 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─4954 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─4958 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─5203 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               ├─5320 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
               └─5326 /usr/sbin/httpd-prefork -DSYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTE>
    
    Jun 15 13:15:27 linux-hvw6 systemd[1]: Starting The Apache Webserver...
    Jun 15 13:15:30 linux-hvw6 start_apache2[1683]: AH00557: httpd-prefork: apr_sockaddr_info_get() failed for linux-hvw6
    Jun 15 13:15:30 linux-hvw6 start_apache2[1683]: AH00558: httpd-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
    Jun 15 13:15:33 linux-hvw6 systemd[1]: Started The Apache Webserver.
    @deano_ferrari, thank you for the references!
    I have seen similar messages and fixed /etc/hosts:

    Code:
    erlangen:~ # cat /etc/hosts
    #
    # hosts         This file describes a number of hostname-to-address
    #               mappings for the TCP/IP subsystem.  It is mostly
    #               used at boot time, when no name servers are running.
    #               On small systems, this file can be used instead of a
    #               "named" name server.
    # Syntax:
    #    
    # IP-Address  Full-Qualified-Hostname  Short-Hostname
    #
    
    
    # special IPv6 addresses
    
    
    127.0.0.1       localhost
    ::1     localhost ipv6-localhost ipv6-loopback
    fe00::0 ipv6-localnet
    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    192.168.178.2   erlangen.fritz.box     erlangen
    192.168.178.3   erlangen.fritz.box     erlangen
    
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  10. #10
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    422

    Default Re: openSuse Leap 15.1: Apache is extremely slow

    my hosts:

    Code:
    127.0.0.1       localhost
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet 
    
    ff00::0         ipv6-mcastprefix 
    ff02::1         ipv6-allnodes 
    ff02::2         ipv6-allrouters 
    ff02::3         ipv6-allhosts 
    192.168.1.2     dataserver dataserver
    Which Apache modules should I enable and how? How can I swap prefork to event and mod-php to php-fpm?
    Desktop: openSUSE Leap 15 | KDE 5 | Intel i-7500 | Asus ROG STRIX Z270H GAMING | Asus EX-GTX1050TI-O4G nVidia
    Laptop Asus UL30A: openSUSE Leap 15 | KDE 5 | Intel SU7300

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •