Results 1 to 5 of 5

Thread: wireless password not saving

  1. #1

    Default wireless password not saving

    I'm using kde and can't get my wifi password to save and have my wifi auto connect on my laptop. Tried using kwallet, tried turning off kwallet and nothing works.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,926
    Blog Entries
    2

    Default Re: wireless password not saving

    Recommend you verify you are using Network Manager to manage your network connections.
    Besides actually making and modifying network connections, you can also inspect

    YaST > Network Settings > Global Options tab

    If you somehow are using Wicked (using classic ifup/ifdown commands), then network settings won't be saved whenever your network connection changes.

    If you verify the setting is correct, please submit a bug to https://bugzilla.opensuse.org since you appear to be using 15.2 which is still in Beta.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: wireless password not saving

    Quote Originally Posted by tsu2 View Post
    Recommend you verify you are using Network Manager to manage your network connections.
    Besides actually making and modifying network connections, you can also inspect

    YaST > Network Settings > Global Options tab

    If you somehow are using Wicked (using classic ifup/ifdown commands), then network settings won't be saved whenever your network connection changes.

    If you verify the setting is correct, please submit a bug to https://bugzilla.opensuse.org since you appear to be using 15.2 which is still in Beta.

    TSU
    Thanks for the tips! I though I'm only one who have this problem lol

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,473

    Exclamation Re: wireless password not saving

    Quote Originally Posted by 1chip View Post
    I'm using kde . . . Tried using kwallet, tried turning off kwallet and nothing works.
    If KDE Plasma then, KWallet is compulsory for storing WLAN/WiFi SSID passphrases and passwords.

    Unfortunately, the openSUSE documentation isn't explicit about this.
    Therefore, other sources are needed:
    KDE Plasma – KWallet Handbook: <https://docs.kde.org/stable5/en/kdeu...et5/index.html>.
    Unlocking KWallet at login: <https://wiki.archlinux.org/index.php/KDE_Wallet>.

    Bottom line:
    1. Create a Wallet, with classic Blowfish encryption, named “kdewallet”.
    2. The password to open the Wallet is, exactly that password you use to login to a KDE Plasma GUI session.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,546
    Blog Entries
    3

    Default Re: wireless password not saving

    Quote Originally Posted by 1chip View Post
    I'm using kde and can't get my wifi password to save
    Right click on the tray applet for NetworkManager, and go to Configure Network Connections.

    Use Edit Connection on your WiFi connection.
    Go to the security entry, where you enter the password. There should be an option there where you can choose where to save the password. Select the option to save to unencrypted file.

    That should solve your problem.

    Although that might look dangerous, it isn't. The unencrypted file is owned by the root user, and not accessible by ordinary users, with the exception that you can still access it since you are the owner of that connection.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •