Results 1 to 4 of 4

Thread: Dell Optiplex 7020: Can't turn off...

  1. #1

    Angry Dell Optiplex 7020: Can't turn off...

    Hi!

    Have here a Dell Optiplex 7020 with BIOS A18 (latest). When I shut down Leap 15.2 (in GUI, with "shutdown -h now" or via "init 0") the machine shuts down, but after 1-2 seconds it reboots again. I can press the power button, but after some 1-2 seconds it will reboot again. If a pull the plug it will stop (of course), but reboot again on plugging in again, but with pressing the power button again it will shut up, finally. Very annoying.

    The BIOS option "Power Management" -> "AC Recovery" is set to "Last power state", as the machine is sometimes used as a router/firewall.

    With Win 7 or BSD I have no such problems on this machine (was comparable with Leap 15.1, but I could stop the rebooting by pressing the power button).

    Any ideas how to stop this? :-(
    Kind regards

    raspu

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,068
    Blog Entries
    1

    Default Re: Dell Optiplex 7020: Can't turn off...

    I don't have a definitive answer here, but FWIW I just wanted to share this long-running kernel bug report that may be of interest to you. Maybe worth trying one of the quirks mentioned?
    openSUSE Leap 15.2; KDE Plasma 5

  3. #3

    Default Re: Dell Optiplex 7020: Can't turn off...

    Hi!

    I added

    Code:
    xhci_hcd.quirks=270336
    to the kernel parameters in YaST -> Bootloader and now the machine shut's up eeh down correctly!

    Many thanks!

    :-)

    PS: Wow, the initial report dates back to 2013! Nobody really cares? A problem with the USB-driver? Hmmm... forgot to say: Keybord and mouse are connected via a USB-"switch":

    https://www.aten.com/global/en/produ...witches/us424/
    Kind regards

    raspu

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,068
    Blog Entries
    1

    Default Re: Dell Optiplex 7020: Can't turn off...

    Quote Originally Posted by suse_rasputin View Post
    Hi!

    I added

    Code:
    xhci_hcd.quirks=270336
    to the kernel parameters in YaST -> Bootloader and now the machine shut's up eeh down correctly!

    Many thanks!

    :-)
    Glad that boot parameter did the trick. I've since seen a number of similar threads/discussions like this. It's also mentioned here...
    https://wiki.archlinux.org/index.php...after_shutdown
    openSUSE Leap 15.2; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •