Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 49

Thread: realtek wireless

  1. #11

    Default Re: realtek wireless

    Code:
    0:100.0   Ethernet controller [0200]: Realtek Semiconductor Co. Ltd.  RTL8111/8168/8411 PCI Express Gigabit Ethernet controller [10ec:8168] (rev 15)
                   Subsystem:  Hewlett-Packard Company Device [103c:832n]
                   Kernel driver in use: r8169
                   Kernel modules: r8169
    
    0:200.0   Network controller [0280]:  Realtek Semiconductor Co. Ltd.  RTL8723DE 802.11 b/g/n PCIe Adapter [10ec:d723]
                   Subsystem:  Hewlett-Packard Company Device [103c:8319]

    Posting better now. Bad extension setting.
    Last edited by deano_ferrari; 06-Jun-2020 at 21:28.

  2. #12
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,583
    Blog Entries
    1

    Default Re: realtek wireless

    Ok, thanks for confirming.

    I assume that you're currently using wired ethernet for connectivity. Try this
    https://github.com/smlinux/rtl8723de

    Some prep first....
    Code:
    sudo zypper in dkms
    You may also need to do
    Code:
    sudo zypper install --type pattern devel_basis
    Code:
    sudo zypper in git
    Then as per the instructions in the github page...
    Code:
    git clone https://github.com/smlinux/rtl8723de.git -b current
    dkms add ./rtl8723de
    dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
    depmod -a
    reboot
    See if that helps with getting your wifi working. (Eventually, someone will build an OBS package for this.)
    Last edited by deano_ferrari; 06-Jun-2020 at 21:43.
    openSUSE Leap 15.2; KDE Plasma 5

  3. #13

    Default Re: realtek wireless

    Quote Originally Posted by deano_ferrari View Post
    Ok, thanks for confirming.

    I assume that you're currently using wired ethernet for connectivity. Try this
    https://github.com/smlinux/rtl8723de

    Some prep first....
    Code:
    sudo zypper in dkms
    You may also need to do
    Code:
    sudo zypper install --type pattern devel_basis
    Code:
    sudo zypper in git
    Then as per the instructions in the github page...
    Code:
    git clone https://github.com/smlinux/rtl8723de.git -b current
    dkms add ./rtl8723de
    dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
    depmod -a
    reboot
    See if that helps with getting your wifi working. (Eventually, someone will build an OBS package for this.)

    I'm actually jumping between os's on my laptop. This os has wireless connected. I have a file RTL8723DE.ymp in my downloads (Leap 15.1) Ran it with yast and it only partially installed after a warning screen. I'm assuming because of no internet connection. Do I need that file still? Here shortly I will be able to connect to ethernet again and will run those commands.

  4. #14
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,583
    Blog Entries
    1

    Default Re: realtek wireless

    Quote Originally Posted by new_user View Post
    I'm actually jumping between os's on my laptop. This os has wireless connected. I have a file RTL8723DE.ymp in my downloads (Leap 15.1)...
    Yes, that won't work. In any case, not a good idea to install packages intended for different distro versions.

    Here shortly I will be able to connect to ethernet again and will run those commands.
    Yes, get wired connectivity sorted first.
    openSUSE Leap 15.2; KDE Plasma 5

  5. #15

    Default Re: realtek wireless

    Quote Originally Posted by deano_ferrari View Post
    Yes, that won't work. In any case, not a good idea to install packages intended for different distro versions.


    Yes, get wired connectivity sorted first.

    Everything ran without issue. Rebooted and no sign of wireless. Wired working fine.

  6. #16
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,384

    Default AW: realtek wireless

    You can use rtlwifi_new-extended:

    Here:
    Code:
    modprobe -c | grep -i "10ec.*d723"
    alias pci:v000010ECd0000D723sv*sd*bc*sc*i* rtl8723de
    Code:
    modinfo rtl8723de
    filename:       /lib/modules/5.7.0-3.gad96a07-default/updates/rtlwifi/rtl8723de/rtl8723de.ko
    firmware:       rtlwifi/rtl8723defw.bin
    description:    Realtek 8723DE 802.11n PCI wireless
    version:        20200502
    license:        GPL
    author:         Realtek WlanFAE <wlanfae@realtek.com>
    author:         PageHe  <page_he@realsil.com.cn>
    suserelease:    openSUSE Tumbleweed
    srcversion:     BDFD1CF50FD67E9CB7E6F41
    alias:          pci:v000010ECd0000D723sv*sd*bc*sc*i*
    depends:        rtlwifi,rtl_pci,btcoexist,rtl8723-common,phydm_mod
    retpoline:      Y
    name:           rtl8723de
    vermagic:       5.7.0-3.gad96a07-default SMP mod_unload modversions 
    sig_id:         PKCS#7
    signer:         home:Sauerland OBS Project
    sig_key:        30:57:31:23:30:21:06:03:55:04:03:0C:1A:68:6F:6D:65:3A:53:61:
                    75:65:72:6C:61:6E:64:20:4F:42:53:20:50:72:6F:6A:65:63:74:31:
                    30:30:2E:06:09:2A:86:48:86:F7:0D:01:09:01:16:21:68:6F:6D:65:
                    3A:53:61:75:65:72:6C:61:6E:64:40:62:75:69:6C:64:2E:6F:70:65:
                    6E:73:75:73:65:2E:6F:72:67:02:09:00:B1:7C:31:01:2A:80:C9:90
    sig_hashalgo:   sha256
    signature:      4A:E2:02:03:D4:73:D9:A1:18:ED:5F:78:4D:80:BE:A2:D9:57:17:AB:
                    43:42:5C:5B:8D:19:2A:CF:4D:EF:79:0F:A0:7C:B3:74:22:72:B6:7C:
                    31:D9:F9:F4:69:00:25:D9:82:51:AB:C9:A7:52:F6:68:50:28:83:B1:
                    6C:5E:14:A5:4C:3D:AF:F9:8B:10:A9:FB:1A:0B:22:2E:BF:2B:78:7F:
                    DB:31:49:0D:3F:C1:89:8B:F4:75:30:CD:26:44:C5:86:4A:AF:4C:72:
                    97:34:6F:B9:5D:47:01:F4:3F:9A:98:3E:51:05:0F:CC:90:16:03:88:
                    40:13:20:31:F0:F8:34:EE:01:C6:58:3C:A9:6A:5A:01:FB:B1:51:5C:
                    28:65:14:DC:E3:C4:D1:67:41:7B:C5:4A:9F:E7:73:06:29:89:22:C6:
                    F1:4D:D2:B0:36:5B:80:04:F5:C7:24:49:3B:80:C1:BD:C4:4A:CC:20:
                    C5:2D:F1:CC:47:06:F4:C1:D2:AD:AA:21:D9:85:D6:BF:83:15:04:AE:
                    9D:2F:73:BB:A9:DC:0C:ED:17:0E:0C:C1:F7:55:E8:11:70:2D:3F:D5:
                    65:A2:E1:51:BC:6B:00:9D:E1:B7:8E:FB:CB:10:D6:B4:A7:42:43:4C:
                    88:90:F4:B2:92:58:2B:24:DA:D1:67:E6:2F:95:0D:FF
    parm:           dma64:bool
    parm:           swenc:Set to 1 for software crypto (default 0)
     (bool)
    parm:           ips:Set to 0 to not use link power save (default 1)
     (bool)
    parm:           swlps:Set to 1 to use SW control power save (default 0)
     (bool)
    parm:           fwlps:Set to 1 to use FW control power save (default 1)
     (bool)
    parm:           msi:Set to 1 to use MSI interrupts mode (default 1)
     (bool)
    parm:           aspm:Set to 1 to enable ASPM (default 0)
     (int)
    parm:           debug_level:Set debug level (0-5) (default 0) (int)
    parm:           debug_mask:Set debug mask (default 0) (ullong)
    parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
     (bool)
    parm:           int_clear:Set to 0 to disable interrupt clear before set (default 0)
     (bool)
    parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
     (int)
    You can enable this Repo to get always the newest one:
    Code:
    zypper ar -f https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.2/ realtek
    Code:
    zypper in rtlwifi_new-extended-kmp-default
    After the Release of openSUSE Leap 15.2 I will enable the Update Repo for the drivers and you have to switch to these drivers.

    But:
    The rtlwifi source will not get any update, only I will patch if necessary because:
    https://github.com/lwfinger/rtlwifi_new/

  7. #17
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,583
    Blog Entries
    1

    Default Re: realtek wireless

    Quote Originally Posted by new_user View Post
    Everything ran without issue. Rebooted and no sign of wireless. Wired working fine.
    You could try loading the driver manually with
    Code:
    sudo modprobe rtl8723de
    I see user Sauerland has now replied with the suggestion to use his repo (providing rtlwifi_new-extended), so that may work for you.
    Last edited by deano_ferrari; 06-Jun-2020 at 23:39.
    openSUSE Leap 15.2; KDE Plasma 5

  8. #18

    Default Re: realtek wireless

    Quote Originally Posted by deano_ferrari View Post
    You could try loading the driver manually with
    Code:
    sudo modprobe rtl8723de
    I see user Sauerland has now replied with the suggestion to use his repo (providing rtlwifi_new-extended), so that may work for you.
    This is what I got running that last command:

    modprobe: FATAL: Module rtl8723de not found in directory /lib/modules/4.12.14-lp151.28.48-default

    Not having any luck with Sauerland commands either. Not sure I'm running them correctly. Just getting new command lines.

  9. #19
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,583
    Blog Entries
    1

    Default Re: realtek wireless

    Quote Originally Posted by new_user View Post
    This is what I got running that last command:

    modprobe: FATAL: Module rtl8723de not found in directory /lib/modules/4.12.14-lp151.28.48-default
    That is a Leap 15.1 kernel! Yet, you mentioned this was being done for openSUSE Leap 15.2.
    openSUSE Leap 15.2; KDE Plasma 5

  10. #20
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,583
    Blog Entries
    1

    Default Re: realtek wireless

    Not having any luck with Sauerland commands either. Not sure I'm running them correctly. Just getting new command lines.
    Show us the configured repos please...
    Code:
    zypper lr -d
    openSUSE Leap 15.2; KDE Plasma 5

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •