Results 1 to 8 of 8

Thread: nvidia (closed source) driver is missing dependencies

  1. #1

    Question nvidia (closed source) driver is missing dependencies

    Hello forum,
    as I did not find any related post, I just want to ask, if somebody else has the problems, that the current nvidia (closed source) drivers cannot be installed due to missing dependencies?

    System info:
    Operating System: openSUSE Leap 15.2
    KDE Plasma Version: 5.18.5
    KDE Frameworks Version: 5.70.0
    Qt Version: 5.12.7
    Kernel Version: 5.3.18-lp152.17-default
    OS Type: 64-bit
    Processors: 5 × AMD Phenom(tm) II X6 1055T Processor
    Memory: 7,8 GiB

    The graphic card is a nvidia GeForce GTX 560 Ti

    I use the nvidia repository:
    https://download.nvidia.com/opensuse/leap/15.2

    The symptom is:
    ksym(default:set_page_dirty_lock) = f9bf7120 benötigt von nvidia-gfxG04-kmp-default-390.132_k5.3.18_lp152.10-lp152.14.1.x86_64 wird nirgends zur Verfügung gestellt


    The problem exists since I tried the first 15.2 beta and still persists in the current 15.2 RC.
    While I know, that this is a problem of nvidia corp that provides the driver, I am surprised that I did not find any posts so far about it.

    Did anybody else run into this?
    Can I do anything to provide the requirement (did I miss any module?)

    Thanks for some pointers...
    Greetings
    Bernd

  2. #2
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: nvidia (closed source) driver is missing dependencies

    Quote Originally Posted by bjohanns View Post
    Hello forum,
    as I did not find any related post, I just want to ask, if somebody else has the problems, that the current nvidia (closed source) drivers cannot be installed due to missing dependencies?

    System info:
    Operating System: openSUSE Leap 15.2
    KDE Plasma Version: 5.18.5
    KDE Frameworks Version: 5.70.0
    Qt Version: 5.12.7
    Kernel Version: 5.3.18-lp152.17-default
    OS Type: 64-bit
    Processors: 5 × AMD Phenom(tm) II X6 1055T Processor
    Memory: 7,8 GiB

    The graphic card is a nvidia GeForce GTX 560 Ti

    I use the nvidia repository:
    https://download.nvidia.com/opensuse/leap/15.2

    The symptom is:
    ksym(default:set_page_dirty_lock) = f9bf7120 benötigt von nvidia-gfxG04-kmp-default-390.132_k5.3.18_lp152.10-lp152.14.1.x86_64 wird nirgends zur Verfügung gestellt


    The problem exists since I tried the first 15.2 beta and still persists in the current 15.2 RC.
    While I know, that this is a problem of nvidia corp that provides the driver, I am surprised that I did not find any posts so far about it.

    Did anybody else run into this?
    Can I do anything to provide the requirement (did I miss any module?)

    Thanks for some pointers...
    Greetings
    Bernd
    Hi Bernd,
    How are you installing this? Are you using the installation .bin executable, zypper, rpm? For GPU as old as GTX 560Ti, you should also check which driver is compatible with your GPU and also you can use the driver from OpenSUSE repository.

  3. #3
    Join Date
    Jan 2012
    Location
    rural MD, USA
    Posts
    5

    Default Re: nvidia (closed source) driver is missing dependencies

    I'm having the exact same problem. It's an older card, a GT 430 in my case, which requires the 390 series driver, or the G04 in SUSE terms. I'm using the nouveau driver currently, which works fine. Assuming that's what is meant by the driver in the openSUSE repos.

    What the op (presumably) and I both have done is added the nvidia repo, which (if memory serves) comes up when Yast is told to search for Community repos. This works fine for me in Tumbleweed, surprisingly not in Leap... I have not and will not try "the hard way" via the nvidia-supplied .run file, since nouveau is working. I would prefer to use the nvidia driver if possible though.

    As a side note, nouveau was always a problem on my old-old card, a GT 240 (340 series or G03), with predictable hard freezes on any distro, though openSUSE seemed to take longer to finally do so...

  4. #4
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: nvidia (closed source) driver is missing dependencies

    With LEAP 15.0 and 15.1 I haven't had any problems but 15.2 is still in betas and I can't speak for much.

    The error message: ksym(default:set_page_dirty_lock) =
    shows as part of https://opensuse.pkgs.org/15.2/nvidi...86_64.rpm.html
    which should be part of kernel 5.3.18 https://pkgs.org/download/ksym(defau...ge_dirty_lock)

    what's your kernel version?
    Code:
    uname -r
    5.3.18-lp152.17-default may be "slightly" out of date kernel-default-5.3.18-lp152.17.3.x86_64.rpm

    I still wish to know, what method did you use to install the driver?

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,844
    Blog Entries
    14

    Default Re: nvidia (closed source) driver is missing dependencies

    Quote Originally Posted by SJLPHI View Post
    With LEAP 15.0 and 15.1 I haven't had any problems but 15.2 is still in betas and I can't speak for much.

    The error message: ksym(default:set_page_dirty_lock) =
    shows as part of https://opensuse.pkgs.org/15.2/nvidi...86_64.rpm.html
    which should be part of kernel 5.3.18 https://pkgs.org/download/ksym(defau...ge_dirty_lock)

    what's your kernel version?
    Code:
    uname -r
    5.3.18-lp152.17-default may be "slightly" out of date kernel-default-5.3.18-lp152.17.3.x86_64.rpm

    I still wish to know, what method did you use to install the driver?
    If you look at the link provided by the OP you can see he's using the rpm packages.

    @Bernd The current NVIDIA packages don't match the current Leap 15.2 kernel.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: nvidia (closed source) driver is missing dependencies

    Hello,
    thanks for your replies.

    To your questions:

    - I installed the driver (or was trying to install the driver) using the YAST "add / remove software" administration tool. I added the nvidida leap 15.2 repository and searched for "nvidia". Both offered packages (G04* and G05*) are missing this dependency.
    - According to knurpht, the missing dependency is caused by a mismatch of the targeted kernel of the provided rpm-packages by NVidia and the current Leap 15.2 kernel.

    I think, that something should be done for that situation, as currently the "standard way" of adding the nvidia drivers does not work for Leap 15.2.

    I tried the "run" package provided by nvidia (as described in the SuSE wiki "the hard way") which worked. I.e. the driver that is installed by the run package is compiled successfully and works flawless (as far as I have tested).

    But in my opinion that is not a good way for the general Leap "average user" as it has several pitfalls which can cause your system to be unusable thereafter (I checked this on my test box - so I could go about it relaxed and succeeded in the second take - after installing the complete system anew because I managed to screw it up in the first try - nvidia driver did not load and I could not restore nouveau correctly and was stuck with runlevel 3).

    Is this to be addressed by nvidia, or can leap do something about this? Who triggers, that this is somehow resolved?

    Thanks for your support.
    Greetings
    Bernd

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,882

    Default AW: nvidia (closed source) driver is missing dependencies


  8. #8
    Join Date
    Jan 2012
    Location
    rural MD, USA
    Posts
    5

    Default Re: nvidia (closed source) driver is missing dependencies

    After reading this thread and the comments over where sauerland commented, I decided to go ahead and try installing the driver using zypper's second option (break the nvidia package by ignoring some of its dependencies or whatever it says exactly). It worked perfectly. I assume the dependency on ksym or whatever will soon be fixed, but anyone else in this situation right now can probably do what I did with equal success.

    I was starting to get some weird flickering with nouveau, so I figured I'd give it a shot...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •