Hallo,


Ik gebruik Darktable sinds een tijdje.
Dat programma bevalt prima en ik wil het in gaan zetten als mijn standaard RAW editor.
Ik gebruik nu Darktable 2.6.3, dat is de versie die standaard met OpenSUSE Leap 15.1 wordt meegeleverd.
Darktable 3.0.x is inmiddels uit maar die wordt nog niet in de standaard OpenSuSE Leap 15.1 repo geleverd.

Op de website van Darktable (https://www.darktable.org/install/) staat het volgende te lezen.
"If you need a newer version than what is included in your distribution, check out the third party packages section.
(https://www.darktable.org/install/#3rdparty)"

Voor de nieuwste versie van Darktable kom ik dan uiteindelijk op de pagina
(https://software.opensuse.org/downlo...kage=darktable) terecht.

En daar staat het volgende te lezen.
For openSUSE Leap 15.1 run the following as root:
zypper addrepo https://download.opensuse.org/reposi...darktable.repo
zypper refresh
zypper install darktable

Het is blijkbaar een "third party" repo, en wordt dus waarschijnlijk niet door OpenSuSE ondersteund maar wordt wel op
de website van OpenSuSE genoemd.
Dus ik neem aan dat dit een betrouwbare repo is ?

Darktable 2.6.3 uit de standaard OpenSuSE repo is nu geinstalleerd.
Als ik de bovenstaande zypper commando's uit voer wordt uiteraard de nieuwe Darktable geinstalleerd maar wel van een andere repo.

Dus "ziet" OpenSuSE dat er al een versie uit een andere repo is geinstalleerd en voert daarna een update vanaf de "nieuwe" repo uit,
of moet ik eerst zaken instellen zodat de update goed wordt uitgevoerd ?

De opbouw van de database van Darktable 3.0 is compleet anders dan de database van Darktable 2.6.3, dus de bestaande database
moet na de installatie door Darktable 3.0 geconverteerd worden.
Er staat al flink wat data in de "oude" versie van de database, dus uiteraard wil ik dat de upgrade goed gaat.
Uiteraard maak ik voor de upgrade een backup van de data, je weet maar nooit....

Wie helpt me met dit probleempje ?


Groet,
Flash2020