Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: PlayOnLinux

  1. #1

    Default PlayOnLinux

    Hi to all,
    Recently Tumbleweed updated and I can't use PlayOnLinux . I can't find the POL on yast (I installed from there last time) so I download the tar.z from POL webpage and tried to installed. I got this errors:
    Code:
    Looking for python... 2.7.18 - Traceback (most recent call last):
      File "/home/gaston/Descargas/playonlinux/python/check_python.py", line 1, in <module>
        import os, wxversion
    ImportError: No module named wxversion
    failed tests
    Looking for python2.7... 2.7.18 - Traceback (most recent call last):
      File "/home/gaston/Descargas/playonlinux/python/check_python.py", line 1, in <module>
        import os, wxversion
    ImportError: No module named wxversion
    failed tests
    Looking for python2.6... which: no python2.6 in (/home/gaston/bin:/usr/local/bin:/usr/bin:/bin:/home/gaston/.local/bin:/home/gaston/gcc-linaro-7.4.1-2019.02-x86_64_arm-linux-gnueabihf/bin/:/home/gaston/.local/bin:/home/gaston/gcc-linaro-7.4.1-2019.02-x86_64_arm-linux-gnueabihf/bin/)
    
    Looking for python2... 2.7.18 - Traceback (most recent call last):
      File "/home/gaston/Descargas/playonlinux/python/check_python.py", line 1, in <module>
        import os, wxversion
    ImportError: No module named wxversion
    failed tests
    Please install python before trying to run this program
    I have python - python 2.7 - python 3 - Wine already installed. Ttried to find python-wxWidget. Try to install python-gtk2.3 (gtk3) but cant find either of this two on yast. How do I solve this errors? How can I re-install POL on Tumbleweed?
    Regards
    Gastón

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,808
    Blog Entries
    15

    Default Re: PlayOnLinux

    Hi
    Is python3-wxPython installed, does POL support python3, python2 is deprecated from Tumbleweed...

    I see (well 19 days ago) they added python3 support as well as removing the deprecated wxversion and moved to wxPyhton
    https://github.com/PlayOnLinux/POL-POM-4
    https://github.com/PlayOnLinux/POL-P...6d585d89175546

    I would suggest a bug report to update to version 4.4 which would fix the issue (released 13 days ago) in Tumbleweed;

    openSUSE:Submitting bug reports - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: PlayOnLinux

    Thanks malcom for your quick reply,
    I have installed python3-wxWidget. I download from github the POL zip file and tried to install it. I got this errors now:

    Code:
     File "mainwindow.py", line 39, in <module>
        import lib.lng as lng
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/lng.py", line 6, in <module>
        from . import Variables
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/Variables.py", line 50, in <module>
        if playonlinux.VersionLower(wx.VERSION_STRING, "3.0.0"):
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/playonlinux.py", line 281, in VersionLower
        version1 = [ int(digit) for digit in version1[0].split(".") ]
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/playonlinux.py", line 281, in <listcomp>
        version1 = [ int(digit) for digit in version1[0].split(".") ]
    ValueError: invalid literal for int() with base 10: 'post2'
    By the way, If i install POL now will I need to re-install all the games I already had installed?
    Gastón

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,808
    Blog Entries
    15

    Default Re: PlayOnLinux

    Quote Originally Posted by Gaston1980 View Post
    Thanks malcom for your quick reply,
    I have installed python3-wxWidget. I download from github the POL zip file and tried to install it. I got this errors now:

    Code:
     File "mainwindow.py", line 39, in <module>
        import lib.lng as lng
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/lng.py", line 6, in <module>
        from . import Variables
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/Variables.py", line 50, in <module>
        if playonlinux.VersionLower(wx.VERSION_STRING, "3.0.0"):
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/playonlinux.py", line 281, in VersionLower
        version1 = [ int(digit) for digit in version1[0].split(".") ]
      File "/home/gaston/Descargas/POL-POM-4-master/python/lib/playonlinux.py", line 281, in <listcomp>
        version1 = [ int(digit) for digit in version1[0].split(".") ]
    ValueError: invalid literal for int() with base 10: 'post2'
    By the way, If i install POL now will I need to re-install all the games I already had installed?
    Gastón
    Hi
    Not sure, is python3-devel installed as well?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: PlayOnLinux

    Yes i have the python3-devel 3.8.3-1.3 installed. I found lots of threads about the same issue but on different linux OS. " days ago I was using POL, yesterday tumbleweed update and today POL is not working. I know that python2 is deprecated. What about POL5?

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,808
    Blog Entries
    15

    Default Re: PlayOnLinux

    Quote Originally Posted by Gaston1980 View Post
    Yes i have the python3-devel 3.8.3-1.3 installed. I found lots of threads about the same issue but on different linux OS. " days ago I was using POL, yesterday tumbleweed update and today POL is not working. I know that python2 is deprecated. What about POL5?
    Hi
    Again a bug report to the maintainers shouldn't take long to fix?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: PlayOnLinux

    Do I reports this bugs? O its you that reports this bugs? Thanks again for your help Malcom
    Gastón

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,808
    Blog Entries
    15

    Default Re: PlayOnLinux

    Quote Originally Posted by Gaston1980 View Post
    Do I reports this bugs? O its you that reports this bugs? Thanks again for your help Malcom
    Gastón
    Hi
    Yes, you can report since your an end user as likely the maintainers may ask you to test etc
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: PlayOnLinux

    Never report a bug and I dont know how to report it.
    Gastón

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,808
    Blog Entries
    15

    Default Re: PlayOnLinux

    Quote Originally Posted by Gaston1980 View Post
    Never report a bug and I dont know how to report it.
    Gastón
    Hi
    Follow the link I posted should get it created for you Just post your issue as you described it
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •