Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Samba Server wird nicht im Netzwerk Sichtbar

  1. #1

    Default Samba Server wird nicht im Netzwerk Sichtbar

    Moin,versuche seit längerem vergeblich Samba einzurichten.
    Ich kann mit Hilfe der IP Adresse auch auf die anderen Samba Freigaben zu greifen und über den befehlt
    smbtree -SN auch die anderen Rechner sehen die im LAN sind jedoch mein Suse 15.1 taucht nicht auf und ist auch von den Andren Windos Rechnern nicht zu sehen und auch nicht von einem anderen Linux PC.
    Habe in zwischen so ziemlich alles aus Probiert was ich an Anleitungen in die Finger bekam.
    Hat Jemand von euch noch eine Idee oder vielleicht eine Anleitung für mich?
    Mit Freundlichen Grüßen und vielen Dank für eure Hilfe.
    Der Heilige

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,101
    Blog Entries
    1

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    Hallo, NetBIOS (wird zum Erkennen / Durchsuchen verwendet) ist nicht mehr verfügbar. Hier ist was möglich ist...

    Linux host-------Linux samba server (Entdeckung via DNS-SD)
    Windows host------Linux samba server (WS-Discovery via wsdd)

    https://de.wikipedia.org/wiki/WS-Discovery
    https://build.opensuse.org/package/s...:hgraeber/wsdd

    Englisch sprechender Benutzer hier mit Google Translate.
    openSUSE Leap 15.2; KDE Plasma 5

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,376

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    @Derheilige:

    Apropos „DNS-SD” – das Zauberwort ist „Zeroconf” beziehungsweise „Avahi” beziehungsweise „mDNS/DNS-SD”.
    • In ‚/etc/nsswitch.conf’ prüfen ob, „hosts: files mdns_minimal [NOTFOUND=return] dns” vorhanden ist – wenn nicht, korrigieren.


    • Prüfen ob, die folgende systemd Dienste aktiviert sind: avahi-daemon.service; dbus-org.freedesktop.Avahi.service; avahi-daemon.socket.
    • Im umstanden, prüfen ob, die systemd avahi-dnsconfd.service Dienst einmal notwendig ist.
    • Entweder alle Avahi Dienste neu starten oder, neu booten.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,101
    Blog Entries
    1

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    Der avahi-daemon.service sollte standardmäßig mit openSUSE aktiv sein. Stellen Sie sicher, dass es mdns-Datenverkehr zulässt.
    openSUSE Leap 15.2; KDE Plasma 5

  5. #5

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    Moin, habe nsswitch.conf geprüft , die Zeile ist so wie sie sein sollte. Wie kann ich den Status der angegebenen Dienste prüfen ? ( Hoffe ich habe da im Wiki nichts übersehen ).
    Mit Freundlichen Grüßen,
    Der Heilige

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,101
    Blog Entries
    1

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    Code:
    sudo systemctl status avahi-daemon
    Code:
    sudo systemctl status firewalld
    Wenn aktiv
    Code:
    firewall-cmd --list-all
    Beispiel
    Code:
    ~> firewall-cmd --list-all
    public (active)
      target: default
      icmp-block-inversion: no
      interfaces: eth0
      sources: 
      services: ssh samba mdns nfs ftp
      ports: 
      protocols: 
      masquerade: no
      forward-ports: 
      source-ports: 
      icmp-blocks: 
      rich rules:
    openSUSE Leap 15.2; KDE Plasma 5

  7. #7

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    Danke. Da merke ich das ich doch noch eine Leihe bin
    so beim ersten bekomme ich folgenden Ausgabe:

    Code:
    ● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
       Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: enabled)
       Active: active (running) since Thu 2020-03-26 00:05:17 CET; 9h ago
     Main PID: 1278 (avahi-daemon)
       Status: "Server startup complete. Host name is Linux.local. Local service cookie is 2230985632."
        Tasks: 1
       CGroup: /system.slice/avahi-daemon.service
               └─1278 avahi-daemon: running [Linux.local]
    
    Mär 26 00:05:17 Linux avahi-daemon[1278]: Server startup complete. Host name is Linux.local. Local service cookie is 2230985632.
    Mär 26 00:05:17 Linux avahi-daemon[1278]: Service "Linux" (/etc/avahi/services/ssh.service) successfully established.
    Mär 26 00:05:17 Linux avahi-daemon[1278]: Service "Linux" (/etc/avahi/services/sftp-ssh.service) successfully established.
    Mär 26 00:05:30 Linux avahi-daemon[1278]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.100.108.
    Mär 26 00:05:30 Linux avahi-daemon[1278]: New relevant interface eth0.IPv4 for mDNS.
    Mär 26 00:05:30 Linux avahi-daemon[1278]: Registering new address record for 192.168.100.108 on eth0.IPv4.
    Mär 26 00:05:30 Linux avahi-daemon[1278]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::224:1dff:fe22:b16a.
    Mär 26 00:05:30 Linux avahi-daemon[1278]: New relevant interface eth0.IPv6 for mDNS.
    Mär 26 00:05:30 Linux avahi-daemon[1278]: Registering new address record for fe80::224:1dff:fe22:b16a on eth0.*.
    Mär 26 08:24:12 Linux avahi-daemon[1278]: Files changed, reloading.
    und der zweite Liefert :
    Code:
    ● firewalld.service - firewalld - dynamic firewall daemon
       Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disabled)
       Active: active (running) since Thu 2020-03-26 00:05:21 CET; 9h ago
         Docs: man:firewalld(1)
     Main PID: 1395 (firewalld)
        Tasks: 2
       CGroup: /system.slice/firewalld.service
               └─1395 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid
    
    Mär 26 00:05:17 Linux systemd[1]: Starting firewalld - dynamic firewall daemon...
    Mär 26 00:05:21 Linux systemd[1]: Started firewalld - dynamic firewall daemon.
    für den dritten sieht es bei mir so aus :
    Code:
    You're performing an operation over default zone ('external'),
    but your connections/interfaces are in zone 'home' (see --get-active-zones)
    You most likely need to use --zone=home option.
    
    external
      target: default
      icmp-block-inversion: no
      interfaces: 
      sources: 
      services: ssh samba-client samba
      ports: 445/tcp 137/tcp 139/tcp 445/udp 137/udp 139/udp
      protocols: 
      masquerade: yes
      forward-ports: 
      source-ports: 
      icmp-blocks: 
      rich rules:
    Gruß Der Heilige

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,101
    Blog Entries
    1

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    Quote Originally Posted by Derheilige View Post
    Code:
    You're performing an operation over default zone ('external'),
    but your connections/interfaces are in zone 'home' (see --get-active-zones)
    You most likely need to use --zone=home option.
    
    external
      target: default
      icmp-block-inversion: no
      interfaces: 
      sources: 
      services: ssh samba-client samba
      ports: 445/tcp 137/tcp 139/tcp 445/udp 137/udp 139/udp
      protocols: 
      masquerade: yes
      forward-ports: 
      source-ports: 
      icmp-blocks: 
      rich rules:
    Gruß Der Heilige
    Mach das

    Code:
    sudo firewall-cmd --zone=home --add-service=mdns
    Code:
    sudo firewall-cmd --runtime-to-permanent
    openSUSE Leap 15.2; KDE Plasma 5

  9. #9

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    Moin,
    So weit schon mal vielen Dank.
    Habe beides gemacht und es bleibt da bei der PC taucht leider nicht auf.
    Gruß Der Heilige

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,376

    Default Re: Samba Server wird nicht im Netzwerk Sichtbar

    @Derheilige:

    Bitte, mit „avahi-browse --all --terminate” prüfen ob, DNS-SD Dienste im LAN sichtbar sind.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •