Results 1 to 3 of 3

Thread: [Tumbleweed] Build failed for rubygem, but only for Tumbleweed

  1. #1
    Join Date
    Apr 2017
    Location
    the Netherlands
    Posts
    18

    Question [Tumbleweed] Build failed for rubygem, but only for Tumbleweed

    I'm trying to figure out why my rubygem package is failing for Tumbleweed, but building fine on Leap:
    Code:
    Building rubygem-other_video_transcoding.spec for openSUSE_Tumbleweed/x86_64
    Getting buildconfig from server and store to /home/overlord/Development/OBS/home:tyrannishawk/rubygem-other_video_transcoding/.osc/_buildconfig-openSUSE_Tumbleweed-x86_64
    Getting buildinfo from server and store to /home/overlord/Development/OBS/home:tyrannishawk/rubygem-other_video_transcoding/.osc/_buildinfo-openSUSE_Tumbleweed-x86_64.xml
    buildinfo is broken... it says:
    unresolvable: nothing provides rubygem(ruby:2.7.0:gem2rpm)
    I'm having the exact same issue with a rubygem I already have on OBS: https://build.opensuse.org/package/s...eo_transcoding

    I'm running the latest snapshot of Tumbleweed (2020-05-04) and the current ruby version is 2.6.6.
    I've followed the Ruby packaging guide: https://en.opensuse.org/openSUSEackaging_Ruby

    Hope someone can tell me why these builds are failing.
    Signature loading: [ |||||||||||||||||||-- ] 90%

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,528
    Blog Entries
    15

    Default Re: [Tumbleweed] Build failed for rubygem, but only for Tumbleweed

    Hi
    There are two ruby versions available in Tumbleweed, 2.6 and 2.7, but no 2.7 rubygems by the looks...

    Try setiing your requires to <= 2.6

    Code:
    BuildRequires:  %{rubygem gem2rpm  <= 2.6}
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    117

    Default Re: [Tumbleweed] Build failed for rubygem, but only for Tumbleweed

    Quote Originally Posted by malcolmlewis View Post
    Hi
    There are two ruby versions available in Tumbleweed, 2.6 and 2.7, but no 2.7 rubygems by the looks...

    Try setiing your requires to <= 2.6

    Code:
    BuildRequires:  %{rubygem gem2rpm  <= 2.6}
    I have the same issue. What us eto successfully build now failed.
    I have nuspell package which I submit to factory, but it just failed recently.
    https://build.opensuse.org/request/show/796572

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •