Results 1 to 4 of 4

Thread: Need help with dual-monitor setup

  1. #1

    Unhappy Need help with dual-monitor setup

    I cannot set up two monitors. Used to be able to. Can someone help?

    The OS is 15.1. I use KDE.

    Two graphic cards are installed, let us call them "small Nvidia" and "big Nvidia". The nvidia driver (G03) drives them both. Big Nvidia is in the first (most important) PCIe slot.

    To each card, a monitor is connected. Monitors are quite different. To the small card, an old, a small VGA monitor is connected. To the big card, a new Display Port monitor is connected.

    With one card + one monitor, each graphics card works correctly.



    Generally, with several variants of dual-monitor setup, only the big card works.

    I am able to run nvidia-settings, where there are about four variants of setup. I do one of the setups, save configuration in xorg.conf, then restart.

    As the KDE starts, the big monitor starts and I log in. The small monitor is dark. When I go to KDE's settings -> "Display and Monitor", the small monitor is absent. nvidia-settings still shows both monitors.

    I have tried many combinations. Sometimes the cursor is seen on the small monitor, but no windows.

    I might be missing a setting to be put in xorg.conf. It looks like the two graphical tools (nvidia-settings and "Display and Monitor") don't have important settings in their choices.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,370

    Default Re: Need help with dual-monitor setup

    @ZStefan:

    We had this in a German language thread – the gist of what seems to work is as follows:
    1. Use “lspci” to obtain the PCI Bus ID of each graphics card – you may have to use either the “-nnk” or “-vmm” options to obtain enough information to work out which card is which.
    2. In “/etc/X11/” copy “xorg.conf.install” to “xorg.conf”.
    3. Add two “Device” sections as follows (example for AMD cards) to “xorg.conf” – it seems that, the rest of the “xorg.conf” content will also be needed …

    Code:
    Section "Device"
            Identifier  "Radeon R7 240/350"
            Driver      "radeon"
            BusID       "PCI:01:00:0"
            Option      "monitor-DVI-0" "Default Monitor"
    EndSection
    
    Section "Device"
            Identifier  "Radeon X1550"
            Driver      "radeon"
            BusID       "PCI:05:00:0"
    EndSection
    Make sure that, you haven't any “Device”, “Screen” or “Monitor” sections defined in the files located in “/etc/X11/xorg.conf.d/”.

  3. #3

    Default Had to install nouveau

    I have tried a number of settings in xorg.conf, including those you mentioned.

    Didn't work.

    I removed the nvidia driver, installed nouveau, and then all worked. Nouveau seems to be a little less productive than nvidia.

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,392

    Default Re: Had to install nouveau

    Quote Originally Posted by ZStefan View Post
    Nouveau seems to be a little less productive than nvidia.
    NVidia doesn't publish specifications necessary for FOSS developers to utilize all available functionality. FOSS developers have to reverse-engineer whatever functionality they can. Five different FOSS "nouveau" packages exist in standard repos just for X, in addition to the nouveau kernel module:
    • Mesa-dri-nouveau
    • libXvMC_nouveau
    • libvdpau_nouveau
    • libdrm_nouveau2
    • xf86-video-nouveau

    The last on the list isn't actually required for most NVidia GPUS, as this primer explains.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1, TW, 15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on i965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •