Results 1 to 5 of 5

Thread: Plasma Wayland: Session crash when monitor goes into standby

  1. #1
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Plasma Wayland: Session crash when monitor goes into standby

    Now that I've solved one bug with using the Wayland Plasma session, there's one more big issue I need to deal with: It appears the session will crash if I use "System Settings - Hardware - Power Management - Energy Saving - Screen Energy Saving" right after the screen powers off. The monitor will first go into standby once the mouse hasn't been moved for the given amount of minutes, but will immediately wake up afterward. When it does I can briefly see the console, followed by the login screen from which I need to log in again. This is quite problematic as I can't power off my screen to preserve its lifetime as well as electricity consumption. I looked but haven't seen any open bug reports on this... figured I'd ask here first before opening one to avoid duplication if the issue is known.

    I have a 1080p / 144 Hz monitor connected via DisplayPort cable (no converters). I also have a cheap 1080p / 60 Hz VR headset connected over a DVI port (DVI to HDMI converter), it's completely disabled from the system settings and should have no influence.

    Linux openSUSE Tumbleweed x64. Plasma 5.18.4. Mesa 20.0.4. Wayland 1.18 / 1.20. KWayland 5.68. AMD Radeon (TM) R9 390 Series (HAWAII, DRM 3.36.0, 5.6.2-1-default, LLVM 10.0.0).
    openSUSE Tumbleweed x64, KDE Framework 5

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,091
    Blog Entries
    1

    Default Re: Plasma Wayland: Session crash when monitor goes into standby

    I looked but haven't seen any open bug reports on this... figured I'd ask here first before opening one to avoid duplication if the issue is known.
    A quick search online turned up this Red Hat bug report (dated May 2019)
    https://bugzilla.redhat.com/show_bug.cgi?id=1705121

    Unfortunately no progress/comments etc
    openSUSE Leap 15.2; KDE Plasma 5

  3. #3
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Re: Plasma Wayland: Session crash when monitor goes into standby

    Quote Originally Posted by deano_ferrari View Post
    A quick search online turned up this Red Hat bug report (dated May 2019)
    https://bugzilla.redhat.com/show_bug.cgi?id=1705121

    Unfortunately no progress/comments etc
    Sounds like it's likely the same thing. Can't believe there's not one review or comment on that bug for months... Wayland is so important yet it's like the Linux community is struggling to find anyone who will look at it. Truth be told this one sounds like it should be reported to Wayland itself... I'll see about making a bug on the Freedesktop tracker today, maybe linking that one too. Thanks for mentioning.
    openSUSE Tumbleweed x64, KDE Framework 5

  4. #4
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Re: Plasma Wayland: Session crash when monitor goes into standby

    Confirming it's most likely the same issue: I enabled my VR headset as a secondary display then turned on monitor standby again. The displays switched but this time there was no actual crash.

    Part of the problem is that modern monitors no longer seem to support classic standby mode, especially not over HDMI and DP connections; They completely cut off the signal until the mouse is moved again. Even back when this worked, Discord would always notify me of a new HDMI audio device whenever the monitor came back online, indicating the system lost connection when it powered off and saw it as a newly connected device when it came back on. I looked in the monitor's settings too but am not sure if this can be fixed.
    openSUSE Tumbleweed x64, KDE Framework 5

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,091
    Blog Entries
    1

    Default Re: Plasma Wayland: Session crash when monitor goes into standby

    Quote Originally Posted by MirceaKitsune View Post
    Confirming it's most likely the same issue: I enabled my VR headset as a secondary display then turned on monitor standby again. The displays switched but this time there was no actual crash.

    Part of the problem is that modern monitors no longer seem to support classic standby mode, especially not over HDMI and DP connections; They completely cut off the signal until the mouse is moved again. Even back when this worked, Discord would always notify me of a new HDMI audio device whenever the monitor came back online, indicating the system lost connection when it powered off and saw it as a newly connected device when it came back on. I looked in the monitor's settings too but am not sure if this can be fixed.
    The KWin compositor should be able to handle this situation regardless of the display behaviour. FWIW, an informative discussion here about monitors, HDMI, and standby behaviours.
    openSUSE Leap 15.2; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •