Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Monitor doesn't stay in standby when using a DP cable

  1. #1
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Monitor doesn't stay in standby when using a DP cable

    Having another little issue with my new monitor. I switched the connection from a HDMI cable to a DP one, as there are a few improvements to using DisplayPort instead. This introduces a small annoyance I don't know how to fix.

    Whenever the monitor goes into standby, it only stays that way for a few seconds before turning itself back on. Power Management - Energy Saving - Screen Energy Saving is set to 5 minutes; The OS does indeed power the monitor off after this idle time and I even see its power LED indicating that. However it only stays this way for roughly 6 - 8 seconds: Despite not moving the mouse or pressing any key, the monitor always powers back on after this amount before I do so. The problem only started after changing the cable type.

    Anyone else experiencing this issue and knows how to solve it? Is this perhaps a kernel / X11 bug that I should report? openSUSE Tumbleweed x64 KDE, amdgpu module, monitor is a ViewSonic VX2758-C-MHD 23.6.
    openSUSE Tumbleweed x64, KDE Framework 5

  2. #2
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Some interesting insight: I tried the following commands, all of which will put the monitor into standby once ran but in every case it still only stays that way for 6 seconds before coming back on:

    Code:
    xset dpms force off
    xset dpms force standby
    xset dpms force suspend
    openSUSE Tumbleweed x64, KDE Framework 5

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,679
    Blog Entries
    15

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Hi
    Does the monitor have a menu system, if so is the 'sleep' mode on or off? I have mine set to off (use DP and HDMI) on the GNOME DE and the power off/on as expected.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Does the monitor have a menu system, if so is the 'sleep' mode on or off? I have mine set to off (use DP and HDMI) on the GNOME DE and the power off/on as expected.
    It has two settings in that regard: Auto Power Off and Sleep, the later giving me large intervals as an option (30 minutes, 60 minutes, etc). I tried enabling them both but it doesn't affect the issue unfortunately.

    Here are the X11 power settings too, in case something should be tweaked here as well. It should be noted the monitor is marked as being Energy Star compliant from what I could find.

    Code:
    mircea@linux-qz0r:~> xset q
    Keyboard Control:
      auto repeat:  on    key click percent:  0    LED mask:  00000000
      XKB indicators:
        00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
        03: Compose:     off    04: Kana:        off    05: Sleep:       off
        06: Suspend:     off    07: Mute:        off    08: Misc:        off
        09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
        12: Group 2:     off    13: Mouse Keys:  off
      auto repeat delay:  660    repeat rate:  25
      auto repeating keys:  00ffffffdffffbbf
                            fadfffefffedffff
                            9fffffffffffffff
                            fff7ffffffffffff
      bell percent:  50    bell pitch:  400    bell duration:  100
    Pointer Control:
      acceleration:  2/1    threshold:  4
    Screen Saver:
      prefer blanking:  yes    allow exposures:  yes
      timeout:  0    cycle:  600
    Colors:
      default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
    Font Path:
      /usr/share/fonts/misc:unscaled,/usr/share/fonts/Type1/,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/75dpi:unscaled,/usr/share/fonts/ghostscript/,/usr/share/fonts/cyrillic:unscaled,/usr/share/fonts/truetype/,built-ins
    DPMS (Energy Star):
      Standby: 300    Suspend: 450    Off: 600
      DPMS is Enabled
      Monitor is On
    Font cache:
      Server does not have the FontCache Extension
    openSUSE Tumbleweed x64, KDE Framework 5

  5. #5
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,385

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Is behavior same if you open some kind of session other than Plasma? You probably already have IceWM at the ready to try.

    If you switch back to HDMI and proper behavior is restored, I'd report both an openSUSE bug and to ViewSonic tech support.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1, TW, 15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on i965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,679
    Blog Entries
    15

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Hi
    Mine are all zero....

    Code:
    DPMS (Energy Star):
      Standby: 0    Suspend: 0    Off: 0
      DPMS is Enabled
      Monitor is On
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Mine are all zero....

    Code:
    DPMS (Energy Star):
      Standby: 0    Suspend: 0    Off: 0
      DPMS is Enabled
      Monitor is On
    Interesting. Maybe those are some delays for the system to wait for a response from the monitor or something similar? How do you change them?

    Quote Originally Posted by mrmazda View Post
    Is behavior same if you open some kind of session other than Plasma? You probably already have IceWM at the ready to try.

    If you switch back to HDMI and proper behavior is restored, I'd report both an openSUSE bug and to ViewSonic tech support.
    Rarely used IceWM but I guess I could try. Would be more tempted to try a Wayland session, I'm already waiting to switch to that once it's stable enough. Will probably look into it later.
    openSUSE Tumbleweed x64, KDE Framework 5

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,679
    Blog Entries
    15

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Quote Originally Posted by MirceaKitsune View Post
    Interesting. Maybe those are some delays for the system to wait for a response from the monitor or something similar? How do you change them?



    Rarely used IceWM but I guess I could try. Would be more tempted to try a Wayland session, I'm already waiting to switch to that once it's stable enough. Will probably look into it later.
    Hi
    Do you have configuration mods in /etc/X11/xorg.conf.d/50-monitor.conf or another file in the directory?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    887

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Do you have configuration mods in /etc/X11/xorg.conf.d/50-monitor.conf or another file in the directory?
    No, I didn't edit those especially since the last time I reinstalled openSUSE from scratch.
    openSUSE Tumbleweed x64, KDE Framework 5

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,679
    Blog Entries
    15

    Default Re: Monitor doesn't stay in standby when using a DP cable

    Quote Originally Posted by MirceaKitsune View Post
    No, I didn't edit those especially since the last time I reinstalled openSUSE from scratch.
    Hi
    It also sounds like this users issue as well;
    https://forums.opensuse.org/showthre...ow-it-to-sleep

    If you run the following, does it help?

    Code:
    xset dpms 0 0 0
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •