Results 1 to 10 of 10

Thread: How to disable Ibus autostart?

  1. #1

    Default How to disable Ibus autostart?

    Hi. I'm using KDE, Leap 15.1

    Recently I had to install Zoom. Ibus was installed as a dependency of Zoom.

    Now every time I reboot and log in I see the additional keyboard layout icon in my system tray, which is ibus'es. It's very annoying to have two icons of the same function, plus my system tray space is very limited.I have to manually disable ibus every time.
    Also I've seen some people had other problems related to ibus: https://www.claudiokuenzler.com/blog...ltiple-windows Here it's suggested to remove Zoom completely, which I can't.

    How do I prevent ibus from loading?

  2. #2
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    490

    Default Re: How to disable Ibus autostart?

    Quote Originally Posted by Alekssan View Post
    Here it's suggested to remove Zoom completely, which I can't.
    There is presently a serious security problem with Zoom. You should uninstall it as soon as possible, or at least not use it until the developers of that software fix it. Apparently, a fix is in the works.

    I don't know why you are unable to remove Zoom completely. Maybe if you tell/show us how you tried to do so, and then maybe someone else might be able to help.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  3. #3

    Default Re: How to disable Ibus autostart?

    I can't remove Zoom because I need to stay in touch with the people who use it.
    I'm not really concerned with the security bleach they have. What else can be done with it apart from hijacking the conferences?
    I would love to only prevent the annoying ibus from starting.

  4. #4
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    367

    Default Re: How to disable Ibus autostart?

    easy fix

    as root chmod 000 /usr/bin/ibus-autostart

    or

    sudo chmod 000 /usr/bin/ibus-autostart

    in MATE you can System > Preferences > Other > Startup Applications - make sure to show hidden uncheck ibus-autostart.

    no idea on how to in KDE.

    If you really need it you can restart it with this command:

    sudo sh /usr/bin/ibus-autostart
    Opensuse 15.2 with VirtualBox VM's (XP, 10 & OpenSUSE 15.0)
    Pi4 with Ubuntu MATE 20.04
    Unix since 1974 (pdp-11 in "B" , Interdata 7/32 in "C") (AT&T, Tandy, Convergent, IBM, NCR, HP flavors)
    Linux since 1995 (mandrake, redhat, fedora, centos, now OpenSUSE)

  5. #5

    Default Re: How to disable Ibus autostart?

    Quote Originally Posted by larryr View Post
    sudo chmod 000 /usr/bin/ibus-autostart
    Problem solved, thank you!

  6. #6
    Join Date
    Dec 2014
    Location
    Paris
    Posts
    60

    Default Re: How to disable Ibus autostart?

    This way`ibus-autostart` can no longer execute. To disable the autostart of `ibus` instead,
    one could remove its autostart entry by `sudo rm /etc/xdg/autostart/ibus-autostart.desktop`.

  7. #7
    Join Date
    Oct 2008
    Location
    Germany, Bremen
    Posts
    49

    Default Re: How to disable Ibus autostart?

    Hello All,

    I just came across this thread as I encountered the same problem.
    Quote Originally Posted by Konfekt View Post
    This way`ibus-autostart` can no longer execute. To disable the autostart of `ibus` instead,
    one could remove its autostart entry by `sudo rm /etc/xdg/autostart/ibus-autostart.desktop`.
    According to the opendesktop spec, the official way should be to copy "/etc/xdg/autostart/ibus-autostart.desktop" to "~/.config/autostart/" and to add the keyword "Hidden=true" to the file. The latter can also be achieved by opening the "KDE Settings / Autostart" and to deselect the "Status" button of the "ibus" entry. This adds the "Hidden" keyword if not existing.
    However: Even with "Hidden=true", on my system ibus is still started - a general KDE issue, an OpenSUSE issue or just a personal one with my installation (see below) ?

    My installation:


    Regards, Sven

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,028

    Default Re: How to disable Ibus autostart?

    In KDE you can just keep the icon from appearing

    Right click the system tray select configure. Select Entries set ibus panel not to show

  9. #9
    Join Date
    Oct 2008
    Location
    Germany, Bremen
    Posts
    49

    Default Re: How to disable Ibus autostart?

    Hi all,

    Quote Originally Posted by the_wumpus View Post
    However: Even with "Hidden=true", on my system ibus is still started - a general KDE issue, an OpenSUSE issue or just a personal one with my installation (see below) ?
    the issue is due to a mismatch between KDE and ibus. There is another ibus start script: "/etc/X11/xim.d/ibus", which contains:

    Code:
    [...]
    case "$WINDOWMANAGER" in
        *kde*|*xfce*|*lxde*)
            # started via xdg autostart
            ;;
        *)
            # FIXME: a little bit of delay is required to avoid race
            (sleep 2; ibus-daemon --xim -d) &
            ;;
    esac
    [...]
    However, $WINDOWMANAGER is set to "/usr/bin/startplasma-x11" which obviously routes script execution to the "default" explicit start. I changed the 1st case pattern to:
    Code:
        *kde*|*xfce*|*lxde*|*startplasma*)
    .. and Vola ! Now ibus is started via xdg autostart and the start can be conveniently controlled via "KDE Settings / Autostart" .

    - Wumpus

  10. #10

    Default Re: How to disable Ibus autostart?

    Quote Originally Posted by the_wumpus View Post
    Hi all,



    the issue is due to a mismatch between KDE and ibus. There is another ibus start script: "/etc/X11/xim.d/ibus", which contains:

    Code:
    [...]
    case "$WINDOWMANAGER" in
        *kde*|*xfce*|*lxde*)
            # started via xdg autostart
            ;;
        *)
            # FIXME: a little bit of delay is required to avoid race
            (sleep 2; ibus-daemon --xim -d) &
            ;;
    esac
    [...]
    However, $WINDOWMANAGER is set to "/usr/bin/startplasma-x11" which obviously routes script execution to the "default" explicit start. I changed the 1st case pattern to:
    Code:
        *kde*|*xfce*|*lxde*|*startplasma*)
    .. and Vola ! Now ibus is started via xdg autostart and the start can be conveniently controlled via "KDE Settings / Autostart" .

    - Wumpus

    In openSUSE Tumbleweed this file is under /usr/etc/X11/xim.d/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •