Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

  1. #11

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by dcurtisfra View Post
    I have an understanding issue here.
    • The standard Oracle VirtualBox version 6.0.12 from the standard Leap 15.1 repositories, with the standard default Leap 15.1 Linux Kernel, happily runs the newest Windows 10, without any annoying behaviour – apart from a slow boot.

    What's so special about MS Office that, it needs a special VirtualBox driver?
    No, Office does not need a special driver. I need to use "non default" kernel, because I need WiFi drivers that are only available in kernel 5.2 (or 5.4) and above. Because of that - I cannot build kernel modules for Virtual Box 6.0.12

  2. #12
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,873

    Default AW: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    What's so special about MS Office that, it needs a special VirtualBox driver?
    Not MS Office, but Kernel 5.6........

    And here Virtualbox from Repo is working:
    Code:
    LANG=C zypper se -si virtualbox kernel-default
    Loading repository data...
    Reading installed packages...
    
    S  | Name                   | Type    | Version                       | Arch   | Repository       
    ---+------------------------+---------+-------------------------------+--------+------------------
    i+ | kernel-default         | package | 5.6.0-1.1.g4de1111            | x86_64 | (System Packages)
    i+ | kernel-default         | package | 5.5.13-2.1.g0af205d           | x86_64 | (System Packages)
    i+ | kernel-default         | package | 5.6.2-1.1.gc8170d6            | x86_64 | kernel-stable    
    i+ | kernel-default-devel   | package | 5.6.0-1.1.g4de1111            | x86_64 | (System Packages)
    i+ | kernel-default-devel   | package | 5.5.13-2.1.g0af205d           | x86_64 | (System Packages)
    i+ | kernel-default-devel   | package | 5.6.2-1.1.gc8170d6            | x86_64 | kernel-stable    
    il | virtualbox             | package | 6.1.4-lp151.527.1             | x86_64 | (System Packages)
    i+ | virtualbox-kmp-default | package | 6.1.4_k5.6.0_1.g4de1111-537.1 | x86_64 | Sauerland-kernel 
    il | virtualbox-qt          | package | 6.1.4-lp151.527.1             | x86_64 | (System Packages)
    Last edited by Sauerland; 03-Apr-2020 at 11:11.

  3. #13
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,370

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by RaveNBlack View Post
    I need WiFi drivers that are only available in kernel 5.2 (or 5.4) and above.
    Leap 15.2 uses the Kernel version 5.3.18 – due early May – Beta Test version available now …

    • Tumbleweed and VirtualBox is possible – Kernel version 5.6.0 …

  4. #14
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,734
    Blog Entries
    2

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by dcurtisfra View Post
    Leap 15.2 uses the Kernel version 5.3.18 – due early May – Beta Test version available now …

    • Tumbleweed and VirtualBox is possible – Kernel version 5.6.0 …
    As I've posted in a couple other places before now,
    kernel 5.6 is a special release because of the flood of new features and capabilities and performance gains.

    openSUSE maintainers really, really need to publish official guidance how everyone running any currently supported versions of openSUSE on all platforms can install kernel 5.6.

    Awhile back Kernel:Portal was a lot more extensive than it is today... It pointed to support articles, repositories for alternate kernels in various stages of development... But today contains hardly any information other than to explain what the openSUSE kernel is.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #15
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,734
    Blog Entries
    2

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by jetchisel View Post
    Hi,

    I have downloaded the .run file from vbox.org

    Code:
    https://www.virtualbox.org/download/testcase/VirtualBox-6.1.5-136807-Linux_amd64.run
    And I just ran as root.

    Code:
    sh ./VirtualBox-6.1.5-136807-Linux_amd64.run
    I currently have leap 15.1 with the kernel version.

    Code:
    5.6.2-1.gc8170d6-default
    All is good no problems at the moment :-)
    Just a fair warning it is not an rpm package just a POSIX sh shell script.
    Yes,
    And that may be the "better" way to install... the RPM is something new, but the .run file is the long time way to install Virtualbox.

    Running the file usually doesn't require the "sh" command, just execute the file...
    Current Virtualbox documentation also fully documents this file which is actually a master script that calls several sub-scripts and if one ever has a problem the Virtualbox documentation walks you through running the subscripts individually to identify the problem.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #16

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by tsu2 View Post
    Yes,

    Running the file usually doesn't require the "sh" command, just execute the file...


    TSU
    If the file (which is a POSIX sh script) is executable (which is not) then yes you don't need to add sh to run it, otherwise you will just get an error permission denied.
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  7. #17
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,734
    Blog Entries
    2

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by jetchisel View Post
    If the file (which is a POSIX sh script) is executable (which is not) then yes you don't need to add sh to run it, otherwise you will just get an error permission denied.
    From the official Virtualbox documentation

    https://www.virtualbox.org/manual/ch...nux-performing

    2.3.3.2. Using the Alternative Generic Installer (VirtualBox.run)

    The installer must be executed as root with either install or uninstall as the first parameter. For example:

    sudo ./VirtualBox.run install

    Or if you do not have the sudo command available, run the following as root instead:

    ./VirtualBox.run install
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #18

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by tsu2 View Post
    From the official Virtualbox documentation

    https://www.virtualbox.org/manual/ch...nux-performing

    2.3.3.2. Using the Alternative Generic Installer (VirtualBox.run)



    TSU
    In this case this is not an official release, what I'm using is a test case build. have you tried downloading what I have posted?

    Code:
    https://www.virtualbox.org/download/testcase/VirtualBox-6.1.5-136807-Linux_amd64.run
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  9. #19
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,734
    Blog Entries
    2

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by jetchisel View Post
    In this case this is not an official release, what I'm using is a test case build. have you tried downloading what I have posted?

    Code:
    https://www.virtualbox.org/download/testcase/VirtualBox-6.1.5-136807-Linux_amd64.run
    Is that your creation, or something you found somehow (maybe a developer version?)
    I notice it's not the current, stable release (6.1.4).

    I haven't tested your version.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #20

    Default Re: OpenSuste 15.1 Kernel 5.6 VirtualBox doesn't build kernl modules

    Quote Originally Posted by tsu2 View Post
    Is that your creation, or something you found somehow (maybe a developer version?)
    I notice it's not the current, stable release (6.1.4).

    I haven't tested your version.

    TSU
    That is why it is calledtest case and not stable .....
    Official documentation does not apply... and it doesn't matter if I created that script or not...
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •