Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

  1. #11

    Default Re: AW: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    Thanks for this suggestion. I'm now using wicked instead of NetworkManager and installed the suggested version of wpa-supplicant and rebooted. Please bear with me as I find the tools to discover if the wifi device has been connected. I'm booted into kernel 28.44 with your LAN driver rtl8822bu-kmp-default aboard.
    journalctl shows:

    Code:
    Apr 03 13:32:14 murdoch kernel: usb 1-4: new high-speed USB device number 8 using xhci_hcd
    Apr 03 13:32:14 murdoch kernel: usb 1-4: New USB device found, idVendor=2357, idProduct=0115
    Apr 03 13:32:14 murdoch kernel: usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=
    3
    Apr 03 13:32:14 murdoch kernel: usb 1-4: Product: 802.11ac NIC
    Apr 03 13:32:14 murdoch kernel: usb 1-4: Manufacturer: Realtek
    Apr 03 13:32:14 murdoch kernel: usb 1-4: SerialNumber: 123456
    Apr 03 13:32:14 murdoch mtp-probe[4497]: checking bus 1, device 8: "/sys/devices/pci0000:00/0000
    :00:14.0/usb1/1-4"
    Apr 03 13:32:14 murdoch mtp-probe[4497]: bus: 1, device: 8 was not an MTP device
    Apr 03 13:32:14 murdoch kernel: usbcore: registered new interface driver rtl88xxau
    
    and

    Code:
    ip route
    default via 192.168.47.1 dev eth0 proto dhcp  
    192.168.47.0/24 dev eth0 proto kernel scope link src 192.168.47.7  
    netstat -i
    Kernel Interface table
    Iface      MTU    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
    eth0      1500    15212      0     17 0         11309      0      0      0 BMRU
    lo       65536      272      0      0 0           272      0      0      0 LRU
    
    So I did not lock wpa_supplicant yet!

    Any more suggestions will be very welcomed. Thank you!

    David

  2. #12
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,384

    Default AW: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    Apr 03 13:32:14 murdoch kernel: usbcore: registered new interface driver rtl88xxau
    This is not the driver build by me.

    Have you installed any driver from a git Repository?

  3. #13

    Default Re: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    Yes, I have tried a few of them. Should I remove any I still have installed?

    David

  4. #14
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,384

    Default AW: Re: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    Quote Originally Posted by davidjmurdoch View Post
    Yes, I have tried a few of them. Should I remove any I still have installed?

    David
    Not remove, deinstall all.

  5. #15

    Default Re: AW: Re: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    Quote Originally Posted by Sauerland View Post
    Not remove, deinstall all.
    Yes, I've deinstalled the git package and reinstalled rtl8822bu-kmp-default, restarted the system.

    The device is detected but not connecting. Could something be keeping the driver from doing its job?

    Where could I look and what tools should I use so I can log the result?

    Thanks.

    David

  6. #16
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,384

    Default AW: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    The journalctl output?
    Also:
    Do you use wicked or networkmanager?

  7. #17

    Default Re: AW: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    The adapter is working now.

    Quote Originally Posted by Sauerland View Post
    Do you use wicked or networkmanager?
    Started with networkmanager but switched to wicked when this problem arose and it's new to me.

    I think I was not configuring the adapter correctly. I used another adapter which had worked before and that connected once I'd configured it correctly.

    Anyway, thanks again for your help.

    David

  8. #18
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,384

    Default AW: wifi adapter Archer T4U now not connecting with post 4.12.14-lp151.28.36-default kernels

    Wicked has a problem with wpa_supplicant, search inside the forum for that.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •