Results 1 to 5 of 5

Thread: Monitor enters pemanent sleep mode while OS boots

  1. #1
    Join Date
    May 2017
    Location
    Russia
    Posts
    149

    Default Monitor enters pemanent sleep mode while OS boots

    Hello, the problem started about a month or two ago. While I'm booting my PC (or exit sleep mode in Linux), my monitor enters permanent sleep mode. It looks like, graphic settings are wrong because if I connect with notebook first or press F8/F12 (entering text mode) it goes smoothly after. Also when I restore from a sleep mode twice pressing ctrl+backspace - all goes well.
    I think, it could be possible because of Nvidia drivers/Kernel update.
    Some people recomend to play with GRUB but I don't know what the problem exactly is.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,735
    Blog Entries
    2

    Default Re: Monitor enters pemanent sleep mode while OS boots

    I'd hazard a guess that you have an APCI setting set wrong somewhere...
    Start by looking in your BIOS and look for settings where if they're not explicitly labeled APCI, they have anything to do with timeouts and putting devices or the.system to sleep

    Then,
    Look in your Desktop's settings, both system and display.
    Look for similar settings, sometimes are explicitly labeled APCI but might not.

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,385

    Default Re: Monitor enters pemanent sleep mode while OS boots

    Based on my experience with displays going to sleep or not waking up when expected, I'm inclined to think it's an either/and problem between display and/or UEFI BIOS that simply do not play nice together except if the BIOS video mode is 80x25 text. UEFI BIOS seem to think people want spindly lowfi graphics rather than clearly legible and responsive displays. The world has grown GUI boot centric, rarely having inclination to see plain text modes, leading me to think display manufacturers do very little if any testing of connections other than to Windows, which means very little actual rebooting, but recovery from hibernate/sleep as a matter of routine.

    I have a 1920x1200 NEC Multisync that works perfectly at POST when its DisplayPort is connected to a legacy BIOS PC, or any PC connected via VGA, DVI or HDMI, but won't wake up on powerup until kernel modesetting kicks in, leaving the screen black all through POST and leaving Grub entirely hidden when connected to a UEFI PC that doesn't have CSM enabled. Another couple of displays wait so long to wake up on power up that I'm lucky if anything shows up on screen during POST.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1, TW, 15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on i965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&

  4. #4
    Join Date
    May 2017
    Location
    Russia
    Posts
    149

    Default Re: Monitor enters pemanent sleep mode while OS boots

    It looks better after latest BIOS firmware update. At least, I see a company logo on boot start now.

  5. #5
    Join Date
    May 2017
    Location
    Russia
    Posts
    149

    Default Re: Monitor enters pemanent sleep mode while OS boots

    Quote Originally Posted by psijic View Post
    It looks better after latest BIOS firmware update. At least, I see a company logo on boot start now.
    It helps only for a day. Need to check what the specific setting I need to change.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •