Results 1 to 6 of 6

Thread: kdeinit5 closed unexpectedly

  1. #1

    Default kdeinit5 closed unexpectedly

    Hi.

    I are having a lot of messanges in the task bar of plasma.
    A icon with a sad face appears and when I click in it it says:

    We are sorry, kdeinit5 closed unexpectedly.
    You cannot report this error, because kdeinit5 does not provide a bug reporting address.

    Then in the developer information

    Code:
    Application: kdeinit5 (kdeinit5), signal: Segmentation fault
     Using host libthread_db library "/lib64/libthread_db.so.1".
     [KCrash Handler]
     #6  0x00007f73198eeabc in ?? () from /usr/lib64/libnvidia-glcore.so.340.108
     #7  0x00007f73198edccf in ?? () from /usr/lib64/libnvidia-glcore.so.340.108
     #8  0x00007f731cdb60a0 in ?? () from /usr/X11R6/lib64/libGL.so.1
     #9  0x00007f73207cb2c2 in _dl_fini () from /lib64/ld-linux-x86-64.so.2
     #10 0x00007f731e95b138 in __run_exit_handlers () from /lib64/libc.so.6
     #11 0x00007f731e95b18a in exit () from /lib64/libc.so.6
     #12 0x000055796f22a926 in ?? ()
     #13 0x000055796f22bc5c in ?? ()
     #14 0x000055796f22c5cf in ?? ()
     #15 0x000055796f22743c in ?? ()
     #16 0x00007f731e94334a in __libc_start_main () from /lib64/libc.so.6
     #17 0x000055796f22809a in ?? ()
     [Inferior 1 (process 14344) detached]



    It is not something that happen when I do something, indeed if it weren't for the icon i would have noticed nothing. It is just it's annoying the icon appearing so often.

    Maybe it's some fail from the nvidia driver?

    best regards

  2. #2
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    440

    Default Re: kdeinit5 closed unexpectedly

    Quote Originally Posted by fperal View Post
    Hi.

    I are having a lot of messanges in the task bar of plasma.
    A icon with a sad face appears and when I click in it it says:

    We are sorry, kdeinit5 closed unexpectedly.
    You cannot report this error, because kdeinit5 does not provide a bug reporting address.

    ...

    It is not something that happen when I do something, indeed if it weren't for the icon i would have noticed nothing. It is just it's annoying the icon appearing so often.

    Maybe it's some fail from the nvidia driver?

    best regards
    to start with it would help to know

    What is your kernel version?
    What version of KDE-Plasma, KDE-Frameworks and Qt does your system use?

    When you see that icon what does
    Code:
    # journalctl -b 0 -p 3
    reveal?

    Regards

    susejunky

  3. #3

    Default Re: kdeinit5 closed unexpectedly

    Quote Originally Posted by susejunky View Post
    to start with it would help to know

    What is your kernel version?
    What version of KDE-Plasma, KDE-Frameworks and Qt does your system use?

    When you see that icon what does
    Code:
    # journalctl -b 0 -p 3
    reveal?

    Regards

    susejunky

    Nothing. It has just happened twice and the last entry is more than 2 hours old.
    I'm thinking if, by the pattern may be something related to sounds


    regards

  4. #4

    Default Re: kdeinit5 closed unexpectedly

    jep, same for me. started some time (maybe one month) ago. I got it really often: always happens when i switch users, sometimes while browsing, then quitting kodi.

    This is 15.1 Leap 4.12.14-lp151.28.48-default #1 SMP Fri Apr 17 05:38:36 UTC 2020 (18849d1) x86_64 x86_64 x86_64 GNU/Linux

    KDE Plasma 5.12.8
    Fw 5.55.0
    Qt 5.9.7

    NVIDIA is 340.108 from nvidia-suse repo

    journactl delivers nothing really helpful:
    Mai 29 21:26:37 pclaptopacer kernel: acer_wmi: Unable to detect available WMID devices
    Mai 29 21:27:23 pclaptopacer pulseaudio[1964]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service >
    ok, but this is like always

    Also happens on 2 other pcs, started at the same time after some update (think nvidia drivers). Unfortunatallley no debug- symbols at fckin nvidia. May be a way to deliver them in repo?
    As the callstack is always that short, maybe there is some missing function beeing called?

    Have not noticed any really convincing consequences - sometimes screen gets blacked out, than it gets reloaded. But as this happens often, sometimes my taskbar gets flooded with 6 crashes. It is a little bit anoying as it had never been doing this years before.

    Regards, Daniel

  5. #5

    Default Re: kdeinit5 closed unexpectedly

    I "solved" it with a quickfix
    I removed the execution permision to /usr/lib64/libexec/drkonqi and I have not seen the error again..... nor anything nasty.
    I know is not the good way but it seems to be a issue not only in opensuse but in other distributions with drkonqui

    best regards



    Quote Originally Posted by obel1x View Post
    jep, same for me. started some time (maybe one month) ago. I got it really often: always happens when i switch users, sometimes while browsing, then quitting kodi.

    This is 15.1 Leap 4.12.14-lp151.28.48-default #1 SMP Fri Apr 17 05:38:36 UTC 2020 (18849d1) x86_64 x86_64 x86_64 GNU/Linux

    KDE Plasma 5.12.8
    Fw 5.55.0
    Qt 5.9.7

    NVIDIA is 340.108 from nvidia-suse repo

    journactl delivers nothing really helpful:
    Mai 29 21:26:37 pclaptopacer kernel: acer_wmi: Unable to detect available WMID devices
    Mai 29 21:27:23 pclaptopacer pulseaudio[1964]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service >
    ok, but this is like always

    Also happens on 2 other pcs, started at the same time after some update (think nvidia drivers). Unfortunatallley no debug- symbols at fckin nvidia. May be a way to deliver them in repo?
    As the callstack is always that short, maybe there is some missing function beeing called?

    Have not noticed any really convincing consequences - sometimes screen gets blacked out, than it gets reloaded. But as this happens often, sometimes my taskbar gets flooded with 6 crashes. It is a little bit anoying as it had never been doing this years before.

    Regards, Daniel

  6. #6
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    431

    Default Re: kdeinit5 closed unexpectedly

    Quote Originally Posted by obel1x View Post
    jep, same for me. started some time (maybe one month) ago. I got it really often: always happens when i switch users, sometimes while browsing, then quitting kodi.

    This is 15.1 Leap 4.12.14-lp151.28.48-default #1 SMP Fri Apr 17 05:38:36 UTC 2020 (18849d1) x86_64 x86_64 x86_64 GNU/Linux

    KDE Plasma 5.12.8
    Fw 5.55.0
    Qt 5.9.7

    NVIDIA is 340.108 from nvidia-suse repo

    journactl delivers nothing really helpful:
    Mai 29 21:26:37 pclaptopacer kernel: acer_wmi: Unable to detect available WMID devices
    Mai 29 21:27:23 pclaptopacer pulseaudio[1964]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service >
    ok, but this is like always

    Also happens on 2 other pcs, started at the same time after some update (think nvidia drivers). Unfortunately no debug- symbols at fckin nvidia. May be a way to deliver them in repo?
    As the callstack is always that short, maybe there is some missing function being called?

    Have not noticed any really convincing consequences - sometimes screen gets blacked out, than it gets reloaded. But as this happens often, sometimes my taskbar gets flooded with 6 crashes. It is a little bit annoying as it had never been doing this years before.

    Regards, Daniel
    I have also started having the same behavior about the same time as you. This system is virtually identical, including the nvidia driver:
    15.1 Leap 4.12.14-lp151.28.48-default
    KDE Plasma 5.12.8
    Frameworks 5.55.0
    Qt 5.9.7

    NVIDIA is 340.108 from nvidia-suse repo
    The behavior is on only this desktop PC, not on any of the ThinkPads.

    There is lengthy thread at https://superuser.com/questions/1475...with-fedora-29 that saw the issue appear last August. It was attributed to
    Conclusion - this error does NOT relate to any particular video driver. This error relates to latest kf5-* version 5.59.0-1 update ONLY. Unfortunately you can not downgrade to kf5-* version 5.58.0-1 - as it is already removed from servers.
    Since we have Frameworks 5.55.0, and I installed it 07 Jul 2019, that would not be the cause of the recent issue.

    There is a bug report at https://bugzilla.redhat.com/show_bug.cgi?id=1746465 that indicates a Fedora fix, but I find nothing for openSUSE yet.
    Regards,
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •