Results 1 to 6 of 6

Thread: SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)

  1. #1

    Default SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)

    Hi,

    I have a ThinkPad W541 with Nvidia Quadro K1100m. I am trying to setup SUSE-Prime package.
    It works however regardless of whether I select intel, intel2 or nvidia, nvidia gpu will always be turned on.
    Code:
    [bbswitch] NVIDIA card is ON
    As far as I understand this is due to render offloading feature in 440 driver.
    The problem is, that nvidia power management works only with Turing GPU. K1100m is Kepler, so driver itself cannot power off the GPU completely.

    Here comes my question: is it possible to use SUSE-Prime the old way (intel = intel GPU only, nvidia = nvidia GPU only) without render offloading?

    I read about this on GitHub page of SUSE-Prime, but I am confused, since the solution with bbswitch seems to apply only to older drivers.

    Thank you for your help

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,090
    Blog Entries
    15

    Default Re: SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)

    Hi
    Your card is not compatible with the 440 series, it's a Legacy card... install the 390.132 driver.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Your card is not compatible with the 440 series, it's a Legacy card... install the 390.132 driver.
    Thank you for your answer. I have removed G05 driver and installed G04.
    However, SUSE-Prime still doesn't work as expected.

    I tried following guide on the GitHub page of the SUSE-Prime project, but executing:

    Code:
     cp 09-nvidia-modprobe-bbswitch-G04.conf /etc/modprobe.d && dracut -f
    results in:
    Code:
    dracut: Executing: /usr/bin/dracut -f
    dracut: No permission to write to /boot.
    and service prime-select (mentioned in next step does not exist).

    Is this a result of an incorrect driver being installed before? Do I need to take some extra steps to remove and clean some leftovers?

    Thank you for your help.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,090
    Blog Entries
    15

    Default Re: SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)

    Quote Originally Posted by felixsartorius View Post
    Thank you for your answer. I have removed G05 driver and installed G04.
    However, SUSE-Prime still doesn't work as expected.

    I tried following guide on the GitHub page of the SUSE-Prime project, but executing:

    Code:
     cp 09-nvidia-modprobe-bbswitch-G04.conf /etc/modprobe.d && dracut -f
    results in:
    Code:
    dracut: Executing: /usr/bin/dracut -f
    dracut: No permission to write to /boot.
    and service prime-select (mentioned in next step does not exist).

    Is this a result of an incorrect driver being installed before? Do I need to take some extra steps to remove and clean some leftovers?

    Thank you for your help.
    Hi
    Unfortunately I don't have a laptop with Nvidia, hopefully the other Forum users with this hardware will chime in in due course....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,004
    Blog Entries
    2

    Default Re: SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)

    Besides the github page,
    There is an SDB that can provide guidance

    https://en.opensuse.org/SDB:NVIDIA_SUSE_Prime

    Additionally, if you're unable to make suse-prime work (we'll provide as much assistance as we can here but like Malcolm I don't have immediate access to a machine with an nVidia GPU), you also have the option to implement the older, "tried and true" way configuring Bumblebee.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,004
    Blog Entries
    2

    Default Re: SUSE-Prime Nvidia GPU always on (Pre-Turing GPU)

    Quote Originally Posted by felixsartorius View Post
    Thank you for your answer. I have removed G05 driver and installed G04.
    However, SUSE-Prime still doesn't work as expected.

    I tried following guide on the GitHub page of the SUSE-Prime project, but executing:

    Code:
     cp 09-nvidia-modprobe-bbswitch-G04.conf /etc/modprobe.d && dracut -f
    results in:
    Code:
    dracut: Executing: /usr/bin/dracut -f
    dracut: No permission to write to /boot.
    and service prime-select (mentioned in next step does not exist).

    Is this a result of an incorrect driver being installed before? Do I need to take some extra steps to remove and clean some leftovers?

    Thank you for your help.
    This sounds like a permissions problem, not a code or content bug.
    Are you running your commands in a full elevated console?
    To switch to a proper elevated console run the following before executing commands
    Code:
    su --login
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •