Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Optimus on Legacy Driver 340

  1. #1

    Default Optimus on Legacy Driver 340

    Hello,
    i have a laptop Asus N61JV, whit Optimus hardware.
    Code:
    # lspci -nnk | egrep 'VGA|3D' -A3
    00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1252]
            Kernel driver in use: i915
            Kernel modules: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT216M [GeForce GT 325M] [10de:0a35] (rev a2)
            Subsystem: ASUSTeK Computer Inc. Device [1043:1252]
            Kernel modules: nouveau
    03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Code:
    # xrandr --listproviders
    Providers: number : 1
    Provider 0: id: 0x45; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 2; outputs: 4; associated providers: 0; name: modesetting
        output LVDS-1
        output VGA-1
        output HDMI-1
        output DP-1
    I install Bumblebee form here https://en.opensuse.org/SDB:NVIDIA_Bumblebee with Bumblebee repo for 15.1, and it work, but Bumblebee NVIDIA driver are 440, and it don't support my card.
    What is my options on using full potential of the laptop. My setup is laptop connected to external monitor. The problem is that when i am using Mozilla in YouTube, every clip is taking 95% CPU usage and clip skip and stop from time to time. So I think that whit using of NVIDIA card for visualization the work is go smoother.

  2. #2

    Default Re: Optimus on Legacy Driver 340

    I also tray to install the driver and recover messed up GL libs:
    Code:
         ./NVIDIA-Linux-x86_64-340.93.run --accept-license --no-backup --no-x-check --no-questions --ui=none --no-x-check --no-distro-scripts --utility-prefix=/nvidia --installer-prefix=/nvidia --opengl-prefix=/nvidia --opengl-libdir=glx
    
    rm /usr/lib64/xorg/modules/extensions/libglx.so
    
    mv /usr/lib64/xorg/modules/extensions/libglx.so.340.93 /nvidia/glx/libglx.so.340.93
    
    ln -s /nvidia/glx/libglx.so.340.93 /nvidia/glx/libglx.so
    
    zypper in -f xorg-x11-server Mesa Mesa-32bit Mesa-libGL1 Mesa-libGL1-32bit Mesa-libEGL1 Mesa-libEGL1-32bit xf86-video-intel xf86-video-vesa
    
    sytemctl enable bumblebeed
    
      In bumblebee.conf:
         #...
    ## Section with nvidia driver specific options, only parsed if Driver=nvidia
    [driver-nvidia]
    # Module name to load, defaults to Driver if empty or unset
    KernelDriver=nvidia
    PMMethod=auto
    # colon-separated path to the nvidia libraries
    LibraryPath=/nvidia/lib64:/nvidia/glx
    # comma-separated path of the directory containing nvidia_drv.so and the
    # default Xorg modules path
    XorgModulePath=/nvidia/glx,/nvidia/lib64,/usr/lib64/xorg/modules
    XorgConfFile=/etc/bumblebee/xorg.conf.nvidia
    #...
    But without success.

  3. #3
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    455

    Default Re: Optimus on Legacy Driver 340

    Give this a try :https://forums.opensuse.org/showthre...-safe-quot-way

    It installs CUDA compatible Nvidia driver which should support your card.

  4. #4

    Default Re: Optimus on Legacy Driver 340

    This is cuda output from install it
    URL: https://paste.opensuse.org/39193142

    First error is here, at "Change the following lines under [driver-nvidia]:"
    sudo ln -s /usr/lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    ln: failed to create symbolic link '/usr/lib64/nvidia/xorg/modules/extensions/libglx.so': file exist

  5. #5
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    455

    Default Re: Optimus on Legacy Driver 340

    Try
    Code:
    sudo ln -sf /usr/lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    changing the flag from -s to -sf to replace the symbollic link. Also, if it already exists, you can just skip this step.

    -SJL

  6. #6

    Default Re: Optimus on Legacy Driver 340

    Quote Originally Posted by SJLPHI View Post
    Try
    Code:
    sudo ln -sf /usr/lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    changing the flag from -s to -sf to replace the symbollic link. Also, if it already exists, you can just skip this step.

    -SJL
    I just remove the existing file end start
    Code:
    ln -s /usr/lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    whitout errors. After that
    Code:
    mkinitrd
    .
    And than
    Code:
    options bbswitch load_state=-1 unload_state=1
    reboot and test.
    Code:
    optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    Code:
    optirun glxgears
    output was [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

    PS: Now i test
    Code:
    sudo ln -sf /usr/lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    reboot, update, reboot, and test

    Code:
    optirun --status
    [  101.724632] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [  101.724705] [ERROR]Could not connect to bumblebee daemon - is it running?
    linux-4962:/home/hristokz # sudo systemctl restart bumblebeed
    linux-4962:/home/hristokz # optirun --status
    [  110.217413] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [  110.217487] [ERROR]Could not connect to bumblebee daemon - is it running?
    linux-4962:/home/hristokz # sudo systemctl enable bumblebeed
    linux-4962:/home/hristokz # optirun --status
    [  150.728466] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [  150.728529] [ERROR]Could not connect to bumblebee daemon - is it running?

  7. #7
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    455

    Default Re: Optimus on Legacy Driver 340

    Did you set the right groups and permissions? Also, did you start and enable bbswitch and bumblebeed in systemctl?

  8. #8

    Default Re: Optimus on Legacy Driver 340

    Code:
    sudo usermod -aG bumblebee hristokz
    linux-4962:/home/hristokz # sudo usermod -aG video hristokz
    bumblebeed is enabled and start but
    Code:
    sudo systemctl enable bbswitch
    Failed to enable unit: Unit file bbswitch.service does not exist.
    TEST
    Code:
    optirun --status
    [ 5604.773774] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [ 5604.773841] [ERROR]Could not connect to bumblebee daemon - is it running?

  9. #9

    Default Re: Optimus on Legacy Driver 340

    After reinstall bbswitch and bbswitch-kmp-default:
    Code:
    sudo systemctl enable bbswitch
    Failed to enable unit: Unit file bbswitch.service does not exist.
    linux-4962:/home/hristokz # optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    linux-4962:/home/hristokz # sudo systemctl start bumblebeed
    linux-4962:/home/hristokz # optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    linux-4962:/home/hristokz # optirun glxgears 
    [ 7541.822120] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
    
    [ 7541.822236] [ERROR]Aborting because fallback start is disabled.
    PS: after just reboot
    Code:
    sudo systemctl start bbswitch
    Failed to start bbswitch.service: Unit bbswitch.service not found.
    linux-4962:/home/hristokz # optirun glxgears 
    [  153.124317] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [  153.124374] [ERROR]Could not connect to bumblebee daemon - is it running?
    linux-4962:/home/hristokz # sudo systemctl start bumblebeed
    linux-4962:/home/hristokz # optirun glxgears 
    [  226.154855] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [  226.154929] [ERROR]Could not connect to bumblebee daemon - is it running?
    linux-4962:/home/hristokz # optirun --status
    [  231.962653] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [  231.962743] [ERROR]Could not connect to bumblebee daemon - is it running?

  10. #10
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    455

    Default Re: Optimus on Legacy Driver 340

    you need to "enable" as well as starting bbswitch and bumblebeed. I don't know why you are installing bbswitch-kmp-default.

    I don't know what went wrong since I don't know exactly what sequence you went with but if systemctl cannot start bbswitch, obviously bbswitch and/or its dependence hasn't been installed properly.

    Don't expect bumblebee to work without bbswitch, but you need to sort out where it went wrong.

    I am sorry, I cannot help you since you haven't even uninstalled the Nvidia driver you installed originally. As I've said in my set of instructions, you have to start from "clean" state first.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •