Results 1 to 2 of 2

Thread: Pulse audio outputting s32le when set to s24le

  1. #1

    Default Pulse audio outputting s32le when set to s24le

    Hello,

    My speakers/sound-monitors are active and they feed 24bit/192 audio. When I configured my Pulseaudio conf file to s24le and either 192000 or 96000 it magically switches itself to s32le. I have avoid re-sampling on(but tested with off also) and after running "pactl list short sinks" it shows that it switches to s16/44100 when playing spotify, but then changes to S32/48000 when opening say youtube or vlc for example. It starts to sound like a compressor is running because it's sampling up and down. While things like youtube audio are not exactly premium listening experiences, I would like to avoid having it ever going into 32bit since the speaker amplifier can't handle that and downsample making everything sound overprocessed.

    Thank you for the help.

  2. #2

    Default Re: Pulse audio outputting s32le when set to s24le

    Try to set PulseAudio
    Code:
    resample-method = copy
    or

    Code:
    resample-method = soxr-vhq
    Additionally you may change ALSA settings.

    AFAIK problem is not with s32le.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •