Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: No soundcard detected after reboot

  1. #1

    Default No soundcard detected after reboot

    Hi,

    since I connected my laptop to a USB 3 dock the laptop's intrenal soundcard is no longer detected after reboot. (I'm not entirely sure if the problem emerged right afterwards)
    KDE shows a "Dummy Output" only and no sound is being played.
    What helps is to go to the sound configuration within Yast and a) delete the present configuration and b) edit the than unconfigured sound card. Yast restarts the sound system in some sort of way I was not able to do manually.

    I tried quite a lot of things to resurrect the initial recognition of the card.
    I deleted /etc/modprobe.d/50-sound.conf and let Yast recreate it, I tried to restart alsa via `systemctl restart alsasound.service`, `alsactl init`, tried to tinker with the alsamixer ... nothing helped so far.
    Recently, I booted from a Leap 15.1 live USB stick and sound worked out of the box. This should rule out hardware problems.
    On another and different laptop I tested the other day it helped to add "snd-intel-dspcfg.dsp_driver=1" to the boot options. Not surprisingly, this didn't help with this issue.

    Another thing I noticed where this two messages during boot:
    hdaudio hdaudioC0D0: Unable to bind the codec
    See the journalctl's snippet below:

    Code:
    # journalctl -b | egrep -i 'snd|codec'
    Mar 13 15:14:39 thinkpad kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.5.8-3.g1538c30-default root=UUID=903728c8-3fc7-402b-8757-4909aca7bef2 resume=/dev/disk/by-uuid/2ffbed8e-fc8d-4e8b-9846-9a1c0aaaaac3 splash=silent quiet showopts snd-intel-dspcfg.dsp_driver=1
    Mar 13 15:14:39 thinkpad kernel: Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.5.8-3.g1538c30-default root=UUID=903728c8-3fc7-402b-8757-4909aca7bef2 resume=/dev/disk/by-uuid/2ffbed8e-fc8d-4e8b-9846-9a1c0aaaaac3 splash=silent quiet showopts snd-intel-dspcfg.dsp_driver=1
    Mar 13 15:14:39 thinkpad kernel: snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    Mar 13 15:14:39 thinkpad systemd-modules-load[249]: Inserted module 'snd_hda_intel'
    Mar 13 15:14:39 thinkpad dracut-cmdline[273]: Using kernel command line parameters: resume=UUID=2ffbed8e-fc8d-4e8b-9846-9a1c0aaaaac3 root=UUID=903728c8-3fc7-402b-8757-4909aca7bef2 rootfstype=btrfs rootflags=rw,relatime,ssd,space_cache,subvolid=257,subvol=/@,subvol=@ BOOT_IMAGE=/boot/vmlinuz-5.5.8-3.g1538c30-default root=UUID=903728c8-3fc7-402b-8757-4909aca7bef2 resume=/dev/disk/by-uuid/2ffbed8e-fc8d-4e8b-9846-9a1c0aaaaac3 splash=silent quiet showopts snd-intel-dspcfg.dsp_driver=1
    Mar 13 15:14:39 thinkpad kernel: hdaudio hdaudioC0D0: Unable to bind the codec
    Mar 13 15:14:39 thinkpad kernel: hdaudio hdaudioC0D2: Unable to bind the codec
    Mar 13 15:15:42 thinkpad plasmashell[2220]: org.kde.plasma: invalid metadata "/usr/lib64/qt5/plugins/k3blibsndfiledecoder.so"
    Mar 13 15:28:28 thinkpad kernel: snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    Mar 13 15:28:28 thinkpad kernel: snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC257: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    Mar 13 15:28:28 thinkpad kernel: snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    Mar 13 15:28:28 thinkpad kernel: snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
    Mar 13 15:28:28 thinkpad kernel: snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
    Mar 13 15:28:28 thinkpad kernel: snd_hda_codec_realtek hdaudioC0D0:    inputs:
    Mar 13 15:28:28 thinkpad kernel: snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
    Mar 13 15:28:28 thinkpad kernel: snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
    Running `/usr/sbin/alsa-info.sh`right after booting generated this output:
    http://alsa-project.org/db/?f=4a9de9...e7811571cc1973

    Running it again after reconfiguring the sound card with Yast resulted in this output:
    http://alsa-project.org/db/?f=3c9ab3...1834b0ebbc52a2

    I'm running out of ideas where else to look.
    (This problem survived several weeks and a lot of updates of many packages.)
    Any help is appreciated!

    Additional info:
    - When booting the laptop connected to the USB-dock, the dock's sound device is recognized immediately.
    - This "Dummy Audio Device" is shown within KDE no matter which user logs in after reboot
    Even a newly created user doesn't see the internal sound device
    This leads me to the conclusion, that it's a system wide configuration not being quite right.

    Code:
    cat /etc/modprobe.d/50-sound.conf
    
    options snd slots=snd-hda-intel
    # nS1_.hHmDP7YoWB0:Sunrise Point-LP HD Audio
    alias snd-card-0 snd-hda-intel
    Last edited by marodger; 13-Mar-2020 at 08:43. Reason: Wrong alsa info output url

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    For some reason the sound module doesn't load at boot. Check for any errors in the kernel messaging...
    Code:
    dmesg |grep snd
    openSUSE Leap 15.1; KDE Plasma 5

  3. #3

    Default Re: No soundcard detected after reboot

    Code:
     dmesg | grep snd
    [    4.426359] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    
    [    4.624156] hdaudio hdaudioC0D0: Unable to bind the codec
    [    4.632715] hdaudio hdaudioC0D2: Unable to bind the codec
    Apart from the hdaudio messages, I don't see any other error.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    Quote Originally Posted by marodger View Post
    Code:
     dmesg | grep snd
    [    4.426359] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    
    [    4.624156] hdaudio hdaudioC0D0: Unable to bind the codec
    [    4.632715] hdaudio hdaudioC0D2: Unable to bind the codec
    Apart from the hdaudio messages, I don't see any other error.
    Try reloading the driver by hand
    Code:
    rmmod snd-hda-intel
    modprobe snd-hda-intel
    then check the kernel messaging again
    Code:
    dmesg|tail
    That might provide more clues. It may be that a bug report is required.
    openSUSE Leap 15.1; KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    BTW, I recommend removing 'snd_intel_dspcfg: dsp_driver=1' from your kernel boot config. It's shown as present in your alsa-info.sh output you shared.
    openSUSE Leap 15.1; KDE Plasma 5

  6. #6

    Default Re: No soundcard detected after reboot

    I recommend removing 'snd_intel_dspcfg: dsp_driver=1'
    Yes, thanks, I did this already. Adding this option was a test.

    Reloading the snd-hda-intel (via rmmod followed by modprobe) lets the internal sound device reappear.
    That is a good start.
    Strange, I was almost certain, I had tried this before.
    Below I added the output of lsmod before and after the rmmod modprobe command as well.


    Code:
    thinkpad:~ # lsmod | grep snd
    snd_soc_skl           180224  0
    snd_soc_sst_ipc        20480  1 snd_soc_skl
    snd_soc_sst_dsp        40960  1 snd_soc_skl
    snd_hda_ext_core       36864  1 snd_soc_skl
    snd_soc_acpi_intel_match    32768  1 snd_soc_skl
    snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_soc_skl
    snd_soc_core          286720  1 snd_soc_skl
    snd_compress           28672  1 snd_soc_core
    snd_pcm_dmaengine      16384  1 snd_soc_core
    snd_hda_intel          57344  0
    snd_intel_dspcfg       28672  2 snd_hda_intel,snd_soc_skl
    snd_hda_codec         163840  1 snd_hda_intel
    snd_hwdep              16384  1 snd_hda_codec
    snd_hda_core          106496  4 snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_skl
    snd_pcm               155648  6 snd_hda_intel,snd_hda_codec,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
    snd_timer              40960  1 snd_pcm
    snd                   110592  8 snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,thinkpad_acpi,snd_soc_core,snd_pcm
    soundcore              16384  1 snd
    thinkpad:~ # rmmod snd-hda-intel
    thinkpad:~ # modprobe snd-hda-intel
    thinkpad:~ # dmesg | tail -n 20
    [ 4079.892287] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    [ 4079.963646] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC257: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    [ 4079.963652] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [ 4079.963656] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
    [ 4079.963658] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
    [ 4079.963660] snd_hda_codec_realtek hdaudioC0D0:    inputs:
    [ 4079.963663] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
    [ 4079.963666] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
    [ 4080.047129] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15
    [ 4080.047306] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input16
    [ 4080.047488] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input17
    [ 4080.047647] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input18
    [ 4080.047864] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
    [ 4080.048417] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20
    [ 4080.058888] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input21
    [ 4080.059157] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input22
    
    
    thinkpad:~ # lsmod | grep snd
    snd_hda_codec_hdmi     73728  1
    snd_hda_codec_realtek   126976  1
    snd_hda_codec_generic    94208  1 snd_hda_codec_realtek
    snd_hda_intel          57344  5
    snd_soc_skl           180224  0
    snd_soc_sst_ipc        20480  1 snd_soc_skl
    snd_soc_sst_dsp        40960  1 snd_soc_skl
    snd_hda_ext_core       36864  1 snd_soc_skl
    snd_soc_acpi_intel_match    32768  1 snd_soc_skl
    snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_soc_skl
    snd_soc_core          286720  1 snd_soc_skl
    snd_compress           28672  1 snd_soc_core
    snd_pcm_dmaengine      16384  1 snd_soc_core
    ledtrig_audio          16384  3 snd_hda_codec_generic,snd_hda_codec_realtek,thinkpad_acpi
    snd_intel_dspcfg       28672  2 snd_hda_intel,snd_soc_skl
    snd_hda_codec         163840  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
    snd_hwdep              16384  1 snd_hda_codec
    snd_hda_core          106496  7 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_soc_skl
    snd_pcm               155648  7 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
    snd_timer              40960  1 snd_pcm
    snd                   110592  21 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,thinkpad_acpi,snd_soc_core,snd_pcm
    soundcore              16384  1 snd
    I still need to figure out, what goes wrong during boot, though.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    Quote Originally Posted by marodger View Post
    Reloading the snd-hda-intel (via rmmod followed by modprobe) lets the internal sound device reappear.
    That is a good start.
    That's good. Some kind of issue with probing perhaps. It might be that adding an explicit 'model=' option can be used as a workaround, and that would depend on your hardware. What model laptop do you have?
    Code:
    inxi -MSCxx
    I still need to figure out, what goes wrong during boot, though.
    As I mentioned before, that might take a bug report to resolve.
    https://en.opensuse.org/openSUSE:Submitting_bug_reports
    openSUSE Leap 15.1; KDE Plasma 5

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    Actually, trawling though alsa-info.sh output I note that you have a Lenovo...
    Code:
    Manufacturer:      LENOVO
    Product Name:      20L7CTO1WW
    Product Version:   ThinkPad T480s
    Firmware Version:  N22ET60W (1.37 )
    Board Vendor:      LENOVO
    Board Name:        20L7CTO1WW
    openSUSE Leap 15.1; KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    Please run the alsa-info script again (after boot and then after the module is reloaded by hand), now that you have removed the 'snd-intel-dspcfg.dsp_driver=1' boot parameter shown in the original alsa-info.sh output...
    Code:
    [    0.213025] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.5.8-3.g1538c30-default root=UUID=903728c8-3fc7-402b-8757-4909aca7bef2 resume=/dev/disk/by-uuid/2ffbed8e-fc8d-4e8b-9846-9a1c0aaaaac3 splash=silent quiet showopts snd-intel-dspcfg.dsp_driver=1
    openSUSE Leap 15.1; KDE Plasma 5

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    Some useful ALSA documentation that may aid with understanding and diagnostics...
    https://www.kernel.org/doc/html/late...dio/index.html
    Last edited by deano_ferrari; 13-Mar-2020 at 16:37.
    openSUSE Leap 15.1; KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •