Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: No soundcard detected after reboot

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    I do wonder if force-loading of 'snd_hda_codec_realtek' might do the trick as a workaround here. (Pure speculation on my part of course and along the lines discussed in this Debian mail thread. Read that first so that you get the idea.)

    This can be done using /etc/modules-load.d/ (eg /etc/modules-load.d/0-sound.conf) with...
    Code:
    snd_hda_codec_realtek
    snd_hda_intel
    and will take effect next boot.

    It may need additional modules loaded...I'm not sure, but might be worth a shot.
    openSUSE Leap 15.1; KDE Plasma 5

  2. #12

    Default Re: No soundcard detected after reboot

    I'll try your suggestion.
    Here is the alsa info without the snd-intel-dspcfg.dsp_driver=1

    After boot:
    http://alsa-project.org/db/?f=e86f8e...da45d14161264c

    After rmmod modprobe
    http://alsa-project.org/db/?f=851b6c...aadb55b797bf2c

    Meanwhile I also read
    https://en.opensuse.org/SDB:Intel-HDA_sound_problems
    Code:
    head -n 1 /proc/asound/card0/codec*
    ==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC257
    
    ==> /proc/asound/card0/codec#2 <==
    Codec: Intel Kabylake HDMI
    and
    https://github.com/torvalds/linux/bl...figuration.rst

    But wasn't able to find the mentioned ALSA-Configuration.txt

    And I also read this article:
    https://en.opensuse.org/SDB:Audio_troubleshooting

    So I assumed I might have to edit the /etc/modprobe.d/50-sound.conf
    So far, I didn't make any progress with that (Especially as I couldn't really find possible options for the ALC257 within the ALSA-Configuration.txt as claimed within the aforementioned articles.

    But, I found it via the link you provided:
    https://www.kernel.org/doc/html/late...alc3xxx-models

    Next I'll boot with
    Code:
    cat /etc/modprobe.d/50-sound.conf
    options snd-hda-intel model=thinkpad enable=1 index=0
    # nS1_.hHmDP7YoWB0:Sunrise Point-LP HD Audio
    alias snd-card-0 snd-hda-intel

    About the modules-load.d

    Currently it looks like this

    Code:
    ll /etc/modules-load.d/
    total 4
    -rw-r--r-- 1 root root 14 Dec  8  2017 yast.conf
    thinkpad:~ # cat /etc/modules-load.d/yast.conf 
    snd-hda-intel
    Thanks for the Debian list link. Looks good, I'll test that and report back.

  3. #13

    Default [Solved] Re: No soundcard detected after reboot

    I finally found a solution.
    It's absolutely strange but deleting both

    Code:
    /etc/modprobe/50-sound.conf
    as well as
    Code:
    /etc/modules-load.d/yast.conf
    (the latter contained snd_hda_intel as the only line)

    solved the issue.

    Sound is available right after boot. Even though, Yast Sound claimes this device to be "Not configured".

    Code:
    dmesg | grep snd
    [    7.723047] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    [    7.905407] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC257: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
    [    7.905410] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [    7.905411] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
    [    7.905412] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
    [    7.905413] snd_hda_codec_realtek hdaudioC0D0:    inputs:
    [    7.905415] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
    [    7.905416] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12

    http://alsa-project.org/db/?f=e5bfc8...ff35b524c41894

    Thankyou for your input!

  4. #14
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: [Solved] Re: No soundcard detected after reboot

    Quote Originally Posted by marodger View Post
    I finally found a solution.
    It's absolutely strange but deleting both

    Code:
    /etc/modprobe/50-sound.conf
    as well as
    Code:
    /etc/modules-load.d/yast.conf
    (the latter contained snd_hda_intel as the only line)

    solved the issue.
    Thanks for the update, and yes for the majority of users no explicit configuration is required.
    openSUSE Leap 15.1; KDE Plasma 5

  5. #15
    Join Date
    Aug 2008
    Location
    Neuendorf, Switzerland
    Posts
    109

    Default Re: No soundcard detected after reboot

    I have the same problem on my Lenovo Thinkcentre. My current "solution" is:

    Code:
    vi /etc/default/grub
    Find GRUB_CMDLINE_LINUX_DEFAULT and add snd-intel-dspcfg.dsp_driver=1 (older version was snd_hda_intel.dmic_detect=0) to the end of it.

    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    reboot
    System sound works, but not in Appications.

  6. #16
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,948
    Blog Entries
    1

    Default Re: No soundcard detected after reboot

    Quote Originally Posted by boenis View Post
    I have the same problem on my Lenovo Thinkcentre. My current "solution" is:

    Code:
    vi /etc/default/grub
    Find GRUB_CMDLINE_LINUX_DEFAULT and add snd-intel-dspcfg.dsp_driver=1 (older version was snd_hda_intel.dmic_detect=0) to the end of it.

    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    reboot
    System sound works, but not in Appications.
    If you have partial sound, then check your mixer settings. Ideally, you should start a new thread for your particular issue.
    openSUSE Leap 15.1; KDE Plasma 5

  7. #17

    Default Re: No soundcard detected after reboot

    Quote Originally Posted by boenis View Post
    I have the same problem on my Lenovo Thinkcentre. My current "solution" is:
    ....
    I tried this as stated in the first post or so. I had tested this since this was a fix on a HP elitebook laptop I had to test.

    But this is a different problem and worth a new thread.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •