Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: TW20200309 Anyone else seeing these systemd 'errors' at boot.

  1. #1
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default TW20200309 Anyone else seeing these systemd 'errors' at boot.

    After a zypper dup to 20200309 both of my TW machines have these 'errors' at boot:

    Code:
    systemd[1]: Failed to start Setup Virtual Console.
    
    and
    
    systemd[1]: Dependency failed for dracut ask for additional cmdline parameters.
    Anyone else seeing these?
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,111
    Blog Entries
    15

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by tannington View Post
    After a zypper dup to 20200309 both of my TW machines have these 'errors' at boot:

    Code:
    systemd[1]: Failed to start Setup Virtual Console.
    
    and
    
    systemd[1]: Dependency failed for dracut ask for additional cmdline parameters.
    Anyone else seeing these?
    Hi
    Haven't updated yet, waiting for the python 3.8 builds to finish and publish....

    That's been seen before by folks in the Forum "Failed to start Setup Virtual Console", you need to look through the logs for the dracut error, what is being rebuilt, third party kernel modules?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by malcolmlewis View Post
    ... That's been seen before by folks in the Forum "Failed to start Setup Virtual Console",
    I'll have a search through the forum, see what I can find...

    you need to look through the logs for the dracut error, what is being rebuilt, third party kernel modules?
    These are the only 'dracut' related entries in the journal ... doesn't mean a lot to me I'm afraid

    Code:
    paul@Orion-15:~$ journalctl -b | grep -i dracut
    Mar 11 17:36:39 Orion-15 systemd[1]: Dependency failed for dracut ask for additional cmdline parameters.
    Mar 11 17:36:39 Orion-15 systemd[1]: dracut-cmdline-ask.service: Job dracut-cmdline-ask.service/start failed with result 'dependency'.
    Mar 11 17:36:39 Orion-15 systemd[1]: Starting dracut cmdline hook...
    Mar 11 17:36:39 Orion-15 systemd[1]: Started dracut cmdline hook.
    Mar 11 17:36:39 Orion-15 systemd[1]: Starting dracut pre-udev hook...
    Mar 11 17:36:39 Orion-15 systemd[1]: Started dracut pre-udev hook.
    Mar 11 17:36:39 Orion-15 dracut-cmdline[226]: dracut-dracut-049.1+git125.e2b2c9ef-1.1
    Mar 11 17:36:39 Orion-15 dracut-cmdline[226]: Using kernel command line parameters: resume=UUID=08a4ff75-8318-40cf-b78b-b7049064dfb5 root=UUID=2511d4d8-0425-4e80-bd14-86798396bdfb rootfstype=ext4 rootflags=rw,noatime BOOT_IMAGE=/boot/vmlinuz-5.5.7-1-default root=UUID=2511d4d8-0425-4e80-bd14-86798396bdfb noresume libata.force=noncq showopts
    Mar 11 17:36:39 Orion-15 systemd[1]: Condition check resulted in dracut pre-trigger hook being skipped.
    Mar 11 17:36:39 Orion-15 systemd[1]: Condition check resulted in dracut initqueue hook being skipped.
    Mar 11 17:36:39 Orion-15 systemd[1]: Condition check resulted in dracut pre-mount hook being skipped.
    Mar 11 17:36:40 Orion-15 systemd[1]: Condition check resulted in dracut mount hook being skipped.
    Mar 11 17:36:40 Orion-15 systemd[1]: Condition check resulted in dracut pre-pivot and cleanup hook being skipped.
    Mar 11 17:36:40 Orion-15 systemd[1]: dracut-pre-udev.service: Succeeded.
    Mar 11 17:36:40 Orion-15 systemd[1]: Stopped dracut pre-udev hook.
    Mar 11 17:36:40 Orion-15 systemd[1]: dracut-cmdline.service: Succeeded.
    Mar 11 17:36:40 Orion-15 systemd[1]: Stopped dracut cmdline hook.
    paul@Orion-15:~$
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,111
    Blog Entries
    15

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by tannington View Post
    I'll have a search through the forum, see what I can find...



    These are the only 'dracut' related entries in the journal ... doesn't mean a lot to me I'm afraid

    Code:
    paul@Orion-15:~$ journalctl -b | grep -i dracut
    Mar 11 17:36:39 Orion-15 systemd[1]: Dependency failed for dracut ask for additional cmdline parameters.
    Mar 11 17:36:39 Orion-15 systemd[1]: dracut-cmdline-ask.service: Job dracut-cmdline-ask.service/start failed with result 'dependency'.
    Mar 11 17:36:39 Orion-15 systemd[1]: Starting dracut cmdline hook...
    Mar 11 17:36:39 Orion-15 systemd[1]: Started dracut cmdline hook.
    Mar 11 17:36:39 Orion-15 systemd[1]: Starting dracut pre-udev hook...
    Mar 11 17:36:39 Orion-15 systemd[1]: Started dracut pre-udev hook.
    Mar 11 17:36:39 Orion-15 dracut-cmdline[226]: dracut-dracut-049.1+git125.e2b2c9ef-1.1
    Mar 11 17:36:39 Orion-15 dracut-cmdline[226]: Using kernel command line parameters: resume=UUID=08a4ff75-8318-40cf-b78b-b7049064dfb5 root=UUID=2511d4d8-0425-4e80-bd14-86798396bdfb rootfstype=ext4 rootflags=rw,noatime BOOT_IMAGE=/boot/vmlinuz-5.5.7-1-default root=UUID=2511d4d8-0425-4e80-bd14-86798396bdfb noresume libata.force=noncq showopts
    Mar 11 17:36:39 Orion-15 systemd[1]: Condition check resulted in dracut pre-trigger hook being skipped.
    Mar 11 17:36:39 Orion-15 systemd[1]: Condition check resulted in dracut initqueue hook being skipped.
    Mar 11 17:36:39 Orion-15 systemd[1]: Condition check resulted in dracut pre-mount hook being skipped.
    Mar 11 17:36:40 Orion-15 systemd[1]: Condition check resulted in dracut mount hook being skipped.
    Mar 11 17:36:40 Orion-15 systemd[1]: Condition check resulted in dracut pre-pivot and cleanup hook being skipped.
    Mar 11 17:36:40 Orion-15 systemd[1]: dracut-pre-udev.service: Succeeded.
    Mar 11 17:36:40 Orion-15 systemd[1]: Stopped dracut pre-udev hook.
    Mar 11 17:36:40 Orion-15 systemd[1]: dracut-cmdline.service: Succeeded.
    Mar 11 17:36:40 Orion-15 systemd[1]: Stopped dracut cmdline hook.
    paul@Orion-15:~$
    Hi
    Seems it's this line;

    Code:
    Mar 11 17:36:39 Orion-15 systemd[1]: dracut-cmdline-ask.service: Job dracut-cmdline-ask.service/start failed with result 'dependency'.
    I don't see that service here.... can you check the status;

    Code:
    systemctl status dracut-cmdline-ask.service
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by malcolmlewis View Post
    ... I don't see that service here.... can you check the status;
    Code:
    paul@Orion-15:~$ systemctl status dracut-cmdline-ask.service
    Unit dracut-cmdline-ask.service could not be found.
    paul@Orion-15:~$
    Hmm... seems a good reason for it to fail.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  6. #6
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    245

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by tannington View Post
    After a zypper dup to 20200309 both of my TW machines have these 'errors' at boot:
    Code:
    systemd[1]: Failed to start Setup Virtual Console.
    and
    systemd[1]: Dependency failed for dracut ask for additional cmdline parameters.
    If you don’t need perfectly set-up text consoles (for example, if you're fine using an US kbd mapping when dropping to text), then you can try out my dirty hack from last year. Graphical sessions (Gnome, KDE-Plasma, XFCE etc) won’t see any detrimental effects.

    Can’t believe these vconsole problems are still a thing, grumblegrumble…

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,111
    Blog Entries
    15

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by tannington View Post
    Code:
    paul@Orion-15:~$ systemctl status dracut-cmdline-ask.service
    Unit dracut-cmdline-ask.service could not be found.
    paul@Orion-15:~$
    Hmm... seems a good reason for it to fail.
    Hi
    I wonder what is installed that wants it, have you played with the dracut.conf file? Do you have third party kernel modules?

    It is there;
    Code:
    ls /usr/lib/dracut/modules.d/98dracut-systemd/*cmdline-ask*
    /usr/lib/dracut/modules.d/98dracut-systemd/dracut-cmdline-ask.service  /usr/lib/dracut/modules.d/98dracut-systemd/dracut-cmdline-ask.sh
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,322
    Blog Entries
    3

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by tannington View Post
    Anyone else seeing these?
    I updated (in a virtual machine). No problems.

    Then I rebooted. But I was not watching the reboot. I was doing something else, while the VM rebooted. So I didn't notice any problems.

    Maybe I should go back and look more closely.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,430
    Blog Entries
    14

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Funny, systemd-vconsole-setup is disabled on my laptop. Could be I did this, but don't remember.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,280

    Default Re: TW20200309 Anyone else seeing these systemd 'errors' at boot.

    Quote Originally Posted by tannington View Post
    Code:
    paul@Orion-15:~$ systemctl status dracut-cmdline-ask.service
    Unit dracut-cmdline-ask.service could not be found.
    paul@Orion-15:~$
    Hmm... seems a good reason for it to fail.
    Code:
    erlangen:~ # systemctl status systemd-vconsole-setup.service 
    ● systemd-vconsole-setup.service - Setup Virtual Console
         Loaded: loaded (/usr/lib/systemd/system/systemd-vconsole-setup.service; static; vendor preset: disabled)
         Active: inactive (dead) since Wed 2020-03-11 16:03:20 CET; 4h 13min ago
           Docs: man:systemd-vconsole-setup.service(8)
                 man:vconsole.conf(5)
        Process: 944 ExecStart=/usr/lib/systemd/systemd-vconsole-setup (code=exited, status=0/SUCCESS)
       Main PID: 944 (code=exited, status=0/SUCCESS)
    
    Mar 11 16:03:20 erlangen systemd[1]: Starting Setup Virtual Console...
    Mar 11 16:03:20 erlangen systemd[1]: systemd-vconsole-setup.service: Succeeded.
    Mar 11 16:03:20 erlangen systemd[1]: Started Setup Virtual Console.
    erlangen:~ # systemctl status dracut-cmdline-ask.service 
    Unit dracut-cmdline-ask.service could not be found.
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •