Results 1 to 8 of 8

Thread: after update of nvidia graphics driver, not able to login in my user name

  1. #1
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    284

    Default after update of nvidia graphics driver, not able to login in my user name

    I did an upgrade of nvidia drivers from G04 to G05 using yast as I saw I could use higher level driver (GEforce 1050 ti). Software manager removed all the G04 files and installed the G05 files. G05 in software opensuse nvidia repo is same software version number that nvidia recommended for this video card on their website. I thought I was secure.

    After unenabling the nvida repo, I did a reboot. Reboot proceed fine until user login cam up. I was unable to login using my user name and pw. After user login screen just froze. It keeps saying "not listed" underneath normal login box. I tried all the desktops that I have installed (mate is my standard) and mu user name was not accepted and "not listed" kept coming up

    I clicked onto user "not listed" and was able to login successfully as root to mate desktop and to other desktops. I went to yast group and user management and my user name was listed there as before. I looked at settings and it said that my user login was not disabled. I did notice that " move home to new directory" was checked. I don't remember that before. I dont know what that means. I unchecked that with no effect.

    My home directory files are still there as I could see them as root.

    Any suggestions? The video seems to be working fine but something got modified in this change somewhere.

    Tom Kosvic

  2. #2

    Default Re: after update of nvidia graphics driver, not able to login in my user name

    Hi,

    Just to clear something up. can you login without the X or gui? I mean via Ctrl+Aalt+F6 and so on?
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  3. #3
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    284

    Default Re: after update of nvidia graphics driver, not able to login in my user name

    i could login to my user using ctrl+alt+f6. I have a terminal logged into my user account and my home directory looks intact.

    How do I start graphical display and start mate? What do I do to correct problem?

    I am thinking of setting nvidia graphics back to old version and seeing if i get back to where i was. Any thoughts?

  4. #4
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    284

    Default Re: after update of nvidia graphics driver, not able to login in my user name

    I ran startx and xinit says giving up. unable to connect to X server: Connection refused. also says:
    /usr/bin/Xorg is not setuid.

    looks like X is not running or got deleted by nvidia upgrade.
    Any advice to fix? I can get to software manage by a root login.

    Thanks all

  5. #5
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    284

    Default Re: after update of nvidia graphics driver, not able to login in my user name

    I ran startx and xinit says giving up. unable to connect to X server: Connection refused. also says:
    /usr/bin/Xorg is not setuid.

    looks like X is not running or got deleted by nvidia upgrade.
    Any advice to fix? I can get to software manage by a root login.

    Thanks all

  6. #6
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,148
    Blog Entries
    1

    Default Re: after update of nvidia graphics driver, not able to login in my user name

    Quote Originally Posted by tckosvic View Post
    I ran startx and xinit says giving up. unable to connect to X server: Connection refused. also says:
    /usr/bin/Xorg is not setuid.
    This is a typical result of trying to run X as non-root user via startx. For non-root user to succeed with startx usually requires modification of /etc/permissions.local. Its last line needs to be uncommented, then the instruction at the top of the file followed to apply the change.

    Something to try before trying to make startx work, to try to make login from the login manager work, is to disable Plymouth, which has a history of trouble when using NVidia's drivers. Strike the E key at the Grub menu, move the cursor to the end of the line (which probably is wrapped) that starts with linu, then append plymouth.enable=0, then proceed with boot according to the instruction on that Grub screen. Does this enable normal user login? If so, make it permanent by adding plymouth.enable=0 to the end of the GRUB_CMDLINE_LINUX_DEFAULT= string in /etc/default/grub like so
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash plymouth.enable=0 "
    then updating grub.cfg, or by uninstalling Plymouth altogether:
    Code:
    sudo zypper rm plymouth; sudo al plymouth
    I keep Plymouth uninstalled on all my installations. I find it to be no more than bloatware.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, TW, 15.3 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.2 on i965P w/ Radeon
    Tertiary: Mageia, Fedora, Debian, more on Kaby Lake & older Intel, AMD, NVidia &&&&&

  7. #7
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    284

    Default Re: after update of nvidia graphics driver, not able to login in my user name

    I have disabled plymouth at login as suggested and I still cant login to my user graphically. also I cant run startx when logged in as my user in a terminal with plymouth disabled. I get the same messages as before.
    I have changed nvidia drivers back to previous version with no change. i did a forced reinstall of all the X pattern files. i did a dvd 15.1 upgrade to my 15.1 with no success even after changing 75 files or so.

    I am postulating a 15.1 install to overwrite current installation but i dont want to lose my work. if i do fresh install am not sure whether to use the old g04 nvidia that worked or the g05 files that should work.

    any more ideas will be helpful. i dont know enough about login processes to troubleshoot this myself
    thanks, tom kosvic

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,148
    Blog Entries
    1

    Default Re: after update of nvidia graphics driver, not able to login in my user name

    Please paste here using code tags output from:
    Code:
    sudo zypper lr -EU
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, TW, 15.3 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.2 on i965P w/ Radeon
    Tertiary: Mageia, Fedora, Debian, more on Kaby Lake & older Intel, AMD, NVidia &&&&&

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •