Results 1 to 2 of 2

Thread: Lenovo Ideapad S740 with GTX 1650 not playing sound

  1. #1

    Default Lenovo Ideapad S740 with GTX 1650 not playing sound

    Hey Guys,

    I'm quite the newbie with linux in general.

    I've scoured the forums to try to figure out how to get the sound working on my Lenovo Ideapad S740.

    I previously installed elementary OS and I couldn't get the sound to work on that distro either. I ended up switching to OpenSUSE for no main reason, but I still can't get the sound working.

    Here are some of the outputs that I've seen on other forums being asked for

    Code:
    cat /proc/asound/cards
    HTML Code:
    --- no soundcards ---
    Code:
    hwinfo --sound
    HTML Code:
    23: PCI 1f.3: 0401 Multimedia audio controller                  
      [Created at pci.386]
      Unique ID: nS1_.QgFu6BfHwfA
      SysFS ID: /devices/pci0000:00/0000:00:1f.3
      SysFS BusID: 0000:00:1f.3
      Hardware Class: sound
      Model: "Intel Cannon Lake PCH cAVS"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0xa348 "Cannon Lake PCH cAVS"
      SubVendor: pci 0x17aa "Lenovo"
      SubDevice: pci 0x3827 
      Revision: 0x10
      Memory Range: 0x604b108000-0x604b10bfff (rw,non-prefetchable)
      Memory Range: 0x604b000000-0x604b0fffff (rw,non-prefetchable)
      IRQ: 16 (no events)
      Module Alias: "pci:v00008086d0000A348sv000017AAsd00003827bc04sc01i00"
      Driver Info #0:
        Driver Status: snd_hda_intel is not active
        Driver Activation Cmd: "modprobe snd_hda_intel"
      Driver Info #1:
        Driver Status: snd_soc_skl is not active
        Driver Activation Cmd: "modprobe snd_soc_skl"
      Driver Info #2:
        Driver Status: snd_sof_pci is not active
        Driver Activation Cmd: "modprobe snd_sof_pci"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
    Code:
    alsa-info.sh --upload
    http://alsa-project.org/db/?f=d1a5e6...b6451508646b97

    Any help would be greatly appreciated to try and figure out how to get my sound.

    I've tried to go into YaST and reconfigure the Intel Cannonlake PCH card as it shows up in the YaST GUI but I just get an error that the kernel module for sound support could not be loaded

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Lenovo Ideapad S740 with GTX 1650 not playing sound

    I note from the diagnostic script an 'Lenovo IdeaPad S740-15IRH' computer and also Tumbleweed with 5.5.4-1-default kernel.

    I note the alsa sound driver (in the kernel) does not recognize your sound card:
    Code:
    !!Soundcards recognised by ALSA
    !!-----------------------------
    --- no soundcards ---
    Further, the dmesg has entries I am not familiar with:
    Code:
    !!ALSA/HDA dmesg
    !!--------------
    [    8.522835] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    ...
    [    8.573019] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake  platform, using SOF driver
    [    8.885818] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [    8.886028] snd_soc_skl 0000:00:1f.3: Digital mics found on Skylake  platform, using SOF driver
    ...
    [    9.164867] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
    [    9.164869] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
    ...
    [ 1040.200059] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [ 1040.200286] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake  platform, using SOF driver
    The above makes me think you could try installing the package "alsa-firmware" , reboot, and see if that makes a difference, as one speculative possibility is your computer openSUSE Tumbleweed install is missing necessary software associated with your computer firmware.

    However my suspicion is that won't work (although it is worth a try).

    I've read others struggled with the Lenovo Yogo S740 and GNU/Linux sound. One user in this thread noted they succeeded with the following:

    The logs were being spammed with "snd_hda_intel 0000:00:1f.3: No response from codec, resetting bus". I found some comments on https://bugzilla.kernel.org/show_bug.cgi?id=205229 so "fixed" this issue with

    echo "options snd-hda-intel probe_mask=1" > /etc/modprobe.d/snd-hda-intel.conf

    This may break sound output via HDMI, I haven't been able to test it.

    For now everything seems to be working apart from the HDMI sound output issue above

    ... the above is based on this note in the bug report:

    There is a Debian code signing issue flying around, where the issue appears to be related to not being able to even load snd-hda-intel. (IMO) that's distinct from the current issue.

    - For me, a semi-reliable way of triggering the issue is to plug in and un-plug an external monitor (DisplayPort) monitor into either USB-C jack on the machine that advertises HDMI audio support.

    - I suspect that "options snd_hda_intel probe_mask=1" will prevent snd-hda-intel from enumerating the HDMI codec and thus perhaps sidestep the issue for now. No HDMI audio is more livable for me than random hangs and suspend failures...

    Honestly, I don't know if creating an /etc/modprobe.d/snd-hda-intel.conf file per that 'echo' recommendation is the best approach for openSUSE.

    If it were me on openSUSE, I would instead with root permissions either add this line to the file /etc/modprobe.d/50-sound.conf, or create a new file '/etc/modprobe.d/50-sound.conf' with this content :
    Code:
    options snd-hda-intel probe_mask=1
    save the change, re-boot the PC, and test the sound. See if that works. If not, then remove that entry.

    It may be worth while writing a bug report on openSUSE Tumbleweed if no success. Guidance can be provided on how to do that.

    .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •