Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

  1. #21

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Thanks, conram for the effort of trying this out.

    I think the main difference in your experiment is that all monitors are connected to the same GPU.


    In my setup 2 monitors are on GPU0 and 2 monitors are on GPU1 (see screenshot).
    There you can also see that i can only add the selected monitor to either X screen 1 or X screen 2. There is no option to add that monitor to X screen 0.


  2. #22
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,164
    Blog Entries
    15

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Hi
    In the selection box, wouldn't you select the second gpu for the other two displays?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #23

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    In the selection box, wouldn't you select the second gpu for the other two displays?
    Not sure which selection box you are referring to.

    The left two displays are connected to GPU0, the right two displays are connected to GPU1. The pictured configuration works flawlessly in LEAP 42.3.

    The answer was supposed to answer conram's suggestion to select X screen 0 for all 4 displays, which is not possible in nvidia-settings.

    I can only select a shared X screen for those displays sharing the same GPU.
    Sharing an X screen across all GPUs and Monitors is not supported by the nvidia-settings applet.

    Anyway, that is not my problem. The X server crashing in LEAP 15.1 with this perfectly legal configuration is my problem.

  4. #24
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,164
    Blog Entries
    15

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by karlheinrich View Post
    Not sure which selection box you are referring to.

    The left two displays are connected to GPU0, the right two displays are connected to GPU1. The pictured configuration works flawlessly in LEAP 42.3.

    The answer was supposed to answer conram's suggestion to select X screen 0 for all 4 displays, which is not possible in nvidia-settings.

    I can only select a shared X screen for those displays sharing the same GPU.
    Sharing an X screen across all GPUs and Monitors is not supported by the nvidia-settings applet.

    Anyway, that is not my problem. The X server crashing in LEAP 15.1 with this perfectly legal configuration is my problem.
    Hi
    The first one below the screens that has ..DVI-2 on GPU1 in your shot, then I would assume select advanced to set up the viewport etc? I can't really test as don't have that many screens, I do run three nvidia gpu's but only want the cuda cores, use my intel gpu for the screens...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #25

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    The first one below the screens that has ..DVI-2 on GPU1 in your shot, then I would assume select advanced to set up the viewport etc? I can't really test as don't have that many screens, I do run three nvidia gpu's but only want the cuda cores, use my intel gpu for the screens...
    The DVI-I ports are numbered 2 and 3 on each GPU, possibly because there are some other interfaces numbered 0 and 1? I Don't know.
    The depicted configuration is a shot from LEAP 42.3 where it functions just fine.

    The 15.1 X server crash remains unsolved.

  6. #26

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by karlheinrich View Post
    Thanks, conram for the effort of trying this out.

    I think the main difference in your experiment is that all monitors are connected to the same GPU.


    In my setup 2 monitors are on GPU0 and 2 monitors are on GPU1 (see screenshot).
    There you can also see that i can only add the selected monitor to either X screen 1 or X screen 2. There is no option to add that monitor to X screen 0.
    It's a multi gpu.I have two gpu but the bios does not allow running simultaneously. The option is one at a time so I can't test it.
    Could be your driver load only on one GPU.
    What is the output if you run
    Code:
    inxi -Fxz
    You can try enabling the base-mosaic and see if it will make your other monitors come to life.
    Code:
    nvidia-xconfig --base-mosaic
    as su and disable Xinerama
    People who do not break things first will never learn to create anything

  7. #27

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by conram View Post
    What is the output if you run
    Code:
    inxi -Fxz
    You can try enabling the base-mosaic and see if it will make your other monitors come to life.
    Code:
    nvidia-xconfig --base-mosaic
    as su and disable Xinerama
    I'm gonna try it but it's probably gonna take a while because this is my busiest desktop machine, and each distro switching cycle takes about an hour with disk swapping and all the reboots .

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •