Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

  1. #11

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Likely sddm these days... I use GNOME so hopefully another user may offer some advice. In /etc/gdm/custom.conf I had to set WaylandEnable=false as it interfered with the nvidia cards I have.
    Yeah you're right, sddm it is.

    IMO The logs indicate that either the X server or the nvidia driver is the culprit:
    Code:
    1. [ 447.893] (EE)
    2. [ 447.893] (EE) Backtrace:
    3. [ 447.893] (EE) 0: X (xorg_backtrace+0x65) [0x559f5554cf45]
    4. [ 447.893] (EE) 1: X (0x559f5539b000+0x1b5c19) [0x559f55550c19]
    5. [ 447.893] (EE) 2: /lib64/libpthread.so.0 (0x7fd259ff7000+0x12300) [0x7fd25a009300]
    6. [ 447.893] (EE) 3: /lib64/libc.so.6 (gsignal+0x110) [0x7fd259c73160]
    7. [ 447.893] (EE) 4: /lib64/libc.so.6 (abort+0x151) [0x7fd259c74741]
    8. [ 447.893] (EE) 5: /lib64/libc.so.6 (0x7fd259c3d000+0x2e75a) [0x7fd259c6b75a]
    9. [ 447.893] (EE) 6: /lib64/libc.so.6 (0x7fd259c3d000+0x2e7d2) [0x7fd259c6b7d2]
    10. [ 447.893] (EE) 7: X (0x559f5539b000+0x41ca9) [0x559f553dcca9]
    11. [ 447.893] (EE) 8: X (0x559f5539b000+0x9b9c8) [0x559f554369c8]
    12. [ 447.893] (EE) 9: X (_CallCallbacks+0x34) [0x559f553fc7f4]
    13. [ 447.893] (EE) 10: X (0x559f5539b000+0x60442) [0x559f553fb442]
    14. [ 447.893] (EE) 11: /lib64/libc.so.6 (__libc_start_main+0xea) [0x7fd259c5df8a]
    15. [ 447.893] (EE) 12: X (_start+0x2a) [0x559f553e512a]
    16. [ 447.893] (EE)
    17. [ 447.893] (EE)
    18. Fatal server error:
    19. [ 447.893] (EE) Caught signal 6 (Aborted). Server aborting
    20. [ 447.893] (EE)
    21. [ 447.893] (EE)
    22. Please consult the The X.Org Foundation support
    23. at http://wiki.x.org
    24. for help.
    That's probably independent of the desktop.

    I hope for a resolution. Otherwise I'm stuck with 42.3.
    Well, maybe a later version yet to come will fix the problem.
    Last edited by malcolmlewis; 23-Feb-2020 at 13:04.

  2. #12
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,665
    Blog Entries
    15

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by karlheinrich View Post
    Yeah you're right, sddm it is.

    IMO The logs indicate that either the X server or the nvidia driver is the culprit:
    Code:
    1. [ 447.893] (EE)
    2. [ 447.893] (EE) Backtrace:
    3. [ 447.893] (EE) 0: X (xorg_backtrace+0x65) [0x559f5554cf45]
    4. [ 447.893] (EE) 1: X (0x559f5539b000+0x1b5c19) [0x559f55550c19]
    5. [ 447.893] (EE) 2: /lib64/libpthread.so.0 (0x7fd259ff7000+0x12300) [0x7fd25a009300]
    6. [ 447.893] (EE) 3: /lib64/libc.so.6 (gsignal+0x110) [0x7fd259c73160]
    7. [ 447.893] (EE) 4: /lib64/libc.so.6 (abort+0x151) [0x7fd259c74741]
    8. [ 447.893] (EE) 5: /lib64/libc.so.6 (0x7fd259c3d000+0x2e75a) [0x7fd259c6b75a]
    9. [ 447.893] (EE) 6: /lib64/libc.so.6 (0x7fd259c3d000+0x2e7d2) [0x7fd259c6b7d2]
    10. [ 447.893] (EE) 7: X (0x559f5539b000+0x41ca9) [0x559f553dcca9]
    11. [ 447.893] (EE) 8: X (0x559f5539b000+0x9b9c8) [0x559f554369c8]
    12. [ 447.893] (EE) 9: X (_CallCallbacks+0x34) [0x559f553fc7f4]
    13. [ 447.893] (EE) 10: X (0x559f5539b000+0x60442) [0x559f553fb442]
    14. [ 447.893] (EE) 11: /lib64/libc.so.6 (__libc_start_main+0xea) [0x7fd259c5df8a]
    15. [ 447.893] (EE) 12: X (_start+0x2a) [0x559f553e512a]
    16. [ 447.893] (EE)
    17. [ 447.893] (EE)
    18. Fatal server error:
    19. [ 447.893] (EE) Caught signal 6 (Aborted). Server aborting
    20. [ 447.893] (EE)
    21. [ 447.893] (EE)
    22. Please consult the The X.Org Foundation support
    23. at http://wiki.x.org
    24. for help.
    That's probably independent of the desktop.

    I hope for a resolution. Otherwise I'm stuck with 42.3.
    Well, maybe a later version yet to come will fix the problem.
    Hi
    Does it work if you try the likes of IceWM instead of Plasma? Could be the legacy driver as well....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #13
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,384

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Not everything that matters is on an (EE) line. You should upload to http://susepaste.org/ the whole file so that we might spot clues.

    Also you could try stripping out irrelevancies from NVidia's xorg.conf. There is no purpose I can imagine served by it creating sections for input unless using a touchscreen.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1, TW, 15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on i965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&

  4. #14

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    I have uploaded full logs to paste.opensuse.org.
    see previous posts.

    The very same xorg.conf works fine in Leap 42.3.
    I don't believe stripping input sections will change the situation as the log indcates that the server ignores them anyway.

  5. #15

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Try to update to 390.132: https://www.nvidia.com/Download/driv...x/153832/en-us

    Possibly troubles with parameter "nvidiaXineramaInfoOrder".

  6. #16

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    If you run the nvidia-settings, what does it show in the X Server XVideo Settings?

    Edit:
    Ok, I saw it, you said it is disabled in nvidia-settings.
    In the configuration it should be set to X screen 0.
    and enable the disabled monitors as su to save it.
    People who do not break things first will never learn to create anything

  7. #17

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by conram View Post
    If you run the nvidia-settings, what does it show in the X Server XVideo Settings?

    Edit:
    Ok, I saw it, you said it is disabled in nvidia-settings.
    In the configuration it should be set to X screen 0.
    and enable the disabled monitors as su to save it.
    In nvidia-settings it is impossible to add more than two monitors to X screen 0.
    If you look at the configuration in my first post, that is what works nicely on OpenSuse LEAP 42.3.
    The very same configuration crashes the X server on LEAP 15.1.

    My conclusion: a change in X is likely to have caused the problem.

  8. #18

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Quote Originally Posted by karlheinrich View Post
    In nvidia-settings it is impossible to add more than two monitors to X screen 0.
    If you look at the configuration in my first post, that is what works nicely on OpenSuse LEAP 42.3.
    The very same configuration crashes the X server on LEAP 15.1.

    My conclusion: a change in X is likely to have caused the problem.
    Is it? I removed my extra monitor, I am only using two right now I can try
    to add one more, to see if really impossible for more than two. Oh
    I am using tumbleweed but have a Leap 15.1 on another partition which I am not booting right now.
    I will boot on Leap 15.1 and reinstall the driver and see if 3 monitors will work and post back.
    People who do not break things first will never learn to create anything

  9. #19

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Hi,
    So I added another monitor in my two monitor setup.
    I have two monitors and one tv now.
    Graphic card is NVIDIA GeForce GTX 650 Ti
    The driver isNVIDIA_Linux-x86_64-440.59
    Procedure I did:
    I deleted my xorg.conf, then rebooted Leap 15.1,
    boot to init 3 and installed the .run driver.
    As su I run nviia-settings and configured the three monitors
    as X screen 0.
    At first after running nvidia-settings, I just logout and login,
    it didn't work, the tv connected to HDMI after login was disabled,
    I have to manually enable it to function. Then I run the nvidia-settings again
    enabled the tv then rebooted. This time all three monitors are now working.
    Hope this will work for you.
    I am using Xfce 4.14.
    To add I also deleted the display.xml in my /home/conram/.config/xfce4/xfonf
    to ensure that I am starting a clean config on my displays.

    I also tested this in IceWM and Plasma and found it to work also.
    In plasma I don't touch the kscreen2, it is disabled.
    People who do not break things first will never learn to create anything

  10. #20

    Default Re: Xorg crashes after upgrade to LEAP 15.1 (nvidia)

    Here is the image.
    People who do not break things first will never learn to create anything

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •