Results 1 to 4 of 4

Thread: NetworkManager drops connection after last update 2020 feb 19

  1. #1

    Exclamation NetworkManager drops connection after last update 2020 feb 19

    Update was 2020 feb 19, previous was ~feb 16.
    NM tries to establish connection, then drops it.

    Service "wicked" works well.

    I use kernel from "Stable" repo: 5.5.4-2.1.g813d10d, previous was 5.5.4-1.g119f9ca.
    All works well with kernel 5.5.4-1.g119f9ca.
    Trying both kernels after update: same mistakes.

    Enabling/disabling IPv6 didn't helped.

    Some output with dmesg:
    trying to establish connection every 15 seconds, then fails.

    Code:
    [   83.324589] r8169 0000:03:00.0 eth0: Link is Up - 1Gbps/Full - flow control rx/tx
    [   83.324606] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [   83.329432] r8169 0000:03:00.0 eth0: Link is Down
    [   83.345166] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [   83.469659] r8169 0000:03:00.0 eth0: Link is Down
    [   83.505739] NET: Registered protocol family 17
    [   89.520812] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [   89.650909] r8169 0000:03:00.0 eth0: Link is Down
    [  116.387431] r8169 0000:03:00.0 eth0: Link is Up - 1Gbps/Full - flow control rx/tx
    [  116.391844] r8169 0000:03:00.0 eth0: Link is Down
    [  116.409442] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  116.533230] r8169 0000:03:00.0 eth0: Link is Down
    [  122.584872] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  122.717883] r8169 0000:03:00.0 eth0: Link is Down
    [  149.353390] r8169 0000:03:00.0 eth0: Link is Up - 1Gbps/Full - flow control rx/tx
    [  149.357844] r8169 0000:03:00.0 eth0: Link is Down
    [  149.381006] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  149.509838] r8169 0000:03:00.0 eth0: Link is Down
    [  155.565024] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  155.694958] r8169 0000:03:00.0 eth0: Link is Down
    [  182.478672] r8169 0000:03:00.0 eth0: Link is Up - 1Gbps/Full - flow control rx/tx
    [  182.483337] r8169 0000:03:00.0 eth0: Link is Down
    [  182.501416] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  182.625673] r8169 0000:03:00.0 eth0: Link is Down
    [  188.680872] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  188.818780] r8169 0000:03:00.0 eth0: Link is Down
    [  215.902989] r8169 0000:03:00.0 eth0: Link is Up - 1Gbps/Full - flow control rx/tx
    [  215.907843] r8169 0000:03:00.0 eth0: Link is Down
    [  215.924836] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  216.061182] r8169 0000:03:00.0 eth0: Link is Down
    [  222.124917] Generic FE-GE Realtek PHY r8169-300:00: attached PHY driver [Generic FE-GE Realtek PHY] (mii_bus:phy_addr=r8169-300:00, irq=IGNORE)
    [  222.260393] r8169 0000:03:00.0 eth0: Link is Down

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,309
    Blog Entries
    3

    Default Re: NetworkManager drops connection after last update 2020 feb 19

    While running wicked, delete any files associated with this connection.

    Look in "/etc/NetworkManager/system-connections"
    and in "/var/lib/NetworkManager".

    I don't know if that will help, but it is worth trying.

    I had a problem on Tumbleweed. Switching to "wicked" fixed it. Then forcing a fresh configuration with NetworkManager got that working again. It looked as if NetworkManager was somehow getting the settings wrong.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3

    Default Re: NetworkManager drops connection after last update 2020 feb 19

    I deleted connections settings stored in /etc/NetworkManager/system-connections ad created new - nothing changed.

    Then I deleted DHCP lease keys in /var/lib/NetworkManager.
    After restart of NM it works again.

    Thank you very much, mr. nrickert.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,309
    Blog Entries
    3

    Default Re: NetworkManager drops connection after last update 2020 feb 19

    I'm glad you now have it working.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •