Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Upgrade naar 15.1 hangt bij [OK] Started locale service

  1. #1

    Default Upgrade naar 15.1 hangt bij [OK] Started locale service

    Dag,

    Ik heb mijn laptop (lenovo T420) met OpenSuse 15.0 proberen te upgraden naar 15.1 m.b.v. een installatie-DVD.
    Alles leek goed te gaan, maar bij het opstarten geraakt-ie nu niet verder dan [OK] Started Locale Service.

    Ik heb al wat gezocht op het web, maar kom niet verder.

    Iemand een idee wat er aan de hand zou kunnen zijn?

    Bij voorbaat dank voor jullie reacties.

    Met vriendelijke groet,
    Wilbert.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Hallo en welkom op de openSUSE forums.

    Om even precies te weten hoe je hebt geprobeerd the upgraden.
    • heb je een verse installatie gedaan (met behoud van je /home bestandssysteem)
    • of heb je Upgrade gekozen van het eerste menu van de installatie DVD?
    Henk van Velden

  3. #3

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Quote Originally Posted by hcvv View Post
    Om even precies te weten hoe je hebt geprobeerd the upgraden.
    • heb je een verse installatie gedaan (met behoud van je /home bestandssysteem)
    • of heb je Upgrade gekozen van het eerste menu van de installatie DVD?
    Dag,

    Ik heb "Upgrade" gekozen in het menu van de DVD.

    Nog wat info:
    - met CTRL-ALT-F1 kan ik wel in een console-scherm komen en inloggen als root (of als normale user), maar ik weet niet echt waar ik het probleem nou zoeken moet...
    Heb hierin al "startx" geprobeerd, maar zonder resultaat.
    - CTRL-ALT-F7 brengt me weer terug naar gehangen X-sessie.

    Met vriendelijke groet,

    Wilbert.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Aha, je komt dus toch iets verder dan ik dacht. Het is niet de upgrade die hangt (zoals je in the titel zegt. Het ge-upgrade systeem hangt.

    Het systeem loopt, X is gestart (anders zou je geen Ctrl-Alt Fn functionaliteit hebben) maar je krijgt geen GUI login scherm.

    Hm, ben ik niet zo sterk in. Maar er komen vast nog wel meer helpers. Intussen zou je exact kunnen opgeven welke grafische kaart je hebt.
    Last edited by hcvv; 19-Feb-2020 at 06:49.
    Henk van Velden

  5. #5

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Quote Originally Posted by hcvv View Post
    Aha, je komt dus toch iets verder dan ik dacht. Het is niet de upgrade die hangt (zoals je in the titel zegt. Het ge-upgrade systeem hangt.

    Het systeem loopt, X is gestart (anders zou je geen Ctrl-Alt Fn functionaliteit hebben) maar je krijgt geen GUI login scherm.

    Hm, ben ik niet zo sterk in. Maar er komen vast nog wel meer helpers. Intussen zou je exact kunnen opgeven welke grafische kaart je hebt.

    Dag,

    Bedankt voor je reactie.

    Volgens een zoektocht op het internet is het een Intel HD Graphics 3000.
    In Yast2 --> Hardware --> Display lees ik: intel 2nd generation core processor family integrated graphics contoller

    Geen idee of dit jullie verder helpt.


    Overigens heb ik dit probleem bij de upgrade van 42.3 naar 15.0 niet gehad... (toen wel via zypper, niet via DVD).


    Met vriendelijke groet,

    Wilbert.

  6. #6

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Dag,

    Ik heb nog wat zitten proberen:

    "3" toegevoegd aan GRUB, maar ik had niet het gevoel dat dat wat uitmaakte.
    Ik kreeg het volgende te zien:
    Code:
    ...
    [ OK ] Started scrub btrfs filesystem, verify block checksums.
           Starting X Display manager...
    [ OK ] Started Balance block groups on a btrfs filesystem.
    [ OK ] Started Discard unused blocks once a week.
           Starting Postfix Mail Transport Agent...
    [ OK ] Started Daily rotation of log files.
    [ OK ] Started Timeline of Snapper Snapshots.
    [ OK ] Started Check if mainboard battery is Ok.
    [ OK ] Started Discard unused blocks on a mounted filesystem.
    [ OK ] Reached target Timers.
           Starting WPA Supplicant deamon...
           Starting Locale Service...
    [ OK ] Started WPA Supplicant daemon.
    [ OK ] Started  SuSEfirewall2 phase 2.
    Hier bleef-ie de laatste keer hangen.

    Dus CTRL-ALT-F1 om in te loggen als root.

    Dit leverde de volgende output:
    Code:
    [ OK ] Started Locale Service.
    [ OK ] Started Hold until boot process finishes up.
    
    Welcome to OpenSUSE Leap 15.1 - Kernel  4.12.14-lp151.28.36- (nog iets, maar stond niet op de schermfoto die ik maakte)
    
    
    linux-gh4e login: root
    Password:
    Last login: Fri Feb 21 09:44:49 on tty3
    Have a lot of fun...
    linux-gh4e:~ # _
    Als ik hier "startx" uitvoer dan wordt het scherm zwart, zie een tijdje heel wat diskactiviteit maar verder gebeurt er niets.

    Als ik dan met CTRL-ALT-F2 een andere console open verschijnt er iets als:
    Code:
    [ 307.290853] ata1.00: exception Emask 0x0 SAct 0x800 SErr 0x0 action 0x0
    [ 307.290896] ata1.00: irq_stat 0x40000008
    [ 307.290917] ata1.00: failed command: READ FPDMA QUEUED
    [ 307.290942] ata1.00: cmd 60/08:58:f8:5a/00:00:16:00:00/40 tag 11 ncq dma 4096 in
                           res 41/40:08:f9:5a:51/00:00:16:00:00/66 Emask 0x409 (media error) <F>
    [ 307.291004] ata1.00: status: { DRDY ERR }
    [ 307.291023] ata1.00: error: {UNC }
    [ 307.293699] print_req_error: I/O error, dev sda, sector 374430457
    Iedere paar seconden verschijnt er dan zo'n nieuw blok met zulke meldingen, enkel andere hex-getallen en soms ook "(device error)" i.p.v. "(media error)".
    Ook het getal achter "tag" verschilt steeds.

    Heeft iemand hier iets aan?
    Ik heb zelf totaal geen idee wat het allemaal betekent.

    Met vriendelijke groet,

    Wilbert.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Nogmaals, als je met Ctrl-Alt-Fn kunt werken loopt X all. startx doen is dan redelijk overbodig (zo niet storend).

    Overigens verbaas ik mij over die vermelding van SuSEfirewall2. Dat is toch al lang vervangen door firewalld?
    Henk van Velden

  8. #8

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Quote Originally Posted by hcvv View Post
    Nogmaals, als je met Ctrl-Alt-Fn kunt werken loopt X all. startx doen is dan redelijk overbodig (zo niet storend).
    Ah, OK, klinkt logisch.

    Quote Originally Posted by hcvv View Post
    Overigens verbaas ik mij over die vermelding van SuSEfirewall2. Dat is toch al lang vervangen door firewalld?
    Geen idee, ik heb me daar nooit in verdiept. Het wordt standaard geïnstalleerd, dacht ik...


    Met vriendelijke groet,

    Wilbert.

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Hm, ik weet ook niet of het er iets mee te maken heeft. In ider geval, maak ergens een notitie on je firewall gebruikt the checken als dit allemaal voorbij is.

    In je beschrijving zie ik ook dingen die op een schijfprobleem wijzen: I/O error op /dev/sda.
    Klinkt niet zo best.
    Henk van Velden

  10. #10

    Default Re: Upgrade naar 15.1 hangt bij [OK] Started locale service

    Dag,

    Nou, ik heb nog e.e.a. geprobeerd met runlevel 3 en dan startx: ik hoorde het muziekje dat ik gewend was te horen na een grafische login, maar geen desktop te zien.
    In de logging Xorg kon ik ook niet ontdekken wat er nou fout is...

    Ik heb de /home-directory maar naar een externe drive gekopieerd.
    Ik ga morgen de schijf eens controleren op badblocks en dan een volledig nieuwe installatie uitvoeren; eens zien of dat een geheel werkend systeem oplevert.
    Anders moet er maar een nieuwe schijf in...

    Toch bedankt voor de reacties...

    Groeten,
    Wilbert.
    Last edited by Cymbaline; 21-Feb-2020 at 10:41. Reason: typo

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •