Results 1 to 6 of 6

Thread: Logitech K120

  1. #1
    Join Date
    Mar 2017
    Location
    Vancouver Island, British Columbia, Canada
    Posts
    6

    Question Logitech K120

    The Logitech K120 keyboard is a bare-bones wired keyboard which appears to be supported by Linux kernel 2.6+ (according to their website), yet is not recognized in Tumbleweed. The only reason I purchased this keyboard is to ensure I have something during my builds/setups, so I'm a little disappointed that such a basic device isn't recognized but such a sweet, sweet distribution.

    I have a number of Logitech devices now that don't seem to be supported for whatever reason (M720 Triathlon mouse & N305 numberpad) and I'm looking to change that.

    I know the basics of C and figure this is something I should really know how to do by now, but don't know where to start. Can anyone point me in the right direction for the basics of building device drivers for openSUSE?

    Much appreciated.

  2. #2

    Default Re: Logitech K120

    i really do not want to seem like i am hijacking the thread here, but just a question ... are these devices USB and plugged into a hub? ... if so I am having issues since just say this past Wednesday or so where any input device i try that is plugged into any hub i have, get's seen (lsbusb and dmesg) but doesn't function ... plugged directly into the laptop and it works fine.

    Anyway if this is not the case here, I will not post again ... just felt like asking as your devices "may be compatible" but you are experience a bug that myself and one other person is seeing with Tumbleweed in the past few days

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,874

    Default Re: Logitech K120

    @drewbags:

    Please take a look at this list: <https://www.freedesktop.org/wiki/Sof...Compatibility/>.
    • Logitech Generic Keyboard
    • Logitech Ultra-X Keyboard
    • Logitech Access Keyboard

    You then setup in “/etc/X11/xorg.conf.d/00-keyboard.conf” by calling “localectl” «with the user “root”»:
    Code:
     > localectl list-keymaps     – to determine the available key maps – choose the one suited to where you are on this planet …
     # localectl set-x11-keymap «keyboard mapping» logitech_base nodeadkeys terminate:ctrl_alt_bksp
    I've chosen the Logitech Model “logitech_base” for this example – the variant “nodeadkeys” may or, may not, apply for your case – please see the “xkeyboard-config” man page to determine if, your keyboard mapping needs the “nodeadkeys” variant or, not …

  4. #4
    Join Date
    Mar 2017
    Location
    Vancouver Island, British Columbia, Canada
    Posts
    6

    Default Re: Logitech K120

    Interesting... logitech_base isn't showing up in the man pages on either of my Tumbleweed machines.

  5. #5
    Join Date
    Mar 2017
    Location
    Vancouver Island, British Columbia, Canada
    Posts
    6

    Default Re: Logitech K120

    Setting the keymap through localectl still edits the xorg.conf.d file successfully though, as I now see:

    Code:
    Section "InputClass"
       Identifier "system-keyboard"
       MatchIsKeyboard "on"
       Option "XkbLayout" "us"
       Option "XkbModel" "logitech_base"
       Option "XkbVariant" "terminate:ctrl_alt_bksp"
    EndSection
    No success unfortunately.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,874

    Default Re: Logitech K120

    Quote Originally Posted by drewbags View Post
    logitech_base isn't showing up in the man pages on either of my Tumbleweed machines.
    With a CLI and the user “root”, execute “mandb” a couple of times to rebuild the “man” database.
    Code:
    > man xkeyboard-config | grep -i 'logitech'
           │logitech_base         Logitech                                           │
           │logitech_g15          Logitech G15 extra keys via G15daemon              │
           │logiaccess            Logitech Access                                    │
           │logiclx300            Logitech Cordless Desktop LX-300                   │
           │logii350              Logitech Internet 350                              │
           │logimel               Logitech Internet 350                              │
           │logicd                Logitech Cordless Desktop                          │
           │logicd_it             Logitech Cordless Desktop iTouch                   │
           │logicd_nav            Logitech Cordless Desktop Navigator                │
           │logicd_opt            Logitech Cordless Desktop Optical                  │
           │logicda               Logitech Cordless Desktop (alt.)                   │
           │logicdpa2             Logitech Cordless Desktop Pro (2nd alt.)           │
           │logicfn               Logitech Cordless Freedom/Desktop Navigator        │
           │logicdn               Logitech Cordless Desktop Navigator                │
           │logiitc               Logitech iTouch Cordless Y-RB6                     │
           │logiik                Logitech Internet                                  │
           │itouch                Logitech iTouch                                    │
           │logicink              Logitech Internet Navigator                        │
           │logiex110             Logitech Cordless Desktop EX110                    │
           │logiinkse             Logitech iTouch Internet Navigator SE              │
           │logiinkseusb          Logitech iTouch Internet Navigator SE USB          │
           │logiultrax            Logitech Ultra-X                                   │
           │logiultraxc           Logitech Ultra-X Cordless Media Desktop            │
           │logidinovo            Logitech diNovo                                    │
           │logidinovoedge        Logitech diNovo Edge                               │
     >
    • « Had to remove some “extraneous noise” lines containing warnings … »

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •