Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: "at-bus-launcher not responding" error when trying to shut down????

  1. #1

    Default "at-bus-launcher not responding" error when trying to shut down????

    Folks:

    Posting in this sub-forum to follow up on what was a significant problem in TW and possibly grub, took a lot of heavy lifting from the forum gurus to repair, but since then the system has been running well . . . using the "default video module" as per "mrmazda's" suggestion . . . rather than "nouveau" or "nvidia" . . . although there might be some issues with getting a TTY shell to show up . . . ???? But that isn't today's complaint . . . .

    Ran a search of "at-bus-launcher" and "no results found" was the response, so I'm posting here to report that every time I try to shut down from the main menu an error of "at-bus-launcher is not responding, would you like to shut down anyway?" error dialogue opens . . . if I click yes, the machine must go into a "shutting down in one minute, but from a few seconds from now . . ." mode, because the machine pauses for awhile before then beginning to shut down . . . .

    I prefer that when I click "shut down" the machine just "shuts down" . . . no error window asking me if I "really want to shut down because people are still doing stuff and would like to keep doing that, particularly mr. bus-launcher is busy" type message . . . . Any way to work around that problem??

    thanks kindly,

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,083

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    Quote Originally Posted by non_space View Post
    I prefer that when I click "shut down" the machine just "shuts down" . . . no error window asking me if I "really want to shut down because people are still doing stuff and would like to keep doing that, particularly mr. bus-launcher is busy" type message . . . . Any way to work around that problem??
    Highly annoying to have to wait to shut down, I fully agree. What does
    Code:
    sudo journalctl | grep at-bus-launcher
    output? If you get any hits, do
    Code:
    sudo journalctl -b
    and search for at-bus-launcher to see the messages before and after for clues to what it belongs to or causes it.

    Is this in your Mac? If not, are there AT bus devices present, maybe a floppy drive, or a CD or DVD drive on ATAPI/PATA? Do you use a PS/2 keyboard connector plugged into the correct port?

    Is this a Wayland session? Xorg? Which DE do you use, Gnome? KDE? Other?

    Check for clues also in ~/.xsession-errors.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  3. #3

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    @mrmazda:

    Thanks for the reply, I'm now away from that computer so I can't run any commands just yet. Yep, on the Mac Pro, there is an optical drive, there is a plug-in usb keyboard, don't know what PS/2 keyboard is . . . .

    This is a "new" thing in TW . . . didn't happen in Leap when I had that going, can't remember if this started with this recent install, as there were significant issues with it . . . but possibly showed up after some updates . . . .

    Should be Xorg with MATE DE . . . .

    I also have MATE running in a Gecko install and this issue isn't happening over there . . . in the other OpenSUSE system that I have installed . . . .

  4. #4

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    Quote Originally Posted by mrmazda View Post
    Highly annoying to have to wait to shut down, I fully agree. What does
    Code:
    sudo journalctl | grep at-bus-launcher
    output?
    No output on that command.

    Check for clues also in ~/.xsession-errors.
    I tried to run it as a "sudo cat" and it returned "No such file or directory." I opened File sytem in the GUI and searched it with ".xsession-errors" . . . nothing came back.

  5. #5
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,083

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    I don't have any Mate installations, so have no way to test, but I suspect this is about your Mate session, not X or the base system. To see if this is the case, log into an IceWM session instead of Mate, then try shutting down.

    If you haven't already done so, try logging out of your desktop session, then choosing to shut down from the greeter/login screen. Does it make a difference?

    Please paste here using code tags output from
    Code:
    sudo journalctl -b -1 | grep ailed
    sudo zypper lr -d
    There could be clues in either. If the first produces hits, you could
    Code:
    sudo journalctl -b -1 | less
    then scan backwards from the end looking for the hit text, and examine before and after for any available context.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  6. #6

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    Code:
    ~> sudo journalctl -b -1 | grep ailed
    [sudo] password for root: 
    Feb 18 07:08:41 linux-f6nl systemd[1]: haveged.service: Failed with result 'exit-code'.
    Feb 18 07:08:50 linux-f6nl systemd-udevd[867]: controlC0: Process '/usr/sbin/alsactl restore 0' failed with exit code 99.
    Feb 18 07:08:51 linux-f6nl systemd-udevd[865]: controlC1: Process '/usr/sbin/alsactl restore 1' failed with exit code 99.
    Feb 18 07:08:52 linux-f6nl nscd[1076]: 1076 stat failed for file `/etc/services'; will try again later: No such file or directory
    Feb 18 07:08:57 linux-f6nl firewalld[1180]: ERROR: Failed to load service file '/usr/lib/firewalld/services/docker-swarm.xml': INVALID_PROTOCOL: esp
    Feb 18 07:08:57 linux-f6nl firewalld[1180]: ERROR: Failed to load service file '/usr/lib/firewalld/services/gre.xml': INVALID_PROTOCOL: gre
    Feb 18 07:08:57 linux-f6nl firewalld[1180]: ERROR: Failed to load service file '/usr/lib/firewalld/services/ipsec.xml': INVALID_PROTOCOL: ah
    Feb 18 07:09:20 linux-f6nl accounts-daemon[2056]: g_dbus_interface_skeleton_get_object_path: assertion 'G_IS_DBUS_INTERFACE_SKELETON (interface_)' failed
    Feb 18 07:11:31 linux-f6nl at-spi-bus-laun[5941]: Failed to register client: Timeout was reached
    Feb 18 09:13:06 linux-f6nl org.mate.panel.applet.MateMenuAppletFactory[23730]: MESA-LOADER: failed to open nouveau (search paths /usr/lib64/dri)
    Feb 18 09:13:06 linux-f6nl org.mate.panel.applet.MateMenuAppletFactory[23730]: libGL error: failed to load driver: nouveau
    Feb 18 09:18:03 linux-f6nl mate-session[5876]: WARNING: Client '/org/gnome/SessionManager/Client1' failed to reply before timeout
    Code:
    ~> sudo zypper lr -d
    # | Alias                            | Name                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                 | Service
    --+----------------------------------+----------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                               |        
    2 | download.opensuse.org-oss        | Main Repository (OSS)      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                   |        
    3 | download.opensuse.org-tumbleweed | Main Update Repository     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                     |        
    4 | openSUSE-20191204-0              | openSUSE-20191204-0        | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-SanDisk_Cruzer_Glide_4C531001500607105562-0:0-part2 |        
    5 | repo-debug                       | openSUSE-Tumbleweed-Debug  | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/tumbleweed/repo/oss/                             |        
    6 | repo-source                      | openSUSE-Tumbleweed-Source | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/tumbleweed/repo/oss/
    Code:
    sudo journalctl -b -1 | less
    Brought a huge number of lines, didn't show the kind of "fails" that the first command brought back . . . does any of that point to some problem?

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,083

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    Quote Originally Posted by non_space View Post
    Code:
    sudo journalctl -b -1 | less
    Brought a huge number of lines, didn't show the kind of "fails" that the first command brought back . . . does any of that point to some problem?
    Several of those lines point to potentially serious trouble. Actually I shouldn't have suggested the "| less" part, because less is what journalctl incorporates in the first place.

    As always with less, while its output remains on screen you can search using / to start, then typing a string to search for, such as at-spi-bus-laun, which looks like a good match for your thread title. If interested only in this one failed line, you can get some likely helpful context this way:
    Code:
    sudo journalctl -b -1 | grep -A8 -B8 at-spi-bus-laun
    "stat failed for file `/etc/services'" is a known problem that I have no idea what to do about. I have seen multiple factory mailing list threads discussing it. *bus-launcher could be more fallout because of that more general problem.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    Quote Originally Posted by mrmazda View Post
    Several of those lines point to potentially serious trouble. Actually I shouldn't have suggested the "| less" part, because less is what journalctl incorporates in the first place.

    As always with less, while its output remains on screen you can search using / to start, then typing a string to search for, such as at-spi-bus-laun, which looks like a good match for your thread title. If interested only in this one failed line, you can get some likely helpful context this way:
    Code:
    sudo journalctl -b -1 | grep -A8 -B8 at-spi-bus-laun
    "stat failed for file `/etc/services'" is a known problem that I have no idea what to do about. I have seen multiple factory mailing list threads discussing it. *bus-launcher could be more fallout because of that more general problem.
    Did run that last line and it brought quite a long list, I just copied the bottom few lines . . . .

    Code:
    Feb 18 09:18:52 linux-fl at-spi-bus-launcher[324]: dbus-daemon[324]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=489 pid=300 comm="/usr/sbin/lightdm-gtk-greeter ")
    Feb 18 09:18:52 linux-fl at-spi-bus-launcher[324]: dbus-daemon[324]: Successfully activated service 'org.a11y.atspi.Registry'
    Feb 18 09:18:52 linux-fl at-spi-bus-launcher[347]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
    Feb 18 09:18:52 linux-fl systemd[1]: session-2.scope: Succeeded.
    Feb 18 09:18:52 linux-fl systemd-logind[1193]: Removed session 2.
    Feb 18 09:19:02 linux-fl systemd[1]: Stopping User Manager for UID 1000...
    Feb 18 09:19:02 linux-fl systemd[5861]: Stopped target Bluetooth.
    Feb 18 09:19:02 linux-fl systemd[5861]: Stopped target Main User Target.
    Feb 18 09:19:02 linux-fl systemd[5861]: Stopping D-Bus User Message Bus...
    Feb 18 09:19:02 linux-fl systemd[5861]: dbus.service: Succeeded.
    Feb 18 09:19:02 linux-fl systemd[5861]: Stopped D-Bus User Message Bus.

  9. #9

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    Bump. What does the "at-bus-launcher" do? Error window still opens each time I try to shut TW down . . . and then puts a timer on it . . . delaying the shut down, etc.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,178
    Blog Entries
    15

    Default Re: "at-bus-launcher not responding" error when trying to shut down????

    Quote Originally Posted by non_space View Post
    Bump. What does the "at-bus-launcher" do? Error window still opens each time I try to shut TW down . . . and then puts a timer on it . . . delaying the shut down, etc.
    Hi
    I think your missing a bit.. it's at-bus-spi-launcher...? Anyway do you have assistive technologies enabled in your desktop (at-spi2-core)?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •