Results 1 to 2 of 2

Thread: VNC desktop sharing doesn't work in home network with router

  1. #1
    Join Date
    Mar 2009
    Location
    Europe, CZ
    Posts
    57

    Default VNC desktop sharing doesn't work in home network with router

    I am trying to setup VNC desktop sharing within home network based on a common router. 2 Linux (OpenSUSE Leap 15.1) PCs are connected via LAN, a Windows Laptop and two Android tablets (and phones, etc.) via WLAN. All by means of Belkin router. I can't get it working and ran out of google and discussions based ideas how to resolve it. I am not network admin and might be doing something wrong or missing a configuration step.

    VNC is (only for the setting up process) without password, started this way:
    Code:
    x11vnc -clip 1280x800+0+0
    It seem to run well and shows:
    Code:
    The VNC desktop is:      linux-xxxxxxxxxxxx
    PORT=5900
    EDIT: Following is turned off due to some advices, because it is not relevant to *local* network. ~~~I tried to set my Belking router to forward IP, not sure if correctly, but it looks like this (192.168.0.105 is the Linux PC with VNC server):~~~

    I can PING the VNC server computer from any device (Android tablets, another Linux PC or Windows laptop) successfully. Also, Samba file sharing is working.

    In YaST (OpenSUSE's configuration tool), I set "Allow remote administration" and checked "Open firewall port" checkbox.

    Based on some threads, the problem could be in iptables or DNS (not pointing to router). However, I have no idea how to configure it properly for this use case in OpenSUSE.

    I used 4 different clients to avoid any trouble on this side (MultiVNC, AndroidVNC, VNC Viewer /all on Android/ and Easy Connect on Windows) setting the IP address of the Linux PC (192.168.0.105) and port 5900.
    My networking knowledge is very limited, basically to what is presented, so I am probably doing something incorrect or stupid... I don't even know how to analyze, whether is the shared desktop not reaching the router or if the router is blocking it.
    Last edited by malcolmlewis; 16-Feb-2020 at 07:49. Reason: Change font color.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,040
    Blog Entries
    2

    Default Re: VNC desktop sharing doesn't work in home network with router

    Start by setting up VNC server on your machine.
    There are various ways to set up depending on various needs... whether you want each remote client to connect as a different or shared session on your machine, more.

    The openSUSE LEAP documentation
    https://doc.opensuse.org/documentati...e/cha-vnc.html

    Post if you have further questions.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •