Results 1 to 3 of 3

Thread: Not able to recover the system with snapper

  1. #1

    Default Not able to recover the system with snapper

    Hi!
    I recently had my system broken trying to install spotify with spotify-install package from official OpenSuse repositories. The installation required libgcrypt.so.11()(64bit) package and I manually installed it.
    After that my system was no longer functional as the screen refreshing started to behave weirdly. I obviously resorted to recovery of the system using a snapshot. I've chosen a several pre-installation ones, but the each time I tried to boot from them, my problem didn't vanish. I had to completely reinstall my system from usb, as I needed the PC to be functional right then.
    Could someone please explain me why I was not able to eliminate the problem just booting from the snapshot? How can I protect myself from the future system failures if snapper doesn't seem to work?
    And perhaps someone can explain me additionally why libgcrypt.so.11()(64bit) broke my system in the first place?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,004
    Blog Entries
    2

    Default Re: Not able to recover the system with snapper

    Unknown why your system broke... Could you have installed a package for a different architecture?
    Also, some of these libcrypt errors are due to a naming convention problem, not actually a different version. These situations should be addressed by symlinking the expected name to the actual library name.

    As for recovering...
    Instead of pave and re-build, you might have been able to repair your system using a DVD image. A "repair" should re-install packages that were good when the DVD was released, so after a successful repair you would want to immediately update your systerm.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    129

    Default Re: Not able to recover the system with snapper

    A little bit off topic, Spotify runs perfectly in Firefox. I have run it that way for the last year or so. Other methods, including snap images, have been troublesome whenever there is an update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •