Results 1 to 10 of 10

Thread: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

  1. #1

    Question K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    Hi,

    I can no longer update via K.D.E.'s Discover application in Tumbleweed.
    Image of error is below:
    http://fallenangelsoftware.com/stuff...tUpdate-01.png

    It happened after installing my Epson WF-3520 printer using Epson website driver.
    Let me know how to fix this issue, thanks!

    Jesse

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    I have never tried Discover for updating. So perhaps my suggestion (below) is wrong.

    I would suggest using:
    Code:
    zypper up
    from a root command line. It should give more detailed error messages on the problem, and probably a conflict resolution dialog.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    Hi,

    Doing "zypper up" in console updated the system, but...
    ...there is still one update in K.D.E. Discover that is broken:

    Image of broken update:
    http://fallenangelsoftware.com/stuff/files/4Stuff/KDE-Discover-BadUpdate-01.png


    It looks like it wants to downgrade the Epson printer driver?
    Any ideas?
    (Epson printer works 100% in my Tumbleweed)

    Jesse

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    I should have suggested "zypper dup" at the command line.

    When you use "zypper up", it will skip packages with problem. If you use "zypper dup" it will usually give you a conflict resolution dialog. And that provides more information on what is going wrong.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    472

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    And, you can save yourself 3 keystrokes by not including the "." when writing KDE. It hasn't been using a "." in more than a decade.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  6. #6

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    Code:
    SortFastDesktop:/home/jlp # zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    Problem: problem with installed package epson-inkjet-printer-escpr-1.7.7-1lsb3.2.x86_64
     Solution 1: install epson-inkjet-printer-escpr-1.6.35-1.4.x86_64 (with vendor change)
      Seiko Epson Corporation  -->  openSUSE
     Solution 2: keep obsolete epson-inkjet-printer-escpr-1.7.7-1lsb3.2.x86_64
    
    Choose from above solutions by number or cancel [1/2/c/d/?] (c):

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    That shows the problem.

    It looks to me as if the installed version is actually the one you want to keep. My suggestion would be to lock that package, so that the package updater does not try to update.

    You can use Yast Software Management. Search for the package (probably "epson" will be a good enough search string to find it). Right click and select lock (or taboo whatever it is called).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    Thanks, that worked!

    Jesse

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    Quote Originally Posted by JeZ-l-Lee View Post
    Thanks, that worked!
    I'm glad to hear that.

    If you ever need to update that package, you may need to unlock it first then lock again after the update.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,759

    Default Re: K.D.E. Discover - Can't Update Anymore? Image Of Error Attached...

    My, very personal, advice would be to not use that Discover and/or the Update applet, but stick to YaST > Software management and/or zypper when managing software on openSUSE systems ( a have not installed PackageKit at all). Specialy on Tumbleweed where zypper dup is the way to update. I know that others now are emulating zypper dup, but hey, why not use the genuine one instead of hoping that the emulating is flawless?
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •