Results 1 to 4 of 4

Thread: [42.3] Certbot installation with ACMEv2

  1. #1

    Default [42.3] Certbot installation with ACMEv2

    Hello,
    I'm working on a 42.3 server and I want to get to HTTPS.
    After Certbot installation, it says that I need to use ACMEv2 now, ACMEv1 is not used anymore.
    The Certbot version is 0.15, it seems that to use ACMEv2 Certbot must be at least at 0.22... (in the configuratio file, putting
    Code:
    server = https://acme-v02.api.letsencrypt.org/directory
    gives the error :
    Code:
    Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
    An unexpected error occurred:
    KeyError: 'Directory field not found'
    Please see the logfiles in /var/log/certbot for more details.
    I'm not good at managing servers, so I would like to ask you : is there a way to get a updated version of Certbot ?
    I have downloaded the 0.30 version on github, but I try to install it via pip it says that my version of pip is too old of course :
    Code:
    You are using pip version 7.1.2, however version 20.0.2 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    So, do you think using Certbot on a 42.3 is possible (and how ), please ?
    And if finally not possible, do you know another ACME client that I could use on the 42.3 ?

    Thank you in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    26,922

    Default Re: [42.3] Certbot installation with ACMEv2

    I have no idea about this particular subject, but I hope you are aware of the fact that 42.3 is old and long out of support. Thus I assume that
    • not many people here will be able to try out things on there own system;
    • not much newer software will install without problems on such an old openSUSE version.


    I assume you have a reason to think your system is save from attacks from the Internet even if it is not updated with the security patches needed, but such a frozen system, while very stable, should be realy frozen. No new/updated software, no new functionality added, etc.
    Henk van Velden

  3. #3

    Default Re: [42.3] Certbot installation with ACMEv2

    Even if it's another subjetc, I agree with wht you say, obviously.
    It's not always easy to update servers that are in production but it will be made this year, I hope.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,589
    Blog Entries
    2

    Default Re: [42.3] Certbot installation with ACMEv2

    Quote Originally Posted by jska View Post
    Hello,
    I'm working on a 42.3 server and I want to get to HTTPS.
    After Certbot installation, it says that I need to use ACMEv2 now, ACMEv1 is not used anymore.
    The Certbot version is 0.15, it seems that to use ACMEv2 Certbot must be at least at 0.22... (in the configuratio file, putting
    Code:
    server = https://acme-v02.api.letsencrypt.org/directory
    gives the error :
    Code:
    Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
    An unexpected error occurred:
    KeyError: 'Directory field not found'
    Please see the logfiles in /var/log/certbot for more details.
    I'm not good at managing servers, so I would like to ask you : is there a way to get a updated version of Certbot ?
    I have downloaded the 0.30 version on github, but I try to install it via pip it says that my version of pip is too old of course :
    Code:
    You are using pip version 7.1.2, however version 20.0.2 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    So, do you think using Certbot on a 42.3 is possible (and how ), please ?
    And if finally not possible, do you know another ACME client that I could use on the 42.3 ?

    Thank you in advance.
    After adding my voice to that you really, really need to consider upgrading your server ASAP which could mean contracting help to at the minimum evaluate the cost and complexity (without actually doing the upgrade yet),

    AFAIK on your specific problems...
    Your pip can easily be upgraded by simply using pip to download and install a newer pip using the command you quoted. That's not an unusual message because it displays because even the most current pip from openSUSE is almost always much older than whatever is in the PyPi repos.

    It'd be problematic upgrading your certbot by any means for such an old, upsupported version of LEAP (or any other old, unsupported version of anything)
    But, I'd recommend following the recommended steps to download and install the latest current certbot for Apache running on LEAP 15.1 at

    https://certbot.eff.org/

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •