Hello,
I'm working on a 42.3 server and I want to get to HTTPS.
After Certbot installation, it says that I need to use ACMEv2 now, ACMEv1 is not used anymore.
The Certbot version is 0.15, it seems that to use ACMEv2 Certbot must be at least at 0.22... (in the configuratio file, putting
Code:
server = https://acme-v02.api.letsencrypt.org/directory
gives the error :
Code:
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
An unexpected error occurred:
KeyError: 'Directory field not found'
Please see the logfiles in /var/log/certbot for more details.
I'm not good at managing servers, so I would like to ask you : is there a way to get a updated version of Certbot ?
I have downloaded the 0.30 version on github, but I try to install it via pip it says that my version of pip is too old of course :
Code:
You are using pip version 7.1.2, however version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
So, do you think using Certbot on a 42.3 is possible (and how ), please ?
And if finally not possible, do you know another ACME client that I could use on the 42.3 ?

Thank you in advance.