As the title says. Some info:

GeForce 1650 with nvidia driver G05and dual 4K 60Hz monitors (DisplayPort 1.4 and HDMI 2.0b)

Enable/disable effects with ALT+SHIFT+F12.

systemsettings>Display>Compositor settings are:
- fast animation speed,
- Precise scale method,
- OpenGL2 infrastructure (I had issues some time ago with OpenGL 3.1, IIRC),
- tearing prevention (vsync) in automatic mode.

Tearing occurs with mpv, vlc and browser videos (youtube, netflix, etc).

NVIDIA Xserver settings:

- Forcing any combination of pipeline composition advanced options make no difference.
- X Server XVideo Settings > Sync to this device is set to Auto, device is HDMI monitor (DP monitor is the primary display)
- Sync to vblank is enabled in openGL settings

OMG, Newbie mistake. The HDMI monitor was set to 30Hz in nvidia-settings. Changed to 60 Hz (supported by the 2.0b cable, else only 30Hz), and no tearing with effects enabled. I've temporarily connected this monitor to another box, probably the cable version was < 2.0b and the driver downgraded the frequency.

It's true that, many times, just collecting accurate info about the problem lead to the solution. I think this is one of those occasions .

I'll leave this post here for future reference.

Edit: The title should have started with[SOLVED], but it can't be edited. Sorry about that.