Results 1 to 5 of 5

Thread: how to disable auto-copy to clipboard in openbox

  1. #1

    Default how to disable auto-copy to clipboard in openbox

    Hi, I use openbox on a headless server and PCManFM as "icon manager", so I can see icons on desktop(s). Everything is fine, except whenever I select any text anywhere (geany, pcmanfm, xterminal...), it automatically overwrites what I have in clipboard with the selection. I don't use any clipboard managager (and I don't want to), just the clipboard which is built in X (or openbox?), which works just fine, except the described annoying feature.

    I want to achieve normal cliboard behaviour, i.e. not to copy until I press ctrl-insert (or ctrl+c, or right-click and select copy). I tried to experiment with XTerm*selectToClipboard: false in ~..Xresources, but it does not have effect and I have not found any other option affecting clipboard either.

    If someone knows something, please help. Thank you.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: how to disable auto-copy to clipboard in openbox

    I don't think xterm will do what you want.

    X uses two buffers. There's a select buffer and there's the clipboard. In my experience, xterm only uses the select buffer, and pastes from that with middle-click. Maybe try a different terminal application. Your browser puts into the clipboard with CTRL-C and pastes fromt here with CTRL-V.

    Konsole uses CTRL-SHIFT-C to put in clipboard and CTRL-SHIFT-V to paste.

    Personally, I mostly use xterm. But occasionally things don't work the way that I want, because of those differences. If I use Konsole, I have more control over copy/paste.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,844
    Blog Entries
    2

    Default Re: how to disable auto-copy to clipboard in openbox

    Although @nrickert describes xterm accurately (except that I think the buffer is called the "cut buffer) in that unless you install a clipboard manager xterm will not share its clipboard with the clipboard all other apps generally use.

    But,
    The behavior you describe has been described before in openbox, so I wonder if this default behavior might be specific to openbox... I haven't noticed this before but maybe also haven't been looking for this issue.

    In any case,
    An old solution might still apply at least for xterm...

    From
    https://unix.stackexchange.com/quest...t-auto-copying

    See if the following entry or something like it that might apply to the regular clipboard is in

    .xprofile
    Code:
    autocutsel -selection PRIMARY -fork
    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4

    Default Re: how to disable auto-copy to clipboard in openbox

    Thanks guys, the x-terminal behaviour worries me least of all, I'm talking about the behaviour of the whole desktop environment. Whatever I select or what gets autoselected, it gets copied. It is so annoying. Say I want to create new folder in pcmanfm, so I press ctrl+shift+n to create new folder, a windows with "New" popups, but this New is autoselected, so this "New" gets autocopied into the clipboard and I cannot paste a name from clipboard, I cannot paste one text over another, I cannot use clipboard in a usual way. I love openbox, I can switch desktops using alt+mouse scroll, but the clipboard really eats me

    TSU, I found that article too, but it uses additional clipoard manager, which needs to be installed, maybe it could work, but this is not what I am after. I used openbox because it needs only few megabytes of ram and disk and I have fully working graphic enviroment via VNC, I can run remotely firefox or whatever, but I'm trying to avoid dependncies here and there, as the redundant clipboard manager, when one is already built in, only behaves oddly. If I will go the easy way, sooner or later instead of a few megabytes on disk and ram I will have a hungry beast. I don't even hav taskbar, because I don't need it, when I can swap desktops, or switch between running apps using middle mouse button. I don't want to waste resources on a headless machine.

    So there isn't a config file for built in clipboard management in openbox (or X)? When I select something, system does not copy it at once, but waits like 250ms and then it copies it into cliboard, I fail to believe that this timeout cannot be configured somewhere.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,844
    Blog Entries
    2

    Default Re: how to disable auto-copy to clipboard in openbox

    I'm pretty sure a clipboard manager isn't a standard feature in any WM (or at least I haven't seen it).
    Out of curiosity, unless you expressly removed IceWM, it should still be installed in your system (It's a standard part of almost every openSUSE install I've seen regardless of architecture, DE (or not)). If it's still on your system, you could logout and back in choosing it and see if you still have that auto-selection issue.

    I've also experimented a bit with
    fluxbox, fvm2, twm, sway, xfwm4

    But there are many others in the openSUSE repos... There used to be a way to list most of them in the same package group, today you might search "window manager" in the YaST Software Manager.

    OpenBox might be preferred, but if it doesn't suit your needs, there are others you can experiment with as well.
    IceWM seems to be as close to a full DE as possible without actually being a full DE.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •