Results 1 to 7 of 7

Thread: Choqok-1.7.0 KDE Extra Conflict

  1. #1
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    176

    Default Choqok-1.7.0 KDE Extra Conflict

    Choqok is a micro-blogging client for KDE with Twitter integration. I find it useful.
    Version 1.6 (2016) is available in openSUSE repos but Twitter integration is broken since Twitter changed their micro-blog character limit from 140 to 280.
    Choqok version 1.7 updates the Twitter character limit to 280, among other things.
    choqok-1.7.0 has been kindly made available in openSUSE Leap 15.1 KDE Extra repo, but there is a conflict.
    Code:
    #### YaST2 conflicts list - generated 2020-02-11 13:50:23 ####
    nothing provides libQt5Core.so.5(Qt_5.14)(64bit) needed by choqok-1.7.0-lp151.37.3.x86_64
        [ ] break choqok-1.7.0-lp151.37.3.x86_64 by ignoring some of its dependencies
        [ ] do not install choqok-1.7.0-lp151.37.3.x86_64
    #### YaST2 conflicts list END ###
    Seems libQt5Core.so.5(Qt_5.14)(64bit) is available in Tumbleweed repo rpmfind.
    A bug report was posted here.
    Is this conflict resolvable by user. If so, how?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: Choqok-1.7.0 KDE Extra Conflict

    Maybe check the repos listed here:

    SDB:KDE repositories
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: Choqok-1.7.0 KDE Extra Conflict

    Actually, you might only need to switch system packages to the KDE Extra repo.

    Try:

    Code:
    zypper dup --from "name-of-kde-extra-repo" --allow-vendor-change
    Change the quoted string to the appropriate name you are using for that repo.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    176

    Default Re: Choqok-1.7.0 KDE Extra Conflict

    Quote Originally Posted by nrickert View Post
    Maybe check the repos listed here: SDB:KDE repositories
    Actually, you might only need to switch system packages to the KDE Extra repo.
    Thanks nrickert. SDB page looks interesting. May help. Lots to learn.

    Switching system packages generated same conflict for all relevant KDE Exra packages:
    "nothing provides libQt5Core.so.5(Qt_5.14)(64bit)". Fortunatly there were only a few.

    I'm curious, and others may wish to know.
    Is this expected for KDE Extra? Are the KDE repositories a prerequisite for KDE Extra?

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,844
    Blog Entries
    2

    Default Re: Choqok-1.7.0 KDE Extra Conflict

    If you install something from the KDE:Extra repo,
    That package may reasonably require a later Qt framework which would be provided by one of the Qt Framework repos.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    176

    Default Re: Choqok-1.7.0 KDE Extra Conflict [SOLVED]

    I made an error mixing KDE:Extra repositories. I failed to check (!) and attempted to install from:
    Code:
    URL: https://download.opensuse.org/repositories/KDE:/Extra/KDE_Applications_openSUSE_Leap_15.1/
    Hence conflict.

    With kind advice from bugziller.opensuse I now know I should have used:
    Code:
    URL: http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_15.1/
    Hence installed Choqok 1.7.0 with no dependencies.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,172
    Blog Entries
    3

    Default Re: Choqok-1.7.0 KDE Extra Conflict

    I'm glad it is now working.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •