Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: mount command not working

  1. #11
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    128

    Default Re: mount command not working

    nfs4 is the correct type to use for version 4, otherwise use nfs

    https://doc.opensuse.org/documentati...ng-nfs-clients

  2. #12

    Default Re: mount command not working

    Here is what happens:
    Code:
    linux-4skc:~ # mount -t nfs -v 192.168.2.2:/mnt/md1/ulimnt /home/uli/ulimnt
    mount.nfs: timeout set for Mon Feb 10 12:52:55 2020
    mount.nfs: trying text-based options 'vers=4.2,addr=192.168.2.2,clientaddr=192.168.2.59'
    mount.nfs: mount(2): Protocol not supported
    mount.nfs: trying text-based options 'vers=4,minorversion=1,addr=192.168.2.2,clientaddr=192.168.2.59'
    mount.nfs: mount(2): Protocol not supported
    mount.nfs: trying text-based options 'vers=4,addr=192.168.2.2,clientaddr=192.168.2.59'
    mount.nfs: mount(2): Protocol not supported
    mount.nfs: trying text-based options 'addr=192.168.2.2'
    mount.nfs: prog 100003, trying vers=3, prot=6
    mount.nfs: trying 192.168.2.2 prog 100003 vers 3 prot TCP port 2049
    mount.nfs: prog 100005, trying vers=3, prot=17
    mount.nfs: trying 192.168.2.2 prog 100005 vers 3 prot UDP port 933
    I just use nfs and it starts trying from v4.2 downwards

  3. #13
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    128

    Default Re: mount command not working

    Interesting. I am using autofs and used nfs for version 3 mounts. It recently stopped working so I switched to 'nfs4' with the NAS nfs4 mount point and everything worked.

    I did come across the following document on specifying nfs in fstab and it explains what you are seeing on the command line.

    https://www.systutorials.com/docs/linux/man/5-nfs/

    Specifically, "The fstype field contains "nfs". Use of the "nfs4" fstype in /etc/fstab is deprecated." and

    nfsvers=n
    The NFS protocol version number used to contact the server's NFS service. If the server does not support the requested version, the mount request fails. If this option is not specified, the client negotiates a suitable version with the server, trying version 4 first, version 3 second, and version 2 last.

  4. #14
    Join Date
    Sep 2012
    Posts
    5,318

    Default Re: mount command not working

    Quote Originally Posted by fuerstu View Post
    Is there a way to have the mount command using NFSv3 only that it does not try v 4.2, 4.1, 4.0 before mounting with the v3?
    Code:
    mount -o vers=3 ...
    man 5 nfs

  5. #15

    Default Re: mount command not working

    Quote Originally Posted by arvidjaar View Post
    Code:
    mount -o vers=3 ...
    man 5 nfs
    I thought that applies only for the fstab file

  6. #16

    Default Re: mount command not working

    OK arvidjaar, I tried it out and you are correct:
    Code:
    linux-4skc:~ # mount -v -t nfs -o vers=3 192.168.2.2:/mnt/md1/ulimnt /home/uli/ulimnt
    mount.nfs: timeout set for Mon Feb 10 17:53:17 2020
    mount.nfs: trying text-based options 'vers=3,addr=192.168.2.2'
    mount.nfs: prog 100003, trying vers=3, prot=6
    mount.nfs: trying 192.168.2.2 prog 100003 vers 3 prot TCP port 2049
    mount.nfs: prog 100005, trying vers=3, prot=17
    mount.nfs: trying 192.168.2.2 prog 100005 vers 3 prot UDP port 933
    linux-4skc:~ #
    Thank you.

  7. #17
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,759

    Default Re: mount command not working

    Quote Originally Posted by fuerstu View Post
    I thought that applies only for the fstab file
    There is a direct relation between the -o option in the mount command and the options field in the fstab. Remember that fstab is in fact only a configuration file for the mount command.
    Henk van Velden

  8. #18
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,759

    Default Re: mount command not working

    Quote Originally Posted by fuerstu View Post
    I am not sure about this:
    Code:
    uli@linux-4skc:~> man nfs4
    No manual entry for nfs4
    But with the next backup I will try with the verbose command. Thanks hcvv
    Hm, it is a bit late reaction, but nobody talked about
    Code:
    man nfs4
    It is
    Code:
    man nfs
    and that will inform you about the versions.

    BUT, my information is outdated, as you will have found out now through the other posts here.
    It is no more the type nfs vs. nfs4, but type nfs and the nfsvers= option.
    Yes, things change faster then light.
    But when you use YaST > Network Services > NFS Client, you will see that the version is to be filled in and I assume the correct fstab entry will be created.
    Henk van Velden

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •